root/gs2-extensions/gnome-lib/branches/macos-dev/src/packages/CASCADE-MAKE/GLIB.sh @ 34350

Revision 34350, 2.6 KB (checked in by davidb, 6 weeks ago)

Changes to allow gnome-lib extension to compile on Macrocarpa (MacOS)

  • Property svn:executable set to *
Line 
1#!/bin/bash
2
3# glib2.28.1 was modified for Greenstone to allow compilation to succed on a Mac, so it has acquired a 'gs-' prefix
4# More recently compiling on Macrocarpa (MacOS) newer compilation errors were encountered,
5# prompting a signficant bump up in version number
6
7#package=gs-glib
8package=glib
9#version=-2.24.2
10#version=-2.28.1
11##version=-2.34.3
12version=-2.54.3
13
14progname=$0
15
16source ../cascade-make/lib/cascade-lib.bash GEXTGNOME ../.. $*
17
18prefix=$GEXTGNOME_INSTALLED
19
20export CFLAGS="$CFLAGS -I$GEXTGNOME_INSTALLED/include"
21export CPPFLAGS="$CPPFLAGS -I$GEXTGNOME_INSTALLED/include"
22export CXXFLAGS="$CXXFLAGS -I$GEXTGNOME_INSTALLED/include"
23export LDFLAGS="$LDFLAGS -L$GEXTGNOME_INSTALLED/lib"
24
25if [ "x$crossOS" = "xandroid" ] ; then
26  # Based on details found at:
27  #   http://axcoto.com/blog/article/836
28  extra_config_args="glib_cv_stack_grows=${glib_cv_stack_grows=no} glib_cv_uscore=${glib_cv_uscore=no} ac_cv_func_posix_getpwuid_r=${ac_cv_func_posix_getpwuid_r=no} ac_cv_func_posix_getgrgid_r=${ac_cv_func_posix_getgrgid_r=no}"
29
30  # Not clear how many of the following are needed.
31  # List came from:
32  #  https://mail.gnome.org/archives/gtk-devel-list/2011-March/msg00096.html
33  #
34  # Could be that some of these are helpful in general (i.e. move out to
35  #   main section of this script) in making a more minimal glib
36
37  extra_config_args="--without-included-regex --disable-java --disable-openmp --without-libiconv-prefix --without-libintl-prefix --without-libglib-2.0-prefix --without-libcroco-0.6-prefix --with-included-libxml --without-libncurses-prefix --without-libtermcap-prefix --without-libcurses-prefix --without-libexpat-prefix --without-emacs $extra_config_args"
38
39
40else
41  extra_config_args=
42fi
43
44opt_run_untar $force_untar $auto_untar $package $version
45opt_run_configure $force_config $auto_config $package $version $prefix \
46  --disable-shared --enable-static --disable-dtrace --disable-systemtap $extra_config_args
47
48# In the above ...
49# Linking error can occur when compiling due to mix of wanting static libraries built
50# and 'dtrace' and 'systemtap' being present on the underlying linux system
51# Details relating to the linking error disucssed at:
52#    https://gitlab.gnome.org/GNOME/glib/issues/653
53# Since we don't want to move to a newer version of the the gslib library (at this stage)
54# the workaround is to add in:
55#    --disable-dtrace and --disable-systemtap in
56
57opt_run_make $compile $package $version
58opt_run_make $install $package $version "install"
59opt_run_make $clean $package $version "clean"
60opt_run_make $distclean $package $version "distclean"
61
62opt_run_tarclean $tarclean $package $version
Note: See TracBrowser for help on using the browser.