root/gs2-extensions/gsdl-amp/trunk/packages/CASCADE-MAKE/APACHE.sh @ 22242

Revision 22242, 0.7 KB (checked in by sjm84, 10 years ago)

Added an ant build file and made several other minor fixes

  • Property svn:executable set to *
Line 
1#!/bin/bash
2
3package=httpd
4version=-2.2.15
5
6progname=$0
7
8source ../cascade-make/lib/cascade-lib.bash
9
10prefix=$GEXTAMP_INSTALLED
11
12if [ $COMPILE_UP_APACHE_HTTPD = "1" ] ; then
13  opt_run_untar $force_untar $auto_untar $package $version
14  opt_run_configure $force_config $auto_config $package $version $prefix --with-layout=Apache --enable-so
15
16  opt_run_make $compile   $package $version
17  opt_run_make $install   $package $version "install"
18  opt_run_make $clean     $package $version "clean"
19  opt_run_make $distclean $package $version "distclean"
20
21  opt_run_tarclean $tarclean $package $version
22else
23  echo "Using Apache HTTPD that is provided externally to the extension at:"
24  echo "  $APACHE_HTTPD_HOME"
25  echo ""
26fi
Note: See TracBrowser for help on using the browser.