root/gs2-extensions/parallel-building/trunk/src/bin/script/perl-version.pl @ 27052

Revision 27052, 285 bytes (checked in by jmt12, 7 years ago)

Turns out the Perl on Medusa doesn't support $V, so I've had to change this script to find other ways of extracting perls version number

  • Property svn:executable set to *
Line 
1#!/usr/bin/perl
2my $version_str = $^V;
3if (defined $version_str && $version_str =~ /(\d+\.\d+\.\d+)/)
4{
5  print $1;
6  exit;
7}
8$version_str = $];
9if (defined $version_str && $version_str =~ /(\d+)\.(\d\d\d)(\d\d\d)/)
10{
11  printf("%d.%d.%d", $1, $2, $3);
12  exit;
13}
14print "unknown";
15exit;
Note: See TracBrowser for help on using the browser.