root/gs2-extensions/parallel-building/trunk/src/src/CASCADE-MAKE/HADOOPGREENSTONEINGEST.sh @ 30290

Revision 30290, 0.7 KB (checked in by jmt12, 5 years ago)

Extended build script to make Hadoop support optional. If no HADOOP_VERSION set in environment then HadoopGreenstoneIngest? not built.

  • Property svn:executable set to *
Line 
1#!/bin/bash
2
3package=HadoopGreenstoneIngest
4version=
5
6progname=$0
7
8source ../cascade-make/lib/cascade-lib.bash GEXTPARALLELBUILDING ../.. $*
9
10prefix=$GEXTPARALLELBUILDING_INSTALLED
11
12# Can't build HadoopGreenstoneIngest without Greenstone
13if [ "${HADOOP_VERSION}x" != "x" ]
14then
15    rm ${GEXTPARALLELBUILDING_INSTALLED}/lib/hadoop-greenstone.jar
16    pushd ${GEXTPARALLELBUILDING}/src/java/org/nzdl/gsdl/
17    rm -rf hgi_classes
18    mkdir hgi_classes
19    javac -cp $HADOOP_PREFIX/hadoop-core-$HADOOP_VERSION.jar -d hgi_classes *.java
20    jar -cvf $GEXTPARALLELBUILDING_INSTALLED/lib/hadoop-greenstone.jar -C hgi_classes/ .
21    popd
22else
23    echo "No Hadoop version specified... skipping!"
24fi
Note: See TracBrowser for help on using the browser.