source: main/trunk/package-kits/linux/managers/pacman/PKGBUILD@ 29508

Last change on this file since 29508 was 29508, checked in by Jeremy Symon, 9 years ago

Makefile generater now also generates package manager scripts. Generated scripts are tested and working on Arch

File size: 511 bytes
Line 
1# Maintainer: Greenstone Team <[email protected]>
2pkgname=@NAME@
3pkgver=@VERSION@
4pkgrel=@RELEASE@
5pkgdesc=@DESCRIPTION@
6url=@HOMEPAGE@
7arch=(@ARCHITECTURE@)
8license=(@LICENSE_SHORT@)
9depends=(@DEPENDS@)
10optdepends=(@OPTDEPENDS@)
11makedepends=(@MAKEDEPENDS@)
12provides=(@PROVIDES@)
13# conflicts=()
14# replaces=()
15# backup=()
16# install=''
17source=(@SOURCES@
18)
19md5sums=(@SOURCE_SUMS@
20)
21
22build() {
23 cd ${srcdir}
24 make build
25}
26
27package() {
28 DESTDIR=${pkgdir} make install
29}
30
31# vim:expandtab:ts=2:sw=2:
Note: See TracBrowser for help on using the repository browser.