Changeset 25958

Show
Ignore:
Timestamp:
17.07.2012 15:18:36 (7 years ago)
Author:
kjdon
Message:

pass gs_version to loading plugins

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/greenstone2/perllib/basebuilder.pm

    r24754 r25958  
    174174    } 
    175175 
    176  
     176    # gs_version for plugins 
     177    my $gs_version = "2"; 
     178    if ($gs_mode eq "gs3") { 
     179    $gs_version = "3"; 
     180    } 
    177181    # get the list of plugins for this collection 
    178182    my $plugins = []; 
     
    188192    push @global_opts, "-separate_cjk"; 
    189193    } 
    190     $self->{'pluginfo'} = &plugin::load_plugins ($plugins, $self->{'verbosity'}, $outhandle, $failhandle, \@global_opts, $self->{'incremental_mode'}); 
     194    $self->{'pluginfo'} = &plugin::load_plugins ($plugins, $self->{'verbosity'}, $outhandle, $failhandle, \@global_opts, $self->{'incremental_mode'}, $gs_version); 
    191195    
    192196    if (scalar(@{$self->{'pluginfo'}}) == 0) {