Show
Ignore:
Timestamp:
07.07.2013 17:45:33 (6 years ago)
Author:
davidb
Message:

Adjustment to ant files that copy in the XML-Parser files necessary for specific version of Perl (for linux). Perl 5.14 added

Location:
main/trunk/release-kits/kits
Files:
2 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/release-kits/kits/rk2/ant-scripts/compile.xml

    r27731 r27769  
    278278                </copy> 
    279279            </if> 
     280 
     281            <!-- Add the 5.14 version if necessary --> 
     282            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.14"/></not></bool> 
     283                <copy todir="${basedir}/compiled/perllib/cpan"> 
     284                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.14,perl-5.14/**/*"/> 
     285                </copy> 
     286            </if> 
    280287        </if> 
    281288 
  • main/trunk/release-kits/kits/rk3/ant-scripts/compile.xml

    r27731 r27769  
    105105        </if> 
    106106 
    107         <!-- insert an xml parser --> 
     107        <!-- insert an xml parser (matched to the version of Perl being used by the release kit) --> 
    108108        <copy todir="compiled/gs2build/perllib/cpan"> 
    109109            <fileset dir="${rk.home}/shared/linux" includes="XML-Parser/**/*"/> 
    110110        </copy> 
     111 
     112        <!-- insert the necessary additional xml parser versions --> 
     113        <if><bool><equals arg1="${rk.os}" arg2="linux"/></bool> 
     114            <!-- Add the 5.6 version if necessary --> 
     115            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.6"/></not></bool> 
     116                <copy todir="${basedir}/compiled/perllib/cpan"> 
     117                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.6,perl-5.6/**/*"/> 
     118                </copy> 
     119            </if> 
     120             
     121            <!-- Add the 5.8 version if necessary --> 
     122            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.8"/></not></bool> 
     123                <copy todir="${basedir}/compiled/perllib/cpan"> 
     124                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.8,perl-5.8/**/*"/> 
     125                </copy> 
     126            </if> 
     127             
     128            <!-- Add the 5.8 mutlithreaded version if necessary --> 
     129            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.8-mt"/></not></bool> 
     130                <copy todir="${basedir}/compiled/perllib/cpan"> 
     131                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.8-mt,perl-5.8-mt/**/*"/> 
     132                </copy> 
     133            </if> 
     134             
     135            <!-- Add the 5.10 version if necessary --> 
     136            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.10"/></not></bool> 
     137                <copy todir="${basedir}/compiled/perllib/cpan"> 
     138                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.10,perl-5.10/**/*"/> 
     139                </copy> 
     140            </if> 
     141 
     142            <!-- Add the 5.14 version if necessary --> 
     143            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.14"/></not></bool> 
     144                <copy todir="${basedir}/compiled/perllib/cpan"> 
     145                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.14,perl-5.14/**/*"/> 
     146                </copy> 
     147            </if> 
     148        </if> 
     149 
    111150 
    112151        <!-- insert ant -->