Changeset 28828 for gs2-extensions

Show
Ignore:
Timestamp:
04.02.2014 16:29:26 (6 years ago)
Author:
ak19
Message:

CUPS.sh needs disable-gssapi in order to compile CUPS on Mac Maverick (Darwin v13).

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • gs2-extensions/gnome-lib/trunk/src/packages/CASCADE-MAKE/CUPS.sh

    r28286 r28828  
    1717export LDFLAGS="$LDFLAGS -L$GEXTGNOME_INSTALLED/lib" 
    1818 
     19opt_config_args= 
     20this_os=`uname` 
     21osversion=`uname -r | sed 's/\..*$//'`; 
     22if [ "x$this_os" = "xDarwin" -a $osversion -ge 13 ] ; then 
     23    opt_config_args=--disable-gssapi 
     24fi 
     25 
    1926opt_run_untar $force_untar $auto_untar $package $version ".tar.bz2" 
    2027 
    2128opt_run_configure $force_config $auto_config $package $version $prefix \ 
    22   --disable-launchd --datarootdir=$GEXTGNOME_INSTALLED/etc --with-bundledir=$GEXTGNOME_INSTALLED/etc --with-rcdir=$GEXTGNOME_INSTALLED/etc 
     29  --disable-launchd --datarootdir=$GEXTGNOME_INSTALLED/etc --with-bundledir=$GEXTGNOME_INSTALLED/etc --with-rcdir=$GEXTGNOME_INSTALLED/etc $opt_config_args 
    2330 
    2431opt_run_make $compile $package $version