Changeset 30290

Show
Ignore:
Timestamp:
09.10.2015 13:30:39 (4 years ago)
Author:
jmt12
Message:

Extended build script to make Hadoop support optional. If no HADOOP_VERSION set in environment then HadoopGreenstoneIngest? not built.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • gs2-extensions/parallel-building/trunk/src/src/CASCADE-MAKE/HADOOPGREENSTONEINGEST.sh

    r27912 r30290  
    1010prefix=$GEXTPARALLELBUILDING_INSTALLED 
    1111 
    12 rm ${GEXTPARALLELBUILDING_INSTALLED}/lib/hadoop-greenstone.jar 
    13 pushd ${GEXTPARALLELBUILDING}/src/java/org/nzdl/gsdl/ 
    14 rm -rf hgi_classes 
    15 mkdir hgi_classes 
    16 javac -cp $HADOOP_PREFIX/hadoop-core-$HADOOP_VERSION.jar -d hgi_classes *.java 
    17 jar -cvf $GEXTPARALLELBUILDING_INSTALLED/lib/hadoop-greenstone.jar -C hgi_classes/ . 
    18 popd 
     12# Can't build HadoopGreenstoneIngest without Greenstone 
     13if [ "${HADOOP_VERSION}x" != "x" ] 
     14then 
     15    rm ${GEXTPARALLELBUILDING_INSTALLED}/lib/hadoop-greenstone.jar 
     16    pushd ${GEXTPARALLELBUILDING}/src/java/org/nzdl/gsdl/ 
     17    rm -rf hgi_classes 
     18    mkdir hgi_classes 
     19    javac -cp $HADOOP_PREFIX/hadoop-core-$HADOOP_VERSION.jar -d hgi_classes *.java 
     20    jar -cvf $GEXTPARALLELBUILDING_INSTALLED/lib/hadoop-greenstone.jar -C hgi_classes/ . 
     21    popd 
     22else 
     23    echo "No Hadoop version specified... skipping!" 
     24fi