Show
Ignore:
Timestamp:
01.08.2017 19:29:36 (2 years ago)
Author:
ak19
Message:

Dr Bainbridge got openssl 1.0.2 compiling successfully on Mac 64 bit, after which wget compiled successfully against our openSSL.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/greenstone2/build-src/packages/configure

    r31834 r31835  
    173173# into $bindir/openssl for wget to use, since wget is built against openssl's 
    174174# static libraries and therefore wget doesn't need these when running. 
    175 echo ./config --prefix=$PACKAGES/openssl --openssldir=$PACKAGES/openssl no-shared 
    176 ./config --prefix=$PACKAGES/openssl --openssldir=$PACKAGES/openssl no-shared 
     175 
     176# for 64 bit Macs, need to run ./Configure with darwin64-x86_64-cc, rather than ./config 
     177# To overcome an error in openssl's perl script determining the LLVM version, we also need force the 
     178# compilers to be GNU since Clang comes back with an LLVM version that doesn't work out 
     179stored_CC=$CC 
     180stored_CXX=$CXX 
     181if [[ "x$GSDLOS" == "xdarwin" ]] && [[ `uname -m` == *"64" ]] ; then 
     182    export CC="gcc" 
     183    export CXX="g++" 
     184    echo ./Configure --openssldir=$PACKAGES/openssl no-shared darwin64-x86_64-cc 
     185    #CC="gcc" CXX="g++" ./Configure --openssldir=$PACKAGES/openssl no-shared darwin64-x86_64-cc 
     186    ./Configure --openssldir=$PACKAGES/openssl no-shared darwin64-x86_64-cc 
     187else 
     188    echo ./config --prefix=$PACKAGES/openssl --openssldir=$PACKAGES/openssl no-shared 
     189    ./config --prefix=$PACKAGES/openssl --openssldir=$PACKAGES/openssl no-shared 
     190fi 
    177191# make 
    178192echo make 
     
    181195echo make install 
    182196make install 
     197# restore the compile flags 
     198export CC=$stored_CC 
     199export CXX=$stored_CXX 
    183200 
    184201# now move the include, lib and bin folders to the correct place 
     
    259276fi 
    260277 
     278# On darwin, the wget binary that we build (in $GSDLHOME/bin/$GSDLOS/wget)  
     279# finds a system libiconv, as you'll notice when you run "otool -L wget" 
     280# That's because we expressly don't compile up libiconv on Macs anymore, 
     281# as the Mac system will have the right libiconv installed. 
     282 
    261283# configure wget 
    262284wget_pkgname=wget-1.15-gs 
     
    278300 
    279301# We weren't compiling up wget statically before either and we still aren't 
    280 # However, to compile up wget (statically or not) with openssl, see 
     302# However, to compile up wget (statically or not) with openssl, as we do now to support retrieving from https urls, see 
    281303# https://stackoverflow.com/questions/9817337/compiling-wget-with-static-linking-self-compiled-openssl-library-linking-issu 
    282304# Note: contrary to the instructions at the link, if the cppflags and ldflags are set during the 
     
    289311 
    290312# for wget-1.15-gs. (can also try adding --localstatedir="$bindir/wget" --enable-iri) 
    291 echo CPPFLAGS="-I$PACKAGES/openssl/include" LDFLAGS="-L$PACKAGES/openssl/lib" ./configure $CACHE_FILE --prefix=$PACKAGES/wget --with-ssl=openssl --bindir="$bindir" -disable-nls $HOSTTARGETFLAGS $wget_extraarg 
     313echo CPPFLAGS="-I$PACKAGES/openssl/include $CPPFLAGS" LDFLAGS="-L$PACKAGES/openssl/lib $LDFLAGS" ./configure $CACHE_FILE --prefix=$PACKAGES/wget --with-ssl=openssl --bindir="$bindir" -disable-nls $HOSTTARGETFLAGS $wget_extraarg 
    292314cd "$PACKAGES/wget/$wget_pkgname" && \ 
    293 CPPFLAGS="-I$PACKAGES/openssl/include" LDFLAGS="-L$PACKAGES/openssl/lib" ./configure $CACHE_FILE --prefix=$PACKAGES/wget --with-ssl=openssl --bindir="$bindir" -disable-nls $HOSTTARGETFLAGS $wget_extraargs 
     315CPPFLAGS="-I$PACKAGES/openssl/include $CPPFLAGS" LDFLAGS="-L$PACKAGES/openssl/lib $LDFLAGS" ./configure $CACHE_FILE --prefix=$PACKAGES/wget --with-ssl=openssl --bindir="$bindir" -disable-nls $HOSTTARGETFLAGS $wget_extraargs 
    294316 
    295317# for wget-1.17.1-gs. (can also try adding --localstatedir="$bindir/wget" --enable-iri)