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Making PDF Accessible with Adobe Acrobat 9 Pro
Introduction

PDF Accessibility

A document or application is accessible if it can be used by people with disabilities—such as mobility 

impairments, blindness, and low vision—and not just by people who can see well and use a mouse. 

Accessibility features in Adobe Acrobat, Adobe Reader, and Adobe Portable Document Format (PDF) make 

it easier for people with disabilities to use PDF documents and forms, with or without the aid of assistive 

software and devices such as screen readers, screen magnifiers, and braille printers.

Making PDFs accessible tends to benefit all users. For example, the underlying document structure that 

makes it possible for a screen reader to properly read a PDF out loud also makes it possible for a mobile 

device to correctly reflow and display the document on a small screen. Similarly, the preset tab order of an 

accessible PDF form helps all users—not just users with mobility impairments—fill the form more easily.

Each PDF File is Different

Not all PDFs are the same. PDF files are created in a variety of ways, from a variety of applications, and for a 

variety of purposes. In addition to applying the proper accessibility enhancements to PDF documents, 

achieving your accessibility goals for an individual PDF file requires understanding the nature of the PDF 

and the uses for which it is intended. 

Using this guide, you will learn how to assess existing PDF files for certain characteristics which influence 

their accessibility. The order in which this assessment is conducted is important. By following these 

procedures in the recommended order, users can efficiently proceed through the analysis of a PDF file in a 

systematic fashion. Systematically ruling out or confirming certain characteristics which a PDF file may 

possess will guide you to the most appropriate next step for making an individual PDF accessible (See 

“Acrobat 9 Pro PDF Accessibility Repair Workflow” on page 5).

This guide also discusses techniques for converting source files to accessible PDF. Using the Adobe 

PDFMaker with Microsoft Word as an example, this guide provides best practices for designing your source 

document with accessibility in mind so that the original document can be efficiently transformed into an 

accessible PDF version (See “Creating Accessible PDF Files Using Authoring Applications” on page 53).

Note: These Best Practices techniques assume the user has access to Adobe Acrobat Pro 9 or 

Adobe Acrobat 9 Pro Extended for Windows. Adobe Reader 9 and Adobe Acrobat 9 

Standard do not have the complete set of tools needed to create and validate PDF 

documents for accessibility.

Two Workflows for Creating Accessible PDF Files

The PDF format is a destination file format. PDF files are typically created in some other application. What 

this means is that the author who is concerned with PDF accessibility will be confronted with one of two 

situations: 

• Individuals working with an existing PDF file will want to know how to edit/update it to be 
an accessible PDF file.

• Authors will want to know how to use some other software application, such as a word processing 

or desktop publishing application, to generate an accessible PDF file from that application if 

possible. 

Making an Existing PDF File Accessible

“Acrobat 9 Pro PDF Accessibility Repair Workflow” on page 5 provides a step-by-step approach for 

analyzing PDF files and making them accessible based upon that analysis.
1
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Generating Accessible PDF Files from Authoring Applications

“Creating Accessible PDF Files Using Authoring Applications” on page 53 provides an example using 

Microsoft Word of how to use Acrobat’s PDFMaker to make an accessible PDF files from a word processing 

application. 

Even if you generate an accessible PDF file from an authoring application, you should then follow the steps 

in “Acrobat 9 Pro PDF Accessibility Repair Workflow” on page 5 in order to identify any items that may 

have been missed in the initial conversion or to add PDF accessibility features that are not provided by the 

authoring tool.

Characteristics of Accessible PDF files

The Adobe Portable Document Format (PDF) is the native file format of the Adobe® Acrobat® family of 

products. The goal of these products is to enable users to exchange and view electronic documents easily and 

reliably, independently of the environment in which they were created. PDF relies on the same imaging 

model as the PostScript® page description language to describe text and graphics in a device-independent 

and resolution-independent manner. To improve performance for interactive viewing, PDF defines a more 

structured format than that used by most PostScript language programs. PDF also includes objects, such as 

annotations and hypertext links, that are not part of the page itself but are useful for interactive viewing and 

document interchange. 

Accessible PDFs have the following characteristics:

Searchable text

A document that consists of scanned images of text is inherently inaccessible because the content of the 

document is a graphic representing the letters on the page, not searchable text. Assistive software cannot 

read or extract the words in a graphic representation, users cannot select or edit the text, and you cannot 

manipulate the PDF for accessibility. You must convert the scanned images of text to searchable text using 

optical character recognition (OCR) before you can use other accessibility features with the document (See 

“Step 2: Determine if the PDF is a Scanned Document” on page 5). 

Fonts that allow characters to be extracted to text

The fonts in an accessible PDF must contain enough information for Acrobat to correctly extract all of the 

characters to text for purposes other than displaying text on the screen. Acrobat extracts characters to 

Unicode text when you read a PDF with a screen reader or the Read Out Loud tool, or when you save as text 

for a braille printer. This extraction fails if Acrobat cannot determine how to map the font to Unicode 

characters.

Interactive form fields

Some PDFs contain forms that a person is to fill out using a computer. To be accessible, form fields must be 

interactive—meaning that a user must be able to enter values into the form fields (See “Step 3: Add 

Interactive Features: Form Fields and Buttons” on page 8). Interactive PDF forms also have a defined tab 

order allowing users of assistive technology to use the tab key in order to progress from one form field or 

interactive control in a logical manner.

Other Features: Buttons, hyperlinks, and navigational aids

Navigational aids in a PDF—such as links, bookmarks, headings, a table of contents, and a preset tab order 

for form fields—assist all users in using the document without having to read through the entire document, 

word by word. Bookmarks are especially useful and can be created from document headings. Many of these 

aids can be accessed using the keyboard without relying on the mouse (See “Step 3: Add Interactive 

Features: Form Fields and Buttons” on page 8). and (See “Step 4: Add Other Accessibility Features” on 

page 16)..
Making PDF Accessible with Adobe Acrobat 9 Pro
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Document language

Specifying the document language in a PDF enables some screen readers to switch to the appropriate 

language (See “Document Language” on page 16).

Security that will not interfere with assistive technology

Some authors of PDFs restrict users from printing, copying, extracting, adding comments to, or editing text. 

The text of an accessible PDF must be available to a screen reader. You can use Acrobat to ensure that 

security settings don’t interfere with a screen reader’s ability to convert the on-screen text to speech (See “Set 

Security That Permits Accessibility” on page 17).

Document structure tags and proper read order

To read a document’s text and present it in a way that makes sense to the user, a screen reader or other text-

to-speech tool requires that the document be structured. Document structure tags in a PDF define the 

reading order and identify headings, paragraphs, sections, tables, and other page elements (See “Step 5: 

Determine if the PDF File is a Tagged PDF File” on page 20).

Alternative text descriptions

Document features such as images and interactive form fields can’t be read by a screen reader unless they 

have associated alternative text. Though web links are read by screen readers, you can provide more 

meaningful descriptions as alternative text. Alternative text and tool tips can aid many users, including those 

with learning disabilities (See “Step 6: Determine if the PDF File is Properly Tagged” on page 23).

Adobe Acrobat and Adobe Reader Accessibility Features

Accessibility features in Adobe Acrobat and Adobe Reader fall into two broad categories: features to make 

the reading of PDF documents more accessible and features to create accessible PDF documents. To create 

accessible PDF documents, you must use Acrobat, not Reader.

Features for Accessible Reading of PDFs

• Preferences and commands to optimize output for assistive software and devices, such as saving as 

accessible text for a Braille printer

• Preferences and commands to make navigation of PDFs more accessible, such as automatic 

scrolling and opening PDFs to the last page read

• Accessibility Setup Assistant for easy setting of most preferences related to accessibility

• Keyboard alternates to mouse actions

• Reflow capability to temporarily present the text of a PDF in a single easy-to-read column

• Read Out Loud text-to-speech conversion.

• Support for screen readers and screen magnifiers

Features for Creating Accessible PDFs

• Creation of tagged PDFs from authoring applications

• Conversion of untagged PDFs to tagged PDFs from within Acrobat

• Security setting that allows screen readers to access text while preventing users from copying, 

printing, editing, and extracting text

• Ability to add text to scanned pages to improve accessibility

• Tools for editing reading order and document structure 

• Tools for creating accessible PDF forms 
Making PDF Accessible with Adobe Acrobat 9 Pro
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Though Acrobat Standard provides some functionality for making existing PDFs accessible, you must use 

Acrobat Pro or Acrobat Pro Extended to perform certain tasks—such as editing reading order or editing 

document structure tags—that may be necessary to make some PDF documents and forms accessible (See 

“Table 1: Features for Creating Accessible PDF Files by Product” on page 4).

Table 1: Features for Creating Accessible PDF Files by Product  

Reader 9
Acrobat 9 
Standard

Acrobat 9 
Pro

Acrobat 9 
Pro 

Extended

Create PDF documents from any 

application that prints

• • •

Convert Microsoft Word, Excel, 

PowerPoint, Publisher, and 

Access files to PDF with one-

button ease*

• • •

Capture web pages as rich, 

dynamic PDF files for review 

and archiving

• • •

Scan paper documents to PDF 

and automatically recognize text 

with optical character recogni-

tion (OCR)

• • •

Save PDF files as Microsoft 

Word documents, retaining the 

layout, fonts, formatting, and 

tables, to facilitate reuse of con-

tent

• • •

Easily create fillable PDF forms 

from paper or existing files using 

the Form Wizard

• • •

Enable users of Adobe Reader® 

(version 8 or later) to fill in and 

save PDF forms locally

• • •

Create dynamic XML forms with 

Adobe LiveCycle® Designer ES 

(included)*

• •

Create and validate accessible 

PDF documents

• •

* Windows Only
Making PDF Accessible with Adobe Acrobat 9 Pro



Making PDF Accessible with Adobe Acrobat 9 Pro
Acrobat 9 Pro PDF Accessibility 

Repair Workflow

PDF Accessibility Workflow Summary

At a high level, the process of making existing PDF files accessible consists of a few basic steps:

1. Analyze and evaluate the PDF document before you (See “Step 1: Analyze the PDF File” on 

page 5).

2. Determine if the PDF file originated from a scan. If so, perform Optical Character Recognition 

(OCR) using the OCR Text Recognition command in Adobe Acrobat 9 (See “Step 2: Determine if 

the PDF is a Scanned Document” on page 5).

3. Add fillable form fields and buttons with short descriptions if the PDF file is intended to work as an 

interactive document. Set the tab order for the form field (See “Step 3: Add Interactive Features: 

Form Fields and Buttons” on page 8).

4. Add other accessibility features to the PDF such as bookmarks and security that does not interfere 

with assistive technology (See “Step 4: Add Other Accessibility Features” on page 16).

5. Add tags to the PDF if it has not been tagged (See “Step 5: Determine if the PDF File is a Tagged 

PDF File” on page 20).

6. Determine if the PDF file has been properly tagged (See “Step 6: Determine if the PDF File is 

Properly Tagged” on page 23).

7. Use the Adobe Acrobat 9 Pro accessibility checker to evaluate the PDF and repair tagging problems 

and other issues such as missing alternate text descriptions, missing short descriptions for form 

fields, and improper read order. Run the accessibility checker and follow its suggestions for repair 

until no problems are found (See “Step 7: Use the Accessibility Checker to Evaluate the PDF File” 

on page 44).

Though these stages are presented in an order that suits most needs, you may perform tasks in these stages in 

a different order or iterate between some of the stages. In all cases, you should first examine the document, 

determine its intended purpose, and use that analysis to determine the workflow that you should apply.

Step 1: Analyze the PDF File

When you open the PDF file, take a moment to analyze the document before you. Take a moment to note its 

characteristics. 

• Is it a short document with a small number of pages or a long document consisting of many pages? 

• Is the document mostly text or a mixture of text and graphics?

• Does the document appear to have form fields?

• Another item to note is the complexity of the document’s layout. In some instances, documents of 

shorter length may be more challenging from an accessibility perspective than longer docments 

because their layout and read order are more complex.  Is the layout simple, a single column with a 

limited number of graphics, or is it complex with multiple columns, mixed layouts, tables and many 

graphics?  Complex layouts are an indicator that you may be spending more time with the 

document doing more detailed accessibility enhancements with the Touch Up Read Order Tool.

Step 2: Determine if the PDF is a Scanned Document

A common method for making PDF documents is to place a paper copy of a document into a scanner and 

then opening the resulting electronic version using Adobe Acrobat to view the newly scanned document as a 

PDF file. Unfortunately, this process results in creating an image of text and not the actual text itself. This 
5
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means the content is not accessible to users who rely on assistive technology to hear the contents of the page. 

Additional work must take place to make the document accesible.

Note: If you are certain that the PDF document is not a scanned document or it has previously 

undergone optical character recognition, you can skip this discussion and proceed to 

“Step 3: Add Interactive Features: Form Fields and Buttons” on page 8.

How to Tell if a PDF File is a Scanned Document

There are a number of indications that a PDF file originated from a scanned page. Onscreen, the document 

appears to contain text, but the page is actually an image. Choose the method that suits you best for 

determining if the PDF is from a scan and is an “image only” PDF.

• Note if the page appears to be skewed.  Sometimes sheets are not properly fed into the 

scanner with the effect being the page appears to be crooked, or skewed on the screen . 

Lines of text will not be straight but will appear to slant up or down (See “Figure 1 Skewed 

Text Indicates a Scanned PDF” on page 6) 

Figure  1 Skewed Text Indicates a Scanned PDF

• Search for characters that appear on the page. Use the find command in Acrobat to 

search for text that appears on the page. Select Edit > Find (Ctrl + F on Windows or 

Option + F on Mac OS) and type a term that appears on the page in the search field.

If the document was scanned, Acrobat will not find the search but will display a message 

indicating “Acrobat has finished searching the document. No matches were found”.

• Zoom in and check for jagged edges on smooth characters. Scanned images are bitmaps 

(See “Figure 2 Bitmap text (top) and text that has undergone OCR (bottom)” on 

page 7)The edges of curves on bit maps will not appear to be smooth or rounded but will 

be jagged as shown in the top sample illustrating the word “Ozone” in Figure 2 on page 7  

Use the marquee zoom tool in Acrobat to define the area and magnify the edges of curved 

letters such as “c”, “s”, and “o”. Text that has undergone the OCR process using the 
Making PDF Accessible with Adobe Acrobat 9 Pro
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ClearScan option will display smoother edges as shown in the bottom illustration of the 

word “Ozone” in Figure 2 on page 7 

Figure  2 Bitmap text (top) and text that has undergone OCR (bottom)

• Use assistive technology or the Read Out Loud feature. Acrobat 9 Pro can detect the 

presence of assistive technology and if it encounters a scanned document will announce an 

audible empty page warning and display the Scanned Page Alert dialog (See “Figure 3 

Scanned Page Alert Dialog” on page 7)

Figure  3 Scanned Page Alert Dialog

What to Do if the PDF is a Scanned Document

Perform Optical Character Recognition (OCR) to convert the bitmap image of text to actual characters. In 

Acrobat 9 Pro. You can do this by selecting “OK” from the Scanned Page Alert dialog (See “Figure 3 

Scanned Page Alert Dialog” on page 7) You can also run the “Recognize Text Using OCR” command in 

Acrobat 9. 

• Document > OCR Text Recognition > Recognize Text Using OCR...

• or use the keyboard accelerator: ALT + D + C + R 

All three of these methods will result in the display of the Recognize Text dialog (See “Figure 4 Recognize 

Text Dialog and Recognize Text Settings” on page 8) Use the Edit button in the scanned page dialog to set 

the desired characteristics for the resulting file.

• Primary OCR Language (user should select the applicable document language)

• PDF Output Style should be ClearScan. ClearScan will allow the resulting PDF to “reflow”. The 

other two options, “Searchable Image” and “Searchable Image Exact” will work with assistive 

technology but will result in a PDF file that cannot be reflowed.

• Downsample should be set to the lowest downsampling which results in the highest resolution as 

measured in dots per inch (dpi). This should be 600 dpi.
Making PDF Accessible with Adobe Acrobat 9 Pro
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Figure  4 Recognize Text Dialog and Recognize Text Settings

For additional information on performing optical character recognition using Adobe Acrobat, refer to the 

Acrobat 9 Help.

What to Do if the PDF is Not a Scanned Document

Proceed to “Step 3: Add Interactive Features: Form Fields and Buttons” on page 8.

Step 3: Add Interactive Features: Form Fields and Buttons

Determining if a PDF file is meant to be an interactive form is a matter of visually examining the file and 

looking for the presence of form fields, or areas in the document where some kind of information is being 

asked for such as name, address, social security number. Boxes or fields drawn on the page are also typical 

indications that the document is meant to function as a form. If you want users to be able to complete the 

form online, rather than resort to printing a paper copy in order to complete the form, then the form is 

meant to be an interactive form. 

Note: If you are certain the PDF document is not intended to have fillable form fields or buttons, 

you can skip this discussion and proceed to “Step 4: Add Other Accessibility Features” on 

page 16.

You can make form fields accessible to vision impaired users and users with mobility challenges by adding 

fillable fields to the PDF and by properly structuring it. In addition, you can use the Tooltip field property to 

provide the user with information about the field or to provide instructions. For example, using the Tooltip 

property value, the screen reader user would hear “Check this box if you will be attending the luncheon.”  

Without the tool tip property, a screen reader simply provides the name of  the form field (Check Box 1), its 

type (Check Box), and its state (Unchecked). It would not be clear to someone listening to the form that they 

are indicating their desire to attend a luncheon.

You can have Acrobat Pro detect and create the form fields automatically or you can manually create the 

necessary fields using Acrobat Pro’s form tools.
Making PDF Accessible with Adobe Acrobat 9 Pro
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This discussion limits itself to the accessibility issues involved with PDF forms. For a more detailed 

discussion of forms, refer to the Adobe Acrobat 9 Online Help.

PDF Form Fields

A PDF form created with Acrobat can contain the following types of fields:

• Text field.  Lets the user type in text, such as name, address, or phone number. 

• Check box.  Presents yes-or-no choices for individual items. If the form contains multiple 

check boxes, the user can typically select as many or few of these as needed.

• Radio button. Presents a group of choices from which the user can select only one item. 

All radio buttons with the same name work together as a group.

• List box. Displays a list of options the user can select. You can set a form field property 

that enables the user to Shift-click or Control-click to select multiple items on the list.

• Combo box.  Lets the user either choose and item from a pop-up menu or type in a value.

• Button.  Initiates a change on the user’s computer, such as opening a file, playing a sound, 

or submitting data to a web server. These buttons can be customized with images, text, and 

visual changes triggered by mouse actions.  Action buttons have a different purpose than 

radio buttons, which represent data choices made by the user.

• Digital signature field.  Lets the user electronically sign a PDF document with a digital 

signature.

• Barcode.  Encodes the input form selected fields and diplays it as a visual pattern that can 

be interpreted by decoding software or hardware (available separately). 

Use Acrobat to Detect and Create Interactive Form Fields

You can convert an existing electronic document (for example a Word, Excel, or PDF document) or scan a 

paper document to a PDF form, and then add interactive form fields to the form. 

When you convert a document to an Acrobat form, Acrobat can detect the form fields in the document. In 

many instances, Acrobat will use the form field labels to name the field and provide a Tooltip. While the 

results are often acceptable, this is not a foolproof process. You will need to examine the document carefully 

to verify that Acrobat accurately detected the fields and labelled them appropriately.

Acrobat Form Wizard

You can use the Form Wizard in Adobe Acrobat 9 Pro or Adobe Acrobat 9 Pro Extended to create 

interactive forms from an existing electronic document (for example a Word, PDF, or Excel document) or 

scan a paper form into a PDF form. 

• Choose Forms > Start Form Wizard.  

This displays the Create or Edit Form Dialog. From the Create or Edit Form Dialog, do one of the following, 

and then follow the on-screen instructions. 

• To convert an existing electronic document (for example Word or PDF) to a PDF form, select An 

Existing Electronic Document. This places the document in Form Editing Mode.

• To scan a paper form and convert it to a PDF form, select A Paper Form. The form will be scanned 

and placed in Form Editing Mode.

• To use LiveCycle Designer to create a form from scratch or from one of the available templates, 

select No Existing Form.  

Note: Using the Adobe LiveCycle Designer, included in Adobe Acrobat Pro and Adobe Acrobat 

Pro Extended for Windows, to create accessible PDF forms is beyond the scope of this Best 
Making PDF Accessible with Adobe Acrobat 9 Pro



Acrobat 9 Pro PDF Accessibility Repair Workflow10 |

Practices Guide.

The Form Wizard completes its analysis of the document, adds any form fields it may detect and places the 

PDF form in Forms Editing Mode where you can edit the automatically created fields or add additional form 

fields (See “Forms Editing Mode” on page 11).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have 

also created fields of the wrong type. Please verify the fields and field names on your form. You can select 

Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete 

fields.

Enter Forms Editing Mode Directly

If you don’t want to use the Form Wizard, you can open the file, and  place the document in Form Editing 

Mode directly.

• From the Acrobat Menu, select Forms > Add Or Edit Fields  (Keyboard shortcut is Shift + Ctrl 7).  

This displays the Add or Edit Form Fields dialog (See “Figure 5 Add or Edit Form Fields Dialog” on 

page 10)

Answering “Yes” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields 

for you?”  results in the automatic detection of form fields prior to placing the document in Form Editing 

Mode. This is the same as if you had proceeded using the Form Wizard on the current PDF.  

Acrobat completes its analysis of the document, adds any form fields it may detect and places the PDF form 

in Forms Editing Mode where you can edit the automatically created fields or add additional form fields (See 

“Forms Editing Mode” on page 11).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have 

also created fields of the wrong type. Please verify the fields and field names on your form. You can select 

Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete 

fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields 

for you?” also places the document in Form Editing mode, but does not create form fields automatically. You 

will have to add the form fields manually.  Proceed to the next section, “Create Form Fields Manually” on 

page 10 for futher information.

Create Form Fields Manually

To add form fields manually you first select Forms > Add or Edit Fields (Keyboard shortcut is Shift + Ctrl 7) 

and answer “No” to the question “Do you want Acrobat to detect the Form Fields for you?” in the resulting 

dialog (See “Figure 5 Add or Edit Form Fields Dialog” on page 10) This places the document in Forms 

Editing Mode without automatically creating any fields. You can now add new form fields to the PDF form. 

Proceed to the next section “Forms Editing Mode” on page 11 for further instruction.

Figure  5 Add or Edit Form Fields Dialog
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Forms Editing Mode

With the PDF form in Forms Editing Mode, you can add new fields and buttons to the form and edit or 

delete any existing field or button (See “Figure 6 Adobe Acrobat 9 Forms Editing Mode” on page 11) The 

Forms Editing Mode changes the Acrobat user interface slightly. 

• A Forms Editing Toolbar provides access to the Select Object tool, the Add New Field button,  and 

the Form Preview button.  You can configure the Add New Field button to display the Forms tools 

on the toolbar instead of the Add New Field button if you prefer.

• On the right hand side of the Forms Editing Toolbar, are the Distribute Form button and the Close 

Form editing button.

• A fields panel  appears on the left side of the document. 

• There is a forms menu bar which offers users choices that are mostly restricted to forms editing 

functions. 

Figure  6 Adobe Acrobat 9 Forms Editing Mode

Creating a New Form Field

In Acrobat, you create a form field by choosing one of the form tools. For each field type, you can set a 

variety of options through the form field Properties dialog box. 

You can access the forms tools one of three ways.

• You can select “Add New Field” on the Forms Editing Toolbar to add more fields

• From the Forms Editing menu you can select Forms > Form Tools (Keyboard accelerator ALT + R 

+ O). This will provide access to the Acrobat form tools.
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• You can right click over the form to present options that allow you to add, edit, or delete fields.

The cursor becomes a cross hair.

• On the page, click where you want to add the field to create a field with the default size. To create a 

field using a custom size, drag a rectangle to define the size of the field. 

• In the Field Name box, type the name of the field and specify if you want the field to be a required 

field.  Acrobat provides a default name based upon the field type and the number of fields drawn on 

the page. You should choose a name that is relevant and descriptive to make organizing and 

collecting the data easier (See “Figure 7 Field Name Box” on page 12)

• To display the Properties dialog box and modify any other field properties, click Show All 

Properties (See “Figure 7 Field Name Box” on page 12)

Note: If you have selected the Keep Tool Selected option in the forms toolbar, the Field Name 

box doesn’t appear after adding a field. Each time you click the page, a new field is added 

to the form. To exit this mode, press the Esc key or click the Select Object Tool button. To 

modify the properties of the field, double-click the field. 

 

Figure  7 Field Name Box

To test your form, click the Preview button. Previewing a form allows you to view the form the same way the 

form recipients will and gives you a chance to verify the form. If you are previewing a form, you can click the 

Edit Layout button to go back to the Forms Editing mode.  

Form Field Properties

How a form field behaves is determined by settings in the Properties dialog box for that individual field. You 

can set properties that apply formatting, determine how the form field information relates to other form 

fields, impose limitations on what the user can enter in the form field, trigger custom scripts, and so forth.

You can set a variety of properties for an Acrobat form field, depending on the form field type. The 

properties for each type of form field are selected on a series of tabs. When you change a property, it is 

applied as soon as you select another property or press Enter.

All the form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear only in 

specific types of form fields. The Options tab appears for most form field types but the options available are 

unique to each type of form field.

If you are changing the properties of multiple fields, you can leave the Properties dialog box open. Click on 

each field to change its properties.

Tooltips for Form Fields

For accessibility, the Tooltip option on the General tab is important for entering text that will be announced 

by screen readers. 

You can make form fields accessible to people with disabilities by adding tags to the PDF and by properly 

structuring it. In addition, you can use the tool tip form field property to provide the user with information 
Making PDF Accessible with Adobe Acrobat 9 Pro



Acrobat 9 Pro PDF Accessibility Repair Workflow | 13

about the field or to provide instructions. For example, using the tool tip property value, the screen reader 

could say “Your first name.” Without the tool tip property, a screen reader announces the type and name of 

the form field (See “Figure 8 Adding a Tooltip for Form Fields” on page 13)

• If necessary, choose Forms > Add or Edit Fields, and make sure that the Select Object tool is 

selected. 

• Double-click a selected form field to open the Properties window. 

• In the General tab, type a description into the tool tip box. 

The Tooltip also displays text that users may find helpful in filling in the form field. Tooltips appear when 

the pointer hovers briefly over the form field. 

Figure  8 Adding a Tooltip for Form Fields

Tooltips for Radio Buttons

To create a set of mutually exclusive Radio Buttons, where only one field can be selected at a time, give each 

field the same name but different Button values. The Button value is a field in the options tab of the Radio 

Button Properties dialog 

To make a radio button accessible, in addition to entering  unique text in the Button Value field for each 

choice, you would enter identical text in the Tooltip field of the General properties tab for each radio button 

in the group (See “Figure 9 Tooltips and Button Values for Radio Button Short Descriptions” on 

page 14)

For example, you may have a radio button group that asks the question, “Are You a Citizen?”. 

• You would create two radio buttons. For each button, you would enter the text “Are You a 

Citizen?” in the Tooltip field. 

• For one button you would enter “Yes” in the Button Value field under the options tab, for the other 

“No” should be entered in the Button Value field.
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Figure  9 Tooltips and Button Values for Radio Button Short Descriptions

Editing or Modifying an Existing Form Field

You can access Acrobat form field properties only when you are in editing mode (by choosing Forms > Add 

Or Edit Fields). You can change the properties for multiple form fields at a time. 

Open the Properties dialog box using one of the following methods: 

• To edit a single form field, double-click it or right-click/Control-click it and choose Properties. 

• To edit multiple form fields, select the fields that you want to edit, right-click/Control-click one of 

the selected fields, and choose Properties. 

Change the properties on each of the available tabs, as needed. The property is changed as soon as you select 

another property or press Enter.

• Click Close to close the Properties dialog box. 

If you select form fields that have different property values, some options in the Properties dialog box are not 

available. Otherwise, changes to the available options are applied to all selected form fields. 

To avoid accidental changes to the form field, select Locked in the lower left corner of the Properties dialog 

box before you close it. To unlock, click the check box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field you would like to delete and do any of the 

following.

• Right mouse click and select delete

• Press the delete key.

• From the menu, select Edit > Delete (ALT + ED)
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Note: You can select multiple fields by holding the Control key as you click on each one.

Buttons

Buttons are most commonly associated with forms, but you can add them to any document. Buttons can 

open a file, play a sound or movie clip, submit data to a web server, and much more. When deciding on how 

to initiate an action, remember that buttons offer the following capabilities that links and bookmarks do not:

• A button can activate a single action or a series of actions.

• A button can change appearance in response to mouse actions.

• A button can be easily copied across many pages.

• Mouse actions can activate different button actions. For example, Mouse Down (a click), Mouse Up 

(releasing after a click), Mouse Enter (moving the pointer over the button), and Mouse Exit 

(moving the pointer away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons are added the 

same way as form fields while in Forms Editing mode. They also should be given a name and a Tooltip and 

their behavior is determined by the actions the user assigns the button on the actions tab of the Button 

Properties dialog. They also appear in the Tab order tree. See the Adobe Acrobat Help for a complete 

discussion of PDF fields and buttons.

Set the Tab Order

If a PDF document doesn’t have a specified tab order, the default tabbing order is based on the document 

structure unless the user has deselected the Tab Order option in the Accessibility preferences.

You can change the tabbing order after you create the fields. 

• If you are in Forms Editing mode, you can order the tabs by document structure (default), row, or 

column. 

• You can also choose the order manually by dragging and dropping fields in the Fields panel. 

• If you are not in Forms Editing mode, you can change the page properties to order the tabs by row 

or column. However, you can’t customize the tab order manually.

To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the Fields panel. 

Then you can drag and drop fields where you want them within the Fields panel to modify the tab order (See 

“Figure 10 Rearranging Tab Order with the Fields Panel” on page 16)

To assist in determining tab order, you can select “Show Tab Numbers” from the Tab Order button of the 

Fields panel (See “Figure 10 Rearranging Tab Order with the Fields Panel” on page 16)

In the example shown in Figure 10 on page 16 , the check box labelled “operating system” is in the fifth 

position. Selecting the entry for operating system in the Forms panel highlights the corresponding field in 
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the document view. To move it to the second position, drag it up and drop it below the check box for “office 

suite”

Figure  10 Rearranging Tab Order with the Fields Panel

Step 4: Add Other Accessibility Features

This stage includes setting the document language, making sure that security settings do not interfere with 

screen readers, creating accessible links, and adding bookmarks.

Document Language

Setting the document language in a PDF enables some screen readers to switch to the appropriate language. 

You can set the document language for an entire document with Acrobat Pro, Acrobat Pro Extended, or 

Acrobat Standard. You can set the document language for specific portions of a multilanguage document 

with Acrobat Pro or Acrobat Pro Extended (See “Figure 11 Setting the document language” on page 17)

To set the language for an entire document:

• Choose File > Properties, (Cntrl + D for Windows, Cmnd + D Mac OS) and select a language from 

the Language menu in the Reading Options area of the Advanced tab. 

To set the language for an entire document to a language not in the Language menu: 

• choose File > Properties (Cntrl + D for Windows, Cmnd + D Mac OS), and enter the ISO 639 code 

for the language in the Language field in the Reading Options area of the Advanced tab. For more 

information, see the ISO Language Codes on http://www.loc.gov/standards. 

You can also set the language for individual sections or words: 

• Select the desired text element in the Tags tab and right click (See “ Tags Panel” on page 38)

• Choose Properties from the Options menu. In the TouchUp Properties dialog box, select the Tag 

tab. Select a language from the Language menu, and click Close. 

Note: The language that you specify for an element also applies to all elements nested under it 

in the logical structure tree.
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Figure  11 Setting the document language

Set Security That Permits Accessibility

You should ensure the Acrobat 9 security settings permit access to the document by assistive technology. 

You can verify the Acrobat 9 or Adobe Reader 9 security settings do not prohibit access to assistive 

technology by checking the security preferences tab of the document properties dialog.

• Select File > Properties (Cntrl + D for Windows, Cmnd + D Mac OS)

• Select the Security Tab of the Document Properties dialog (See “Figure 12 Security Tab Location 

in Document Properties Dialog” on page 18)
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Figure  12 Security Tab Location in Document Properties Dialog

• Select “Password Security” as the security method from the drop-down list. In the Permissions 

section of the Password Security Settings dialog, verify the box labelled “Enable text access for 

screen reader devices for the visually impaired” is checked. This is the default setting for Adobe 

Acrobat 9 and Adobe Reader 9 (See “Figure 13 Password Security Settings” on page 18)

Figure  13 Password Security Settings

Certain applications allow you to set the security settings for PDF files you plan to generate from within the 

application (See “Creating Accessible PDF Files Using Authoring Applications” on page 53).
Making PDF Accessible with Adobe Acrobat 9 Pro



Acrobat 9 Pro PDF Accessibility Repair Workflow | 19

Create Accessible Links

With thoughtfully provided links, users can quickly move from one part of a document to another, to related 

information in a different document, or to a website that is relevant to the content.

For URLs to be accessible to screen readers, you must convert them to active links and make sure that they 

are correctly tagged in the PDF. 

Note: If you tagged the Adobe PDF during conversion from an authoring application, the links 

and URLs in the document are probably already active and included in the tag tree so that 

they are accessible to screen readers. You probably don’t have to do this task unless you 

want to add more links. 

Acrobat provides several ways to create active links for text, objects, and URLs in a PDF. However, the 

methods differ in how they affect the tag tree. The best way to create accessible links is with the Create Link 

command.

Unlike the other methods for creating links in a tagged PDF (by using the Links tool or the Create From 

URLs In Document command), the Create Link command adds all three tags that screen readers require in 

order to recognize a link. The other methods create only one of the three tags, meaning that you must 

manually edit the tag tree to add the remaining two tags for each link and place these tags in the proper 

reading order in the tree. Although you must activate links one by one, using the Create Link command 

provides the fastest results and the least amount of follow-up work to make the links accessible to screen 

readers. All that is left to do is optional editing of the tag tree to add alternate text to the new links.

Note: Automatically detected URLs in PDF documents are not accessible. Avoid using the Create 

Links from URLs command (Advanced > Document Processing > Create Links from URLs... 

or ALT + A D C) . Also, ensure that the Basic Tools General Preference, “Create Links from 

URLs” is unchecked (Edit > Preferences > General). While these are a convenient way to 

detect text that is possibly a URL which allows users to click and go to the URL, the result is 

not an accessible link.  

Creating links with Acrobat Standard doesn’t generate any tags for the links. 

Do the following to make links active and add them to the tag tree:

• Select the text or object for which you want to create a link. 

• Right-click the selection, and choose Create Link from the context menu. 

• In the Create Link dialog box, select the appropriate options, and then follow the on-screen 

instructions to specify a URL, page view, or file as the link target. 

By default, the selected text for each link becomes the link text. After you add all the links, you can edit the 

tag tree to add alternate text to the links, further improving the accessibility of the PDF.

Add Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation pane. Each 

bookmark goes to a different view or page in the document. Bookmarks are generated automatically during 

PDF creation from the table-of-contents entries of documents created by most desktop publishing 

programs. These bookmarks are often tagged and can be used to make edits in the PDF. 

Initially, a bookmark displays the page that was in view when the bookmark was created, which is the 

bookmark’s destination. In Acrobat, you can set bookmark destinations as you create each bookmark. 

However, it is sometimes easier to create a group of bookmarks, and then set the destinations later. 
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In Acrobat, you can use bookmarks to mark a place in the PDF to which you want to return, or to jump to a 

destination in the PDF, another document, or a web page. Bookmarks can also perform actions, such as 

executing a menu item or submitting a form. 

Note: An Acrobat user can add bookmarks to a document only if the security settings allow it.

Step 5: Determine if the PDF File is a Tagged PDF File

Tagging is essential for PDF accessibility, it is used to establish logical read order and to provide hooks for 

adding alternative text descriptions to non-text elements that are in the PDF document. 

If you have been following the workflow up to this point,  you will have a PDF file that is searchable because 

you performed optical character recognition on a scanned document, or it was searchable to begin with. You 

have also added any desired interactivity in the form of navigational controls or interactive form fields. At 

this point it may or may not be a tagged PDF file.

Note: If you are certain the PDF document has been tagged, you can skip this discussion and 

proceed to “Step 6: Determine if the PDF File is Properly Tagged” on page 23.

How to Tell if a PDF File is Tagged

There are several ways to determine if a PDF file has been tagged. 

• View Document Properties. File > Document Properties (Ctrl +D) - In the lower left 

hand corner of the Description tab, is an indication as to whether or not the document is 

tagged (See “Figure 14 Tagged PDF File Property” on page 21)
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Figure  14 Tagged PDF File Property

• Reveal the Tags Panel. View > Navigation Panels > Tags. An untagged document will 

display the words "No Tags Available" as its root. A tagged document will show structure.  

To expand the entire tree fully, Cntrl + click on the root node labelled “Tags”.

Note: In certain instances, a document may not be considered tagged by Acrobat even though a 

structure is visible in the Tags panel.  Select the tags options icon and ensure a check mark 

appears before the entry “Document is Tagged PDF.” If it does not, simply select this entry 

to add the missing check mark (See “Figure 15 Document is Tagged PDF Indicator in a 

Structured Document” on page 22)
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Figure  15 Document is Tagged PDF Indicator in a Structured Document

• Run the Accessibility Quick Check . Advanced > Accessibility > Quick Check (Shift + 

Ctrl + 6). If the document is not tagged, the Accessibility Quick Check will indicate the 

document is not structured.

• Run the Accessibility Full Check. Advanced > Accessibility > Full Check. If the 

document is not tagged, the Accessibility Full Check will indicate the document is not 

tagged.

• Use the Touch Up Read Order Tool. Advanced > Accessibility > TouchUp Reading 

Order - An untagged document will not appear to have undergone a change. A tagged 

document will display shaded areas on the page that are numbered. An untagged 

document will not display these numbered rectangles (See “ TouchUp Reading Order 

Tool (TURO)” on page 23)

What to do if the PDF File is Not Tagged

Add tags to the document using Adobe Acrobat 9 Pro. 

• From the menu, select Advanced > Accessibility > Add Tags to Document (Keyboard Accelerator is 

ALT + AAA)

About the Add Tags Report

If Acrobat encounters potential problems while running the Add Tags To Document command, the Add 

Tags Report opens in the navigation pane. The report lists potential problems by page, provides a 

navigational link to each problem, and offers suggestions for fixing them. 
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You could choose to repair the problems at this time by following the suggestions in the Add Tags report or 

now that the file is tagged proceed to the next step “Step 6: Determine if the PDF File is Properly Tagged” 

on page 23. 

If you choose to repair the document at this stage, remember to assess the context of any error before 

following a particular suggestion for fixing it. For example, the report might state that an element that has 

been tagged as a figure and requires alternate text to make it accessible. When you examine the figure in its 

context on the page, you may decide that the figure is a background design element, not an illustration that 

conveys valuable meaning to the user. In the case of a nonessential image, and you would change the Figure 

tag to a Background tag; in the case of an image intended to convey meaning to the reader, you would add 

the missing alternate text (See “ Step 6: Determine if the PDF File is Properly Tagged” on page 23) 

Note: The Add Tags Report highlights tagging-related problems only, and it is a temporary file 

that you cannot save. You can assess other tagging, reading order, and accessibility 

problems by using Full Check.

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too 

problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. 

If the document contains mostly text, you can select a page and then remove headings, tables, and other 

elements to create a cleaner, simpler tagging structure (See “TouchUp Reading Order Tool (TURO)” on 

page 23).

What to do if the PDF File is Tagged

Proceed to the next step, “Step 6: Determine if the PDF File is Properly Tagged” on page 23.

Step 6: Determine if the PDF File is Properly Tagged

The easiest way to determine if the PDF file has been properly tagged is to use the TouchUp Reading Order 

Tool (See “ TouchUp Reading Order Tool (TURO)” on page 23)

• From the menu, select Advanced > Accessibility > Touchup Reading Order.... (Keyboard 

Accelerator is ALT + AAT)

The Touch Up Reading Order Tool divides a tagged page into shaded segments. Each segment is numbered 

indicating the read order of the item on the page. You can also verify the read order of items on the page by 

displaying the order panel from the Touch Up Read Order Tool.

Note: If you are certain the PDF document is properly tagged, you can skip this discussion and 

proceed to “Step 7: Use the Accessibility Checker to Evaluate the PDF File” on page 44.

TouchUp Reading Order Tool (TURO)

The TouchUp Reading Order tool provides the easiest and quickest way to fix reading order and basic 

tagging problems. When you select the TouchUp Reading Order tool, a dialog box opens that lets you see 

overlay highlights that show the order of page content. Each highlighted region is numbered and highlighted 

with gray or colored blocks; the number indicates the region’s placement in the page’s reading order. After 

you check the reading order of the page, you can correct other, more subtle tagging issues as needed.

The TouchUp Reading Order tool is intended for repairing PDFs that were tagged using Acrobat, not for 

repairing PDFs that were tagged during conversion from an authoring application. Whenever possible, you 

should return to the source file and add accessibility features in the authoring application. Repairing the 

original file ensures that you don’t have to repeatedly touch up future iterations of the PDF in Acrobat.

You use the TouchUp Reading Order tool to perform the following accessibility tasks:

• Visually check, and then repair, the reading order of page content
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• Tag fillable form fields and their labels

• Add alternative text to figures and descriptions to form fields

• Fix the tagging of simple tables, and prepare complex tables for more advanced manipulation in the 

logical structure tree

• Remove nonessential content, such as ornamental page borders, from the logical structure tree

Figure  16 TouchUp Reading Order Dialog

Selecting the TouchUp Reading Order Tool

To select the TouchUp Reading Order Tool, do one of the following: 

• Choose Advanced > Accessibility > TouchUp Reading Order (ALT + AAT)

• Choose Tools > Advanced Editing > TouchUp Reading Order Tool (ALT + TAG).

• Click the TouchUp Reading Order tool button in the Advanced Editing toolbar.

When you select TouchUp Reading Order, a dialog box opens that lets you see overlay highlights that show 

the order of page content (See “Figure 17 Result of Selecting the TouchUp Reading Order Tool” on 

page 25)
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Each highlighted region is numbered and highlighted with gray or colored blocks; the number indicates the 

region’s placement in the page’s reading order.l

Figure  17 Result of Selecting the TouchUp Reading Order Tool

TouchUp Reading Order Tool Options

You can select TouchUp Reading Order options from the dialog box, from the pop-up menu that appears 

when you right-click a highlighted region, or from the Options menu in the Order tab. The TouchUp 

Reading Order tool includes the following options:

• Text . Tags the selection as text. 

• Figure . Tags the selection as a figure. Text contained within a figure tag is defined as part 

of the image and is not read by screen readers. 

• Form Field . Tags the selection as a form field. 

• Figure/Caption . Tags a selected figure and caption as a single tag. Any text contained in 

the tag is defined as a caption. Useful for tagging photos and captions and preventing 

caption text from being incorrectly added to adjacent text blocks. Figures may require 

alternate text. 

• Heading 1, Heading 2, Heading 3 . Tags the selection as a first, second, or third level 

heading tag. You can convert heading tags to bookmarks to help users navigate the 

document. 

• Table . Tags the selection as a table after the selection is analyzed to determine the location 

of headings, columns, and rows. 

• Cell . Tags the selection as a table or header cell. Use this option to merge cells that are 

incorrectly split. 
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• Formula . Tags the selection as a formula. Because speech software may handle formula 

tags differently from normal text, you may want to add a description using alternate text. 

• Background . Tags the selection as a background element, or artifact, removing the item 

from the tag tree so that it doesn’t appear in the reflowed document and isn’t read by 

screen readers. 

• Table Editor . Automatically analyzes the selected table into cells and applies the 

appropriate tags. The table must be tagged as a table before you can use the Table Editor 

command on it. 

• Show Page Content Order . Shows content elements as highlighted areas that contain 

numbers to indicate the reading order. The rectangle next to this entry is a color swatch. 

Specify the desired highlight color for page content order by clicking the color swatch. 

• Show Table Cells . Highlights the content of individual table cells. The rectangle next to 

this entry is a color swatch. Specify the highlight color for Table Cells by clicking the color 

swatch. 

• Show Tables And Figures . Outlines each table and figure with a crossed-out box. The 

box also indicates whether the element includes alternate text. The rectangle next to this 

entry is a color swatch. Specify the highlight color for Tables and Figures by clicking the 

color swatch. 

• Clear Page Structure . Removes the tagging structure from the page. Use this option to 

start over and create a new structure if the existing structure contains too many problems. 

• Show Order Panel . Opens the Order tab to allow you to reorder highlighted content. 

• Edit Alternate Text . Available in the menu that appears when you right-click a 

highlighted figure. Allows the user to add or edit a text description about the figure 

properties that is read by a screen reader or other assistive technology. 

• Edit Form Field Text . Available in the menu that appears when you right-click a form 

field. Allows the user to add or edit a form field text description that is read by a screen 

reader or other assistive technology. 

• Edit Table Summary . Available in the menu that appears when you right-click a 

highlighted table. Allows the user to add or edit a text description about the table 

properties that is read by a screen reader or other assistive technology.

Tips for using the TouchUp Reading Order tool

When using the TouchUp Reading Order tool, you should be mindful of the following tips for use:

• Save the document (or a copy of it) before you use the TouchUp Reading Order tool. You can’t use 

Undo to reverse changes made with this tool, so reverting to a saved document is the only way to 

undo such a change. 

• Choose View > Page Display > Single Page, when using the TouchUp Reading Order tool. When 

you click the Clear Structure button, Acrobat clears tags from all visible pages—even pages that are 

only partially visible. 

Checking Read Order with the Touch Up Read Order Tool

You can quickly check the reading order of tagged PDFs by using the TouchUp Reading Order tool. You can 

also use this tool to add alternate text to images and correct many types of tagging problems that are outlined 

in the report that Acrobat generates when you add tags to a PDF. 

Reading-order problems are readily apparent when you use the TouchUp Reading Order tool. Each section 

of contiguous page content appears as a separate highlighted region and is numbered according to its 

placement in the reading order. 
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Within each region, text is ordered left to right and top to bottom. (You can change this order in the 

TouchUp preferences.) If a single highlighted region contains two columns of text or text that won’t flow 

normally, divide the region into parts that can be reordered. Because highlighted regions are rectangular, 

they may overlap somewhat, especially if their page content is irregularly shaped. Unless page content 

overlaps or is contained within two highlighted regions, no reading order problem is indicated. Page content 

should belong to no more than one highlighted region. 

You can change the reading order of the highlighted regions by moving an item in the Order Panel or by 

dragging it on the page in the document pane. By reordering highlighted regions on the page, you can make 

a figure and caption read at the specific point that they are referenced in the text. By changing the order of a 

highlighted region, you effectively change the reading order of that item without changing the actual 

appearance of the PDF.

Check reading order with the TouchUp Reading Order tool

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

Note: If highlighted regions don’t appear in the document pane, the document doesn’t contain 

tags.  You will need to tag the document (See “ What to do if the PDF File is Not Tagged” 

on page 22)

Optionally, do any of the following: 

• To specify a highlight color, click the color swatch, and then click the color you want.

• To highlight tables and figures, and to view alternate text for figures, select Show Tables And 

Figures.

• Check the reading order of text within each highlighted region. Zooming in can make this step 

easier. 

• Check the numbered order of all highlighted regions. If consecutive, numbered regions don’t 

follow one another, reorder them in the Order tab. 

• Click Show Order Panel, and then select each content entry (in square brackets [ ]) in the Order tab 

to highlight that content region in the document pane. Use this method to find numbered regions 

that you can’t see or locate on the page.

Change the reading order by dragging on the page

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, place the pointer over the number for the highlighted region you want to 

move, and drag it to where you want it to be read. The text-insertion pointer shows target locations 

within the text. 

When you release the highlighted region, the location of the text-insertion pointer becomes the 

dividing line as the underlying highlighted region is split into two new highlighted regions. All 

highlighted regions are renumbered to show the new reading order. 

Change the reading order using the Order panel

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, click Show Order Panel. 

• In the Order tab, navigate to view a list of highlighted regions that appear in the document pane. 

In the Order tab, drag the tag for a highlighted region to the location you want. As you drag, a line 

appears to show potential locations. After you drag an item to a new location, the highlighted 
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regions are renumbered to show the new reading order. You can select and move multiple, adjacent 

regions (See “Figure 25 Acrobat 9 Pro Order Panel” on page 38).

Editing Tags with the TouchUp Reading Order Tool

You can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an 

existing structure. However, this manual tagging doesn’t provide the same level of detail to the tagging 

structure as the Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line 

breaks, and hyphens. Before you clear the existing structure, make sure that manual tagging is your only 

recourse.

Tag a region

• Using the TouchUp Reading Order tool, drag within the document pane to select a region of the 

page that contains one type of content (for example, a text block). 

Do one of the following: 

• To add more page content to the current selection, Shift-drag.

• To remove page content from the current selection, Ctrl-drag/Command-drag.

Click the appropriate button in the TouchUp Reading Order dialog box to specify the tag type.

Change the tag for a region

If Acrobat tags a page element incorrectly, you can change the tag type for the highlighted region. 

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

To select a highlighted region, do one of the following: 

• Drag to select it.

• Click the number of a highlighted region.

• Click the button for the tag type that you want for the highlighted region. 

Add or remove content from a tagged region

The TouchUp Reading Order tool always displays as few highlighted regions as possible. If content within a 

highlighted region doesn’t flow properly, you may need to split a region to reorder it. Highlighted regions 

may also contain adjacent page content that is unrelated or that requires a different tag type. Page content 

may become orphaned from related elements, particularly if the content doesn’t fit within a rectangular 

shape. Use the TouchUp Reading Order tool to add or remove content from a region, or to split a region to 

reorder the content.

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, select a highlighted region. 

Do one of the following: 

• To add content to the current selection, Shift-click the content you want to add. The pointer 

changes to include a plus sign (+).

• To remove content from the current selection, Ctrl-click/Command-click the content you want to 

remove. The pointer changes to include a minus sign (-).

Click the button for the tag type that you want for the highlighted region. 

Split a region into two regions

• Select the TouchUp Reading Order tool. 
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• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, drag to select a small portion of content near the boundary of the first region 

that you want to create. 

• Click the Background button in the dialog box. The highlighted region splits into two regions, 

numbered from right to left. 

• If you need to correct the reading order, click Show Order Panel, and drag the new highlighted 

region to the correct location in the Order tab. 

Drag to select the first content region you created, including the region you defined as Background, and then 

set the tag by clicking a button in the TouchUp Reading Order dialog box.

Apply a heading tag

To help readers navigate a document and find the information they need, make sure that headings are tagged 

with the appropriate level to indicate their hierarchy in the content. 

• Select the TouchUp Reading Order tool, and then select the heading text in the PDF. 

• In the TouchUp Reading Order dialog box, click the button corresponding to the appropriate 

heading tag (for example, Heading 1, Heading 2). 

Remove page elements from the tag structure

When tagging a PDF, Acrobat can’t always distinguish between instructive figures and decorative page 

elements. Items that visually enhance page layout, such as decorative borders, lines, or background elements, 

can add clutter to the structure layout and should be removed. Therefore, Acrobat may incorrectly tag 

artifacts or page elements as figure tags. You can remove artifacts and irrelevant page elements from the tag 

structure by redefining them with the Background tag or by deleting their tags. If a tagged image in the 

document doesn’t contain useful or illustrative information for the user, you can remove the element from 

the tagging structure so that it isn’t read out loud or reflowed.

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order and Show Tables And 

Figures. 

• Remove the page element by doing one of the following: 

• In the document pane, select the page element, and then click Background in the dialog box.

In the Order tab, select the page element, and then press Delete.

Apply a figure tag

You can select an element and define it as a figure by using the TouchUp Reading Order tool. Once you 

define it as a figure, you can add alternate text to describe the figure.

• Using the TouchUp Reading Order tool, select the figure. 

• In the TouchUp Reading Order dialog box, click Figure. 

• In the document pane, right-click the region and choose Edit Alternate Text. 

Enter alternate text, and click OK. 

Using TouchUp Reading Order to Check and Correct Figure Tags

You can use the TouchUp Reading Order tool to identify and correct tagging results for figures. Determine 

whether figures include or require alternate text in order to be read correctly with assistive technologies. 

Ideally, figure tags should identify image content that is meaningful to the document as a whole, such as 

graphs or illustrative photographs. If background elements that shouldn’t be read are tagged as figures, 

redefine them as background.

• Select the TouchUp Reading Order tool, and then click Show Tables And Figures in the dialog box. 
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Do any of the following: 

• If a figure isn’t tagged as a figure, select the content region you want, and then click Figure or 

Figure/Caption in the dialog box.

• To remove text that was incorrectly combined with a figure, drag to select the text, and click the 

Text button in the dialog box.

To include a caption that is grouped with the figure, select the figure and caption, and click the Figure/

Caption button in the dialog box.

Adding Alternate Text with the TouchUp Reading Order Tool

If you want screen readers to describe graphical elements that illustrate important concepts in a document, 

you must provide the description using alternate text. Figures aren’t recognized or read by a screen reader 

unless you add alternate text to the tag properties. If you apply alternate text to text elements, only the 

description, not the actual text, is read. 

• Select the TouchUp Reading Order tool. 

• Select Show Tables And Figures in the dialog box. Figures that are missing Alternate Text will have 

a flag indicating “Figure - No alternate text exists” (See “Figure 18 Add / Edit Alternate Text with 

TouchUp Reading Order” on page 30).

• Right-click the figure, and choose Edit Alternate Text from the pop-up menu. (See “Figure 18 Add 

/ Edit Alternate Text with TouchUp Reading Order” on page 30)

In the Edit Alternate Text dialog box, type a new (or edit an existing) description for the figure, and then 

click OK (See “Figure 19 TouchUp Reading Order Alternate Text Dialog” on page 31) 

Figure  18 Add / Edit Alternate Text with TouchUp Reading Order
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Figure  19 TouchUp Reading Order Alternate Text Dialog

Using the TouchUp Reading Order Tool Table Editor

Tables pose a special challenge for screen readers because they present textual or numerical data to be easily 

referenced visually. Content within table cells can be complex and might contain lists, paragraphs, form 

fields, or another table.

The TouchUp Reading Order Table Editor automatically analyzes the selected table into cells and applies the 

appropriate tags. The table must be tagged as a table before you can use the Table Editor command on it. 

For best results when tagging tables, use the application that you created the document with to add tags 

when you create the PDF. If a PDF isn’t tagged, you can add tags by using the Add Tags To Document 

command. Most tables are properly recognized using this command; however, the command may not 

recognize a table that lacks clear borders, headings, columns, and rows. Use the TouchUp Reading Order 

tool to determine if the table has been properly recognized and to correct recognition problems. To add 

specialized formatting to tables and table cells, use the Tags tab.

You can use the Table Editor to automatically analyze a table into its components and apply the appropriate 

tags, but you may still need to check and correct some of these tags manually. By viewing table tags, you can 

determine whether columns, rows, and cells have been correctly identified. Tables that lack well-defined 

borders and rules are often tagged incorrectly or contain adjacent page elements. You can correct poorly 

tagged tables by selecting and redefining them; you can split combined cells by creating a tag for each cell. 

• Select the TouchUp Reading Order tool, and then click Show Tables And Figures. 

• If the table isn’t clearly labeled in the document pane, drag to select the entire table, and then click 

Table in the dialog box. 

• Click Show Table Cells to make sure that all cells in the table are defined as individual elements.

If cells don’t appear as separate elements, do one of the following: 

• If one or more cells are merged, use the TouchUp Reading Order tool to select the area within a 

single cell, and then click Cell in the dialog box. Repeat for each merged cell.

• If cells aren’t highlighted, the table might not use standard table formatting. Re-create the table in 

the authoring application.

Add a Table Summary

• With the cursor over the table, right click to add a Table Summary. The Edit Table Summary option 

is available in the menu that appears when you right-click a highlighted table. This allows the user 

to add or edit a text description about the table properties that is read by a screen reader or other 

assistive technology.

Place the Table in Editing Mode

There are two ways to place Tables in Table Editing Mode with the TouchUp Reading Order Tool:
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• With the cursor over the table, right click to select Table Editor from the drop down list to place the 

table in Table Editing mode.

• You can also click the Show Order Panel in the TouchUp Reading Order dialog and select the table 

from the Order Panel. One technique is to highlight the snippets of text in the Order Panel that 

match the headings of  the first row in the table. This often activates the Table Editor when it cannot 

otherwise be activated. You then select the Table Editor button on the TouchUp Reading Order 

dialog  to place the table in Table Editing Mode (See “Figure 20 Using the Order Panel to Activate 

the Table Editor” on page 32)

Figure  20 Using the Order Panel to Activate the Table Editor

Once in Table Editing Mode, the borders of the table cells are highlighted. You can change the color of the 

border to suit your needs (See “Figure 21 Table Editing Mode” on page 33). You can select individual cells 

by clicking within the borders with the mouse. You can select multiple table cells by holding down Shift and 

clicking. This is an effecient method for selecting the first row of data cells in a table which need to be 

changed to header cells.
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Figure  21 Table Editing Mode

Once in Table Editing Mode, you can right click to display the Table Cell Properties dialog or the Table 

Editor Options dialog. 

The Table Cell Properties dialog (See “Figure 22 Table Cell Properties” on page 34) allows you to: 

• Specify the type of cell the selected cell should be, whether a Header cell or Data cell

• Set the cells attibutes for row span and column span. Assign a unique header ID for Table Headers 

or associate Data cells with Header IDs that have been created for the table
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Figure  22 Table Cell Properties

The Table Editor Options dialog allows users to control how table cells and table headers are displayed by 

Acrobat when using the TouchUp Reading Order Table Editor (See “Figure 23 Table Editor Options” on 

page 34).

Figure  23 Table Editor Options

Note: To correct complex tagging problems for tables, you often must use the Tags Panel. 
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Remove or replace document structure tags

If the tags in a PDF file in Acrobat appear to be overly complicated you can try retagging an already tagged 

document.  To do this,  you must first remove all existing tags from the tree. 

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too 

problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. 

If the document contains mostly text, you can select a page and then remove headings, tables, and other 

elements to create a cleaner, simpler tagging structure. 

Acrobat can retag an already tagged document after you first remove all existing tags from the tree. 

Replace the existing tag structure

This procedure works best in pages that contain a single column of text. If the page contains multiple 

columns, each column must be selected and tagged individually.

• Select the TouchUp Reading Order tool. 

• In the document pane, drag to select the entire page. The selection includes both text and nontext 

elements. 

• Ctrl-drag/Command-drag around nontext page elements—such as figures and captions—to 

deselect them, until only text is selected on the page. Click Text in the TouchUp Reading Order 

dialog box. 

In the document pane, select a nontext page element, such as a figure and caption, and click the appropriate 

button in the dialog box to tag it. Repeat until all page content is tagged. 

Remove all tags from a PDF

• Open the Tags tab (View > Navigation Panels > Tags) and select the root (topmost) tag, Tags. 

• In the Tags tab, choose Options > Delete tag. 

Note: The Clear Page Structure command in the TouchUp Reading Order dialog box removes all 
tags from the currently visible pages.

Complex Structures

While you can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an 

existing structure, this manual tagging doesn’t provide the same level of detail to the tagging structure as the 

Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line breaks, and 

hyphens. Before you clear the existing structure, make sure that manual tagging is your only recourse.

To perform more advanced reading order and tagging tasks—such as fixing complex tables, removing 

obsolete tags after you delete pages, and adding alternative text to links—you may need to use the Content 

Panel and the Tags panel, which provide an alternate set of tools and features for manipulating PDF tags. 

Content Panel

Use the Content Panel to correct reflow problems in a PDF that can’t be corrected by using the TouchUp 

Reading Order tool. Because you can damage a PDF by editing content objects, make sure that you’re 

familiar with PDF structure before you change anything. For comprehensive information about PDF 

structure, see the PDF Reference Sixth Edition: Adobe Portable Document Format Version 1.7, on the PDF 

reference page (English only) of the Adobe website.

The Content Panel provides a hierarchical view of the objects that make up a PDF, including the PDF object 

itself. Each document includes one or more pages, a set of annotations (such as comments and links), and 

the content objects for the page, consisting of containers, text, paths, and images. Objects are listed in the 
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order in which they appear on the page, similar to tags in the logical structure tree. However, PDFs don’t 

require tags for you to view or change the object structure. 

• Choose View > Navigation Panels > Content.

The Content Panel may open in the document viewing area. It may be part of a panel group that also 

includes the Order Panel and the Tags Panel. You can drag the individual panel and dock it in the 

Navigation pane. You can also a the menu command to dock all panels in the Navigation Pane:

•  View > Navigation Panels > Dock All Panels (ALT + VNK) 

Click the plus sign (+) (Windows) or the triangle (Mac OS) next to the document name to view pages and 

objects.

Note: You may find it helpful to have Acrobat highlight items in the document view when the 

associated item in the Content Panel is selected. From the Content Panel Options Menu, 

select “Highlight Content” (See “Figure 24 Set Highlighting On for the Content Panel” on 

page 36). 

Move a container or object by selecting it and doing one of the following: 

• Drag it to the location you want. 

• Choose Cut from the Options menu, select the tag above the location you want to paste the cut tag, 

and choose Paste from the Options menu

.

Figure  24 Set Highlighting On for the Content Panel

Note: Container elements can’t be pasted directly to page elements. To move a container to 

another page, cut the container you want to move, select a container on the page you 

want to move the container to, and choose Paste from the Options menu. Then, drag the 

container out one level to the location that you want. 
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Content Tab Options

In the Content tab, use the Options menu or right-click an object to choose from the following options:

• New Container . Adds a new container object at the end of the selected page or container. 

• Edit Container Dictionary . Specifies the dictionary for the container. Errors in this 

dialog box may damage the PDF. Available only for containers that include dictionaries. 

• Cut . Cuts and copies the selected object (not the related page content). 

• Paste . Pastes content directly below the selected object at the same hierarchical level. 

• Paste Child . Pastes content into the selected object as a child content item. 

• Delete . Removes the object (not the related page content) from the document. 

• Find Content From Selection . Searches for the object in the Content tab that contains 

the object selected in the document pane. 

• Find . Searches for unmarked (untagged) artifacts, content, comments, and links. Options 

allow you to search the page or document, and to add tags to found items. 

• Create Artifact . Defines selected objects as artifacts. Artifacts are not read by a screen 

reader or by the Read Out Loud feature. Page numbers, headers, and footers are often best 

tagged as artifacts. 

• Remove Artifact . Removes the artifact definition from the selected object. 

• Highlight Content . When selected, highlights appear in the document pane around 

content that relates to a selected object in the Content tab. 

• Show Metadata . Allows viewing and editing of image or object metadata. 

• Properties . Opens the TouchUp Properties dialog box. 

Order Panel

You can change the reading order of the highlighted regions by moving an item in the Order tab or by 

dragging it on the page in the document pane. By reordering highlighted regions on the page, you can make 

a figure and caption read at the specific point that they are referenced in the text. By changing the order of a 

highlighted region, you effectively change the reading order of that item without changing the actual 

appearance of the PDF.

To select the Order Panel, do one of the following:

• Select the TouchUp Reading Order tool. In the TouchUp Reading Order dialog box, click Show 

Order Panel. 

• From the Acrobat menu select View > Navigation Panels > Order (ALT + VNO)

The Order Panel may open in the document viewing area. It may be part of a panel group that also includes 

the Content Panel and the Tags Panel. You can drag the individual panel and dock it in the Navigation pane. 

You can also use a menu command to dock all panels in the Navigation Pane:

•  View > Navigation Panels > Dock All Panels (ALT + VNK) 

To change the order of content using the Order Panel:

• In the Order panel, navigate to view a list of highlighted regions that appear in the document pane. 

In the Order tab, drag the tag for a highlighted region to the location you want. As you drag, a line 

appears to show potential locations. After you drag an item to a new location, the highlighted 

regions are renumbered to show the new reading order. You can select and move multiple, adjacent 

regions. 
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Figure  25 Acrobat 9 Pro Order Panel

Tags Panel

The Tags Panel allows you to view and edit tags in the logical structure tree, or tags tree, of a PDF. In the 

Tags Panel, tags appear in a hierarchical order that indicates the reading sequence of the document. The first 

item in this structure is the Tags root. All other items are tags and are children of the Tags root. Tags use 

coded element types that appear in angle brackets (< >). Each element, including structural elements such as 

sections and articles, appears in the logical structure order by type, followed by a title and the element’s 

content or a description of the content. Structural elements are typically listed as container—or parent—tags 

and include several smaller elements—or child tags—within them.

Though you can correct most tagging issues by using the TouchUp Reading Order tool, you must use the 

Tags Panel to address detailed tagging of tables and substructure items—such as paragraphs, lists, and 

sections that require multiple languages. Add tags manually to a document using the Tags tab only as a last 

resort. First consider using the Add Tags To Document feature.

Note: Important: Operations performed in the Tags tab cannot be undone with the Undo 

command.  Save a backup copy of a document before you begin work on it in the Tags tab.

To select the Tags Panel:

• Choose View > Navigation Panels > Tags. 

Then do one of the following: 

• Expand the tag for the section you want.

• Ctrl-click the plus sign (Windows) or Option-click the triangle (Mac OS) next to the Tags root to 

show all tags in the logical structure tree.

Note: You may find it helpful to have Acrobat highlight items in the document view when the 

associated item in the Tags Panel is selected. From the Content Panel Options menu, 

select “Highlight Content” (See “Figure 26 Set Content Highlighting On for the Tags 

Panel” on page 39). 
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Figure  26 Set Content Highlighting On for the Tags Panel

Edit tags with the Tags Panel

You can edit a tag title, change a tag location, or change the tag type for an element. All page content must be 

tagged, marked as an artifact, or removed from the logical structure tree.

To reveal the TouchUp Properties for any tag select the desired tag in the Tags panel and do one of the 

following:

• Right click and select Properties from the context menu

• Select Properties from the Tags Panel Option Menu
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Figure  27 Revealing TouchUp Properties for Tags 

Edit a tag title

• In the Tags tab, expand the section of the logical structure that you want to edit. 

• To edit the title, Select the tag, choose Properties from the Options menu, enter text in the Title box, 

and click Close. 

Move a tag

• In the Tags tab, expand the Tags root to view all tags. 

• Select the Tag icon of the element that you want to move. 

Do one of the following: 

• Drag the tag to the location you want. As you drag, a line appears at viable locations. 

• Choose Cut from the Options menu, and select the tag that appears above the location you want to 

paste the cut tag. From the Options menu, choose Paste to move the tag to the same level as the 

selected tag, or choose Paste Child to move the tag within the selected tag.

Change the element type

• In the Tags tab, expand the section of the logical structure that you want to change. 

• Select an element and choose Properties from the Options menu. 

• Choose a new element type from the Type menu, and then click Close. 

Tags tab options

In the Tags tab, use the Options menu or right-click a tag in the logical structure tree to choose from the 

following options:
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• New Tag . Creates a new tag in the logical structure tree after the currently selected item. 

Specify type and title of the new tag. 

• Cut . Removes the selected tag from its current location and puts it on the clipboard. 

• Paste . Places the tag that’s on the clipboard into the location specified, replacing the 

selected tag. 

• Paste Child . Places the tag that’s on the clipboard into the location specified, as a child of 

the selected tag. 

• Delete Tag . Removes the selected tag. 

• Find Tag From Selection . Searches for the tag in the Tags tab that contains the text or 

object selected in the document pane. 

• Create Tag From Selection . Creates a new tag in the logical structure tree after the item 

selected in the document pane. Specify type and title of the new tag. 

• Find . Searches for artifacts, OCR suspects, and unmarked (untagged) content, comments, 

links, and annotations. Options allow you to search the page or document and add tags to 

found items. 

• Change Tag To Artifact . Changes selected tags to artifacts and removes the tagged 

content from the structure tree. 

• Copy Contents To Clipboard . Copies all content contained within the selected tags. 

• Edit Class Map . Allows you to add, change, and delete the class map, or style dictionary, 

for the document. Class maps store attributes that are associated with each element. 

• Edit Role Map . Allows you to add, change, and delete role maps for the document. Role 

maps allow each document to contain a uniquely defined tag set. By mapping these 

custom tags to predefined tags in Acrobat, custom tags are easier to identify and edit. 

• Tag Annotations . When selected, all new comments and form fields are added to the tag 

tree after the selected tag element; existing comments and form fields aren’t added to the 

tag tree. Highlight and Underline comments are automatically associated and tagged with 

the text that they annotate and don’t require this option. 

• Document Is Tagged PDF . Flags the PDF as a tagged document. Deselect to remove the 

flag. 

Important: This option doesn’t necessarily indicate that the PDF conforms to PDF guidelines and 

should be used judiciously. 

• Highlight Content . When selected, causes highlights to appear around content in the 

document pane when you select the related tag in the Tags tab. 

• Show Metadata . Opens a read-only dialog box that contains reference information about 

the selected tag. 

• Properties . Opens the TouchUp Properties dialog box.

Add alternate text and supplementary information to tags

Some tagged PDFs might not contain all the information necessary to make the document contents fully 

accessible. For example, if you want to make a document available to a screen reader, the PDF should 

contain alternate text for figures, language properties for portions of the text that use a different language 

than the default language for the document, and expansion text for abbreviations. Designating the 

appropriate language for different text elements ensures that the correct characters are used when you 

repurpose the document and that it is spell-checked with the correct dictionary. 
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You can add alternate text and multiple languages to a tag from the Tags tab. (If only one language is 

required, choose the language with File > Properties instead.) You can also add alternate text by using the 

TouchUp Reading Order tool.

Note: Note: Keep alternate text descriptions as concise as possible. 

Add alternate text to links

Screen readers can read the URLs of web links out loud, but adding meaningful alternate text to links can 

help users immensely. For example, by adding alternate text you can have a screen reader tell a user to “go to 

the Acrobat accessibility page of adobe.com” rather than “go to http://www.adobe.com/products/acrobat/

solutionsacc.html.” 

You add alternate text to the <Link> tag of a link.

Note: Note: You must add alternate text only to tags that don’t have child tags. Adding 

alternate text to a parent tag prevents a screen reader from reading any of that tag’s child 

tags. 

• In the tag tree, select the <Link> tag for the link and choose Options > Properties. 

• In the TouchUp Properties dialog box, select the Tag tab. 

• Type alternate text for the link, and click Close. 

Add alternate text for a figure

• Choose View > Navigation Panels > Tags. 

• Expand the logical structure tree to find and select the <Figure> tag element for the image. 

To find a tag more easily, use the TouchUp Reading Order tool to select the figure—or text near the 

figure—in the document pane, and then choose Find Tag From Selection from the Options menu 

in the Tags tab. 

• Choose Highlight Content from the Options menu in the Tags tab to see a highlighted area in the 

document that corresponds to the tag. 

• Choose Properties from the Options menu in the Tags tab. 

• In the TouchUp Properties dialog box, click the Tag tab. 

• For Alternate Text, type text that describes the figure. 

Add alternate text for an abbreviated term

In the Tags panel, locate the abbreviated term by doing one of the following: 

• Expand the tag tree as needed to see the elements that contain the abbreviation.

• Use the TouchUp Text tool or the Select tool to select the abbreviation in the document, and then 

choose Find Tag From Selection from the Options menu to locate the text in the tag tree.

• Select the tag for that element, and choose Properties from the Options menu. 

Note: Note: If the abbreviation includes additional text, cut the additional text and place it in a 

new <Span> child tag within the same <Span> parent tag. 

• In the TouchUp Properties dialog box, select the Tag tab. 

• For Alternate Text, type the unabbreviated version of the term. 

Click Close. 
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Create a new child tag

• In the Tags tab, select the parent node (the icon located at the same level at which you want to 

create a child tag) in the Tags tree for which you want to create a child tag. 

• Choose New Tag from the Options menu. 

Select the appropriate tag type from the Type pop-up menu, or type a custom tag type, name the tag 

(optional), and then click OK. 

Add tags to comments

When you tag a PDF that includes comments, the comments are tagged as well. However, if you add 

comments to a PDF that’s already tagged, your comments are untagged unless you enable comment tagging 

first. 

Note: To Enable comment tagging in a PDF, in the Tags tab, choose Tag Annotations from the 

Options menu. Comments or markups that you add to the PDF are tagged automatically. 

If a document contains untagged comments, you can locate them in the logical structure tree and tag them 

by using the Find command in the Tags tab.

• In the Tags tab, choose Find from the Options menu. 

• In the Find Element dialog box, choose Unmarked Comments from the Find pop-up menu, and 

click Find. 

• When the comment type appears in the Type field (for example, Text), click Tag Element, choose 

Annotation from the Type pop-up menu in the New Tag dialog box, and then click OK. 

In the Find Element dialog box, click Find Next to locate and tag all comments, and then click Close. 

Correct table tags with the Tags tab

Use the TouchUp Reading Order tool to make sure that tables are tagged correctly. If you need to structure 

figures and text within the cells of your table, you may prefer to re-create the table in the authoring 

application before you convert it as an accessible PDF. Adding tags on a cell level in Acrobat is a labor-

intensive procedure.

Before you make any changes to table elements, use the TouchUp Reading Order tool to determine that the 

table is tagged correctly.

Check table elements

• In the Tags tab, expand the tags root to view a table tag. 

• Select the table tag <Table> and verify that it contains one of the following elements: 

Table Rows, each of which contains Table Header <TH> or Table Data <TD> cells.

<THead>, <TBody>, and <TFoot> sections, each of which contains Table Rows. (The Table Rows 

contain <TH> cells, <TD> cells, or both.)

Do one or more of the following: 

• If the tag for the table doesn’t contain these elements, but rows, columns, and cells appear in the 

table in the document pane, use the TouchUp Reading Order tool to select and define the table or 

individual cells.

• If the table contains rows that span two or more columns, set ColSpan and RowSpan attributes for 

these rows in the tag structure.

• Re-create the table in the authoring application, and then convert it to a tagged PDF.
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Set ColSpan and RowSpan attributes

• In the Tags tab, select a <TD> or <TH> element. 

• Choose Properties from the Options menu. 

• In the TouchUp Properties dialog box, click the Tag tab, and then click Edit Attribute Objects. 

• Select Attribute Objects, and then click New Item to create a new Attribute Object Dictionary. 

• Expand the new dictionary, select the Layout attribute, and then click Change Item. 

• Change the Layout value to Table. 

• Select the Attribute Object Dictionary, and click New Item. 

In the Add Key And Value dialog box, type ColSpan or RowSpan in the Key box, enter the number of 

columns or rows spanned in the Value box, choose Integer from the Value Type pop-up menu, and click 

OK. 

Step 7: Use the Accessibility Checker to Evaluate the PDF File

Note: The accessibility checker tools (Quick Check and Full Check) can help to identify areas of 

documents that may be in conflict with Adobe's interpretations of the accessibility 

guidelines referenced in the application and its documentation. However, these tools 

don’t check documents against all accessibility criteria, including those in such referenced 

guidelines, and Adobe does not warrant that documents comply with any specific 

guidelines or regulations.

Quick Check

Use Quick Check to check for document structure tags, searchable text, and appropriate security settings for 

accessibility. This method is often the best way to check for accessibility before attempting to use a PDF.

Quick Check Results

• This document has logical structure but it is not a Tagged PDF.  Some accessibility 

information may be missing.” Quick Check has found an underlying document structure 

in the document, so Acrobat will use the available document structure to control the 

reading order, rather than analyzing the document itself. However, this untagged 

document structure might be incomplete or unreliable, so assistive software and the 

accessibility features in Acrobat (such as the Read Out Loud and the Save As Text features) 

may not read the page properly. If the reading order of the page seems to be wrong, select 

Override The Reading Order In Tagged Documents in the Reading panel of the 

Preferences dialog box. 

• This document is not structured, so the reading order may not be correct. Try different reading 

orders using the Reading Preferences panel.” . Quick Check has found no underlying 

document structure that Acrobat can use for reading order. Acrobat will analyze the 

reading order of the document using the current analysis method set in the Reading Order 

preference, but this PDF might not be read correctly by screen readers. If the reading order 

seems wrong, select a different option for Reading Order in the Reading panel of the 

Preferences dialog box. 

• No accessibility problems were detected in this quick check. Choose the Full Check command to 

check more thoroughly. Quick Check has found that the PDF contains searchable text, is 

tagged, has an underlying document structure, and has no security settings that prohibit 

access for screen readers. To check for other types of accessibility problems that may be 

present in the PDF, use Full Check. 
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• This document’s security settings prevent access by screen readers. Quick Check has 

found that the PDF has security settings that interfere with screen readers’ ability to extract 

text for conversion to speech. You may be able to use a screen reader with this document if 

your assistive technology product is registered with Adobe as a Trusted Agent. Contact 

your assistive technology product vendor. 

• This document appears to contain no text. It may be a scanned image. Quick Check has 

found that the PDF contains no searchable text, probably because the document consists 

entirely of one or more scanned images. This means that screen readers, Read Out Loud, 

Reflow view, and most other accessibility features—which rely on text as input—will not 

work with this document

Full Check

Use Full Check to perform a more thorough check for many characteristics of accessible PDFs, such as the 

use of fonts that can be mapped reliably to Unicode text. 

Full Check checks a PDF for many of the characteristics of accessible PDFs.

You can choose which kinds of accessibility problems to look for and how you want to view the results.

• Choose Advanced > Accessibility > Full Check. 

• Select options for how you want to view the results.

You can save the results as an HTML file or as comments that are located where the accessibility problems 

are detected. 

• Select a page range if you prefer to do a full check on individual sections of a document. 

When you have a large document, running a full check one section at a time can be more efficient. 

• Select an accessibility standard (Adobe PDF, Section 508 (U.S.), or W3C ) from the Name menu, 

and then select the accessibility options to check for. 

The standard that you select in the Name menu determines which accessibility options are 

available.

• Click Start Checking. 

The results are displayed in the left panel, which also has helpful links and hints for repairing issues (See 

“Figure 28 Acrobat 9 Pro Accessibility Report” on page 46)

If you created a report in step 2, the results are available in the selected folder. Clicking on the links 

highlights the problem areas in the document. The Accessibility Checker panel also provides hints for repair 

which you should follow 
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Figure  28 Acrobat 9 Pro Accessibility Report

Because the Full Check feature is unable to distinguish between essential and nonessential content types, 

some issues it reports don’t affect readability. It’s a good idea to review all issues to determine which ones 

require correction.

Accessibility Full Check Options

• Create Accessibility Report . Creates an HTML report of accessibility issues, which is 

opened in the navigation pane and saved in the location indicated by the Folder field. 

• Include Repair Hints In Accessibility Report . Adds suggestions for fixing accessibility 

problems to the HTML report or comments. 

• Create Comments In Document . Adds comments to the document that indicate 

accessibility problems. Delete all accessibility comments from the PDF after you repair the 

accessibility issues. 

• Page Range . The range of pages to check. 

• Name . The set of accessibility criteria to check. For the Section 508 and W3C guidelines, 

the options area includes a Browse button that links to the website for the respective 

guidelines. Select Adobe PDF to choose from options for the Adobe PDF accessibility 

standard

• Alternative Descriptions Are Provided . Checks for tagged figures that are missing 

alternate text. 

• Text Language Is Specified . Checks for paragraphs that don’t have a language specified 

for them. Setting the language for an entire document in the Document Properties dialog 

box corrects all errors related to this option. 
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• Reliable Character Encoding Is Provided . Checks for fonts that are inaccessible to 

screen readers and other assistive software. Fonts must contain enough information for 

Acrobat to correctly extract all the characters to text. If one or more fonts don’t allow for 

the correct extraction of all the characters, the PDF is inaccessible. 

• All Content Is Contained In The Document Structure . Checks for page elements that 

may have been overlooked during tagging. Adding these elements to the tag tree (if 

necessary) ensures that a screen reader can present the content to a user. 

• All Form Fields Have Descriptions . Checks for form fields that are missing descriptions. 

• Tab Order Is Consistent With The Structure Order . Checks whether tags properly 

reflect the document’s structure. 

• List And Table Structure Is Correct . Checks whether tags that have been generated for 

lists and tables meet the requirements of tagged PDF. 

Continue Checking Until All Issues are Addressed

Repeat the process of running the Accessibility Checker and using familiar repair techniques or following 

the Hints for Repair until the Accessibility Checker indicates “The checker found no problems in this 

document” for the tests you have selected (See “Figure 29 A Successful Accessibility Check” on page 47)

Note: While the Accessibility Checker helps you evaluate the accessibility of your documents 

and helps identify areas that may be in conflict with Adobe's interpretations of the 

referenced guidelines, the Accessibility Checker does not check all accessibility guidelines 

and criteria, including those in such referenced guidelines, and Adobe does not warrant 

that your documents will comply with any specific guidelines or regulations. Please 

consult with your legal counsel for guidance on compliance with the referenced 

guidelines or any other accessibility guidelines.

Figure  29 A Successful Accessibility Check

Additional Validation Techniques

Of course, the best way to test the accessibility of a document is to attempt to use the document with the 

tools that your readers will use. However, even if you don’t have a screen reader or braille printer, you can 

still use any of several methods provided by Acrobat for checking the accessibility of a PDF file.

• Use Reflow view to quickly check reading order. 

• Use Read Out Loud to experience the document as it will be experienced by readers who use this 

text-to-speech conversion tool.

• Save the document as accessible text and then read the saved text file in a word-processing 

application to experience the document as it will be experienced by readers who use a braille 

printer.

• Use the TouchUp Reading Order tool, Tags tab, and Content tab to examine the structure, reading 

order, and contents of a PDF in detail.
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Making PDF Accessible with Adobe Acrobat 9 Pro
 Creating Accessible PDF Files Using 

Authoring Applications

Introduction

In many cases, you can create tagged PDFs from within an authoring application, such as Adobe 

FrameMaker®, Adobe InDesign, Adobe LiveCycle Designer. This functionality extends to applications that 

are not from Adobe Systems, such as Microsoft® Office and OpenOffice.org Writer. Creating tags in the 

authoring application generally provides better results than adding tags in Acrobat. 

In Windows, Acrobat installs both an Acrobat PDFMaker toolbar and an Adobe PDF menu in many 

popular authoring applications. PDFMaker provides conversion settings that let you create tagged PDFs in 

Microsoft Excel, PowerPoint, and Word among others. 

You can use either the toolbar buttons or the Adobe PDF menu (the Action menu in Lotus Notes) to create 

PDFs, but the menu also provides access to conversion settings. Although many of the conversion options 

are common to all authoring applications, a few are application-specific.

Note: For Microsoft Office 2007 applications such as Word, Excel, PowerPoint, and Access, the 

options for creating PDFs are available from the Acrobat Ribbon. 

In general, the following rules apply.

• Design your source document with accessibility in mind

• Do NOT use character formatting for headings, use the program’s styles.

• Do add alternative text to graphics in the source file 

• Do use a table editor if available to create tables

• Do NOT use a table editor to design layouts

• Do generate the PDF file in a way that generates tags

• Do set your PDF output preferences option to tagged PDF

• Do check the results in Adobe Acrobat 9 Pro using Advanced > Accessibility > Full Check 

(shortcut: Alt + A + A + F)

• Do follow the suggestions for repair and repeat checking until no errors are detected

Create an Accessible Microsoft Word Document

You should author the original source document with accessibility in mind. This means you should add 

structure to the document by using styles rather than character formats for such items as headings and lists. 

You should also add alternate text descriptions to graphics that appear in the Word file using the format 

picture dialog. You should use Word’s column command and not tables to create multi-column documents. 

Use Styles

Design your documents with styles. Styles add the structure necessary to make your documents usable to 

people with disabilities.

Text

The default text style for Microsoft Word is Normal. 

• Text should be at least 12 point type. 

• Avoid using Microsoft Word text boxes.
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• Avoid using Enter to create space between paragraphs. Use the space before and space after 

properties in your styles 

Headings

Use Styles to create heading formats. Title, Heading 1, Heading 2, Heading 3, etc. Make styles progress in a 

logical manner , a Heading 2 should come after a Heading 1 

Word 2003 Headings

To create headings in Microsoft Word 2003 do the following

• Format > Styles and Formatting to reveal the styles and formatting task pane (See “Figure 30 

Microsoft Word 2003 Styles and Formatting” on page 50).

• Apply the appropriate heading from the Styles and Formatting panel to your document text 

Figure  30 Microsoft Word 2003 Styles and Formatting

Word 2007 Headings

• Select the Home Ribbon in Word 2007 and select the proper heading from the styles group (See 

“Figure 31 Microsoft Word 2007 Styles and Formatting” on page 50).

 

Figure  31 Microsoft Word 2007 Styles and Formatting
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Add Alternative Text to Word Graphics and Images

Alternative Text or Alt Text refers to text that can be read by a screen reader to describe graphics and images 

which people with visual dis-abilities cannot see.  All Graphics and Images should be provided with 

alternative text descriptions. Avoid placing graphics too close to text. This can cause problems when 

converting to PDF. Place white space between text and graphics. 

Word 2003 

• Double Click on an image or right click and select the format picture dialog. 

• Select the Web tab and enter the alternative text (See “Figure 32 Microsoft Word 2003 Web Tab 

for adding Alternative Text” on page 51).

Figure  32 Microsoft Word 2003 Web Tab for adding Alternative Text

Word 2007 

• Right Click on an image and choose Size 
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• Select the Alt Text tab and enter the alternative text (See “Figure 33 Microsoft Word 2007 Alt Text 

for adding Alternative Text” on page 52) 

Figure  33 Microsoft Word 2007 Alt Text for adding Alternative Text

Configure the PDFMaker

Once you have authored your Microsoft Word document with accessibility in mind, you are ready to 

convert it to an accessible PDF file. To generate an accessible PDF document directly from the Microsoft 

Word source, you should use the Adobe PDFMaker to convert the file to PDF.

PDFMaker is an Acrobat feature that operates within many business applications, such as Microsoft Office 

applications and Lotus Notes. When you install Acrobat, PDFMaker controls appear in the work area of the 

authoring application. 

Using PDFMaker within an authoring application is a simple, one-click procedure. It involves clicking an 

Acrobat PDFMaker toolbar button or choosing a command on the Adobe PDF menu. It is not necessary to 

open Acrobat.

In Windows, Acrobat installs both an Acrobat PDFMaker toolbar and an Adobe PDF menu in many 

popular authoring applications. You can use either the toolbar buttons or the Adobe PDF menu to create 

PDFs, but the menu also provides access to conversion settings.

Note: For Microsoft Office 2007 applications such as Word, Excel, PowerPoint, and Access, the 

options for creating PDFs are available from the Acrobat ribbon (See “Figure 34 Microsoft 

Word 2007 Adobe Acrobat Ribbon and Group” on page 53).
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Figure  34 Microsoft Word 2007 Adobe Acrobat Ribbon and Group

Show or activate PDFMaker in Microsoft Word

If you don’t see the PDF toolbar buttons in Microsoft Word, you must show or activate the PDF toolbar. Use 

one of the following methods to show or activate PDFMaker.

For Office 2003 or earlier, 

• Choose View > Toolbars > Acrobat PDFMaker 9.0

For Office 2007

Do the following: 

• Click the Office button, and then click the Word Options button

• Click Add-Ins on the left side of the dialog box. 

• Do one of the following: 

• If PDFMOutlook or Acrobat PDFMaker Office COM Addin is not listed, choose COM Add-

Ins from the Manage pop-up menu and click Go.

• If PDFMOutlook or Acrobat PDFMaker Office COM Addin is listed under Disabled 

Application Add-ins, select Disabled Items from the Manage pop-up menu and click Go.

• Select PDFMOutlook or Acrobat PDFMaker Office COM Addin and click OK. 

• Restart the Office application.

View PDFMaker conversion settings

PDFMaker conversion settings determine what features of the Microsoft Word document will be included in 

the PDF and how they will be translated into the resulting PDF file.

Do one of the following: 
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•  Choose Adobe PDF > Change Conversion Settings (See “Figure 35 Change PDFMaker Settings 

in Word 2003” on page 54)

Figure  35 Change PDFMaker Settings in Word 2003

• (Office 2007) In the Acrobat ribbon, click Preferences (See “Figure 36 Acrobat Preferences in 

Word 2007” on page 54).

Figure  36 Acrobat Preferences in Word 2007

If you wish to revert to the original default settings, click Restore Defaults on the Settings tab.

Settings Tab

The settings available for PDFMaker depend on the application in which you’re using PDFMaker (See 

“Figure 37 PDFMaker Settings Tab” on page 56). 

• Conversion Settings . Specifies the standard by which the PDF will be optimized. When 

you choose an item in the menu, a description of that preset appears immediately below it. 

• View Adobe PDF Result . Opens the converted document directly into Acrobat. 

(Exception: when you choose Convert To Adobe PDF And Email.) 

• Prompt For Adobe PDF File Name . Lets you enter a custom filename for the resulting 

PDF. Deselect this option to save the file in the same folder as the source file, using the 

same name but with a .pdf extension. 

• Convert Document Information . Adds document information from the Properties 

dialog box of the source file. This setting overrides the printer preferences and settings in 

the Advanced panel of the Adobe PDF Settings dialog box. 

Note: The Advanced Settings button opens the Adobe PDF Settings dialog box, which contains 

many additional conversion options. These conversion settings apply to all Acrobat 
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features that create PDFs, such as Acrobat Distiller, PDFMaker, and the Acrobat 

application itself. 

• Create PDF/A Compliant PDF File . Creates the PDF so that it conforms to this ISO 

standard for long-term preservation of electronic documents. (In the Microsoft Publisher 

application alone, PDFMaker does not support the PDF/A standard.) 

Note: When Conversion Settings are opened from within Word, Excel, or PowerPoint, this 

option specifies PDF/A 1-a:2005. When opened from within Microsoft Visio, Access, 

Microsoft Project, or AutoCAD, it specifies PDF/A 1-b:2005.

• Attach Source File . Includes the Word document that is being converted as an 

attachment to the resulting PDF.

• Create Bookmarks . Converts certain elements in original Office documents to PDF 

bookmarks: Word headings, Excel worksheet names, or PowerPoint titles. Selecting this 

option overrides any settings on the Bookmarks tab of the Conversion Settings dialog box. 

• Add Links . Includes active links and hypertext in the PDF. 

Note: If this option is deselected, but the recipient of the PDF has the Create Links From URLs 

preference selected, URLs in the PDF are still active. For more information, see 

Preferences for viewing PDFs. 

• Enable Accessibility And Reflow With Tagged Adobe PDF . Embeds tags in the PDF 

(on by default).
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Figure  37 PDFMaker Settings Tab

Security Tab

The Security tab settings available for PDFMaker depend on the application in which you’re using 

PDFMaker (See “Figure 38 PDFMaker Security Tab” on page 57). 

• Require A Password To Open The Document . When selected, makes the Document 

Open Password option available, where you enter a password that users must use to open 

the document. 

• Restrict Editing And Printing Of The Document . When selected, makes the other 

Permissions options available. 

• Change Permissions Password . Specifies a password you set that users must use in order 

to do any allowable printing or editing. 

• Printing Allowed . Specifies whether users who use the Permissions Password can print 

the document and at what resolution. 

• Changes Allowed . Specifies what kind of changes users who use the Permissions 

Password can make. 

• Enable Copying Of Text, Images, And Other Contents . Prevents or allows users from 

copying from the PDF. 

• Enable Text Access For Screen Reader Devices For The Visually Impaired . Prevents or 

allows screen reader devices to read text. (Selected by default.) 

• Enable Plaintext Metadata . Specifies whether the search engine can read the document 

metadata. Available only when the PDF-compatibility is set to Acrobat 6.0 (PDF 1.5) or 

later.
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Figure  38 PDFMaker Security Tab

Word Tab

Use the Word Tab to control how certain features in Microsoft Word will be rendered in PDF (See “Figure 

39 PDFMaker Word Tab” on page 58).

• Convert Displayed Comments To Notes In Adobe PDF . Changes any Word comment 

entries to PDF comments. If the currently open Word document contains comments, 

more options appear in the Comments list on this tab: 

• Reviewer. Lists the names of reviewers who have entered comments in the current 

Word document. 

• Include. When deselected, does not include the comments in the PDF. 

• Notes Open. Specifies whether the PDF comment windows automatically open or are 

closed for that reviewer’s comments. 

• Color . Shows the color for that reviewer’s comment icons. Clicking the color icon 

repeatedly cycles through a limited set of available colors. 

• # Of Comments . Shows the number of comments that the reviewer made. 

• Convert Cross-References And Table Of Contents To Links (Word 2002 and 2003 only). 

Enables one-click navigation of these elements in the new PDF. This option is not 

available in Word 2007. 

• Convert Footnote And Endnote Links . Integrates these into the PDF. 

• Enable Advanced Tagging . Integrates this into the PDF. Useful for Microsoft Word 

forms.
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Figure  39 PDFMaker Word Tab

Bookmarks Tab (Microsoft Word)

The options you specify on this tab determine which items are converted into PDF bookmarks in the PDF 

(See “Figure 40 PDFMaker Bookmarks Tab” on page 59).

Note: To include bookmarks in the conversion process, the Add Bookmarks To Adobe PDF 

option on the Settings tab must be selected. If you deselect that option, it overrides any 

options you select on this tab and no bookmarks are created. 

• Convert Word Headings To Bookmarks . Selects all the headings in the Elements list for 

conversion to PDF bookmarks. 

• Convert Word Styles To Bookmarks . Selects all the text styles in the Elements list for 

conversion to PDF bookmarks. (Unselected by default.) 

• Convert Word Bookmarks . Converts any user-created Word bookmarks to PDF 

bookmarks. 

• Element list . Specifies which Word headings and styles are converted to PDF bookmarks. 

• Element . Lists the names of all available Word headings and styles. The icons for 

Headings and Styles indicate the element types. 

• Type . Also indicates whether the element is a heading or style in the Word 

document. 

• Bookmark . Displays X’s, indicating whether individual elements are converted to 

PDF bookmarks. Clicking an individual Bookmark option changes the selection 

status for that element. 
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• Level . Specifies where the element fits in the hierarchy structure of the PDF 

Bookmarks panel. Clicking an individual Level number opens a menu that you can 

use to change the value. 

Note: When some but not all of the available Word headings and styles are selected for 

conversion to PDF bookmarks, the marker in the corresponding check boxes at the top of 

the tab change. If all elements of the type are selected, a check mark appears. If only some 

of the elements of that type are selected, a colored square appears. Otherwise, the check 

box is empty.

Figure  40 PDFMaker Bookmarks Tab

Video Tab (Microsoft Word and PowerPoint)

The options you specify on this tab determine settings for multimedia files that are converted to FLV format 

and inserted into Word or PowerPoint files (See “Figure 41 PDFMaker Video Tab” on page 60).

• Save Video In . To save the converted video file in the same folder as the document, select 

Same As Document Folder. To save the converted video file in a different folder, select Use 

This Folder, and click Browse to locate and select a folder. 

• Video Quality . A higher Video Quality setting results in a larger PDF file size. 

• Deinterlace . Activates the video deinterlacing filter, which can improve video quality. 

• Encode Audio . If unselected, the converted video file does not include audio. If selected, 

specify the data rate at which to encode the audio in the FLV file.
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Figure  41 PDFMaker Video Tab

Settings for Other Microsoft Office Applications

There are application specific options on the settings tab of the PDFMaker for other Microsoft Office 

applications.

Excel-specific options on the Settings tab

These options are specific to the Settings tab in the PDFMaker for the Excel spreadsheet application.

• Convert Comments . Converts user-created Excel comments to notes and lists them in 

the Acrobat Comments panel. 

• Fit Worksheet To A Single Page . Adjusts the size of each worksheet so that all the entries 

on that worksheet appear on the same page of the PDF. 

• Fit To Paper Width . Adjusts the width of each worksheet so that all the columns on that 

worksheet appear on one page in the PDF. 

• Prompt For Selecting Excel Sheets . Opens a dialog box at the beginning of the file 

conversion process. In this dialog box, you can specify which worksheets are included in 

the PDF and the order in which the sheets appear in the PDF. 

PowerPoint-specific options on the Settings tab

These options are specific to the Settings tab in the PDFMaker for the PowerPoint presenation application.

• Convert Multimedia . Converts any linked audio-video file to an FLV file and embeds it 

in the PDF. 
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• Preserve Animation (PowerPoint 2002 and 2003 only) . Converts any animation effects 

in the PowerPoint file to equivalent animations in the PDF. This option is not available in 

PowerPoint 2007. 

• Preserve Slide Transitions . Converts PowerPoint slide transition effects to PDF 

transition effects. 

• Convert Hidden Slides To PDF Pages . Converts any PowerPoint slides that are not seen 

in the usual playing of the presentation to PDF pages. 

• Convert Speaker Notes . Converts any speaker notes for the PowerPoint presentation 

into Text notes in the PDF. 

• Use PowerPoint Printer Settings (PowerPoint 2002 and 2003 only) . Uses the same 

printer settings in the PDF as in the original file. This option is not available in PowerPoint 

2007.

Convert the Word Document to Accessible PDF

Open the Microsoft Word file. 

Microsoft Office 2003

There are two controls on the Microsoft Word 2003 interface for converting to accessible PDF (See “Figure 

42 Convert to Adobe PDF in Word 2003” on page 61).

Do one of the following:

• Click the Convert To Adobe PDF button on the Acrobat PDFMaker toolbar

• Convert to Adobe PDF from the Adobe PDF menu

Figure  42 Convert to Adobe PDF in Word 2003

Enter a filename and location for the PDF, and click Save. 

Microsoft Office 2007

Do one of the following:

• Click the Create PDF button from the Create Adobe PDF Group on the Acrobat ribbon (See 

“Figure 43 Create Accessible PDF in Word 2007” on page 61).

Figure  43 Create Accessible PDF in Word 2007
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• Select Save as Adobe PDF from the Office button (See “Figure 44 Save as Accessible PDF in Word 

2007” on page 62).

Figure  44  Save as Accessible PDF in Word 2007

Enter a filename and location for the PDF, and click Save. 

If the Word Document is a Form

If the Word document has been designed as a form and you want it to be a fillable PDF form, prepare the 

document as described. When you are ready to import it into PDF, do so from within Acrobat using the 

Form Wizard. From Acrobat 9 Pro do the following:

• Select Forms > Start Form Wizard

• Check the box indicating “An existing electronic document”

• Select “Import a file from file system” 

• Click the Browse button to locate the desired file

• Click Next

The document will be converted to PDF with Tags and fillable form fields. You may need to edit the results 

within Acrobat.

Check the PDF Version of the Document Using Acrobat

Once you have converted the document, you will still need to check the results in Adobe Acrobat. To check 

the results, begin at Step 5 of the PDF Accessibility Workflow (see  “Step 5: Determine if the PDF File is a 

Tagged PDF File” on page 20).  Depending upon the type of error, you may have to make adjustments in a 

particular location.

• Adjustments to the Conversion Settings

• Repairs You Make to the Source File

• Repairs You Make to the PDF File
Making PDF Accessible with Adobe Acrobat 9 Pro



Creating Accessible PDF Files Using Authoring Applications | 63

Changes to the Conversion Settings

Some repairs will involve changes to the PDFMaker conversion settings. If, for example, your final check 

indicated that the PDF file was not tagged, you would need to verify that the Enable Accessibility and Reflow 

box was checked in the PDFMaker tabbed settings.

Repairs You Should Make in the Source File

Some repairs can be made on the PDF file, but they would be erased the next time a PDF file was created 

from the same source. A good example is missing alternative text descriptions. You can certainly use the 

Touchup Reading Order Tool in Acrobat to add these to a PDF file, but if you want the change to last during 

updates to the file, it is better to add the alternative text in the Word document using the format picture 

dialog (See “Add Alternative Text to Word Graphics and Images” on page 51).

Repairs You Should Make in the PDF File

Some repairs must take place on the PDF file using Adobe Acrobat 9.

Document Language

In some instances, even if the document language has been specified in the source file, the information about 

document language is not conveyed to the PDFMaker.  Setting the language for an entire document in the 

Document Properties dialog box corrects all errors related to this option. 

• Select File > Properties (Ctrl + D)

• In the Language drop down of the Reading Options section choose the appropriate language for the 

document.

Tab Order is Consistent with Structure Order

In some instances, even though the tags have been inherited from the source file, the Accessibility Checker 

will indicate that tab order is inconsistent with structure order. To correct this issue, do the following:

• Open the Pages icon or select View > Navigation Panels > Pages (ALT + VNP)

• Click on any page icon and  type Cntrl + A (Command + A for the Mac OS) to select all the pages

• From the Options button on the pages panel select “Page Properties”

• In the Tab Order Panel, check “Use Document Structure”

Establish Table Headings for Tables

Table headers are not always properly defined after the conversion from Microsoft Word to PDF. Use the 

TouchUp Reading Order Table Editor to change table data cells that should be table headings to table 

headers or change the TD tags directly into TH tags within the tags panel.
Making PDF Accessible with Adobe Acrobat 9 Pro



Creating Accessible PDF Files Using Authoring Applications64 |
Making PDF Accessible with Adobe Acrobat 9 Pro


	Adobe® Acrobat® 9 Pro Accessibility Guide: Best Practices for Accessibility
	Contents
	Contents i
	Introduction 1
	PDF Accessibility 1
	Each PDF File is Different 1
	Two Workflows for Creating Accessible PDF Files 1
	Making an Existing PDF File Accessible 1
	Generating Accessible PDF Files from Authoring Applications 2

	Characteristics of Accessible PDF files 2
	Searchable text 2
	Fonts that allow characters to be extracted to text 2
	Interactive form fields 2
	Other Features: Buttons, hyperlinks, and navigational aids 2
	Document language 3
	Security that will not interfere with assistive technology 3
	Document structure tags and proper read order 3
	Alternative text descriptions 3

	Adobe Acrobat and Adobe Reader Accessibility Features 3
	Features for Accessible Reading of PDFs 3
	Features for Creating Accessible PDFs 3

	Acrobat 9 Pro PDF Accessibility Repair Workflow 5
	PDF Accessibility Workflow Summary 5
	Step 1: Analyze the PDF File 5
	Step 2: Determine if the PDF is a Scanned Document 5
	How to Tell if a PDF File is a Scanned Document 6
	What to Do if the PDF is a Scanned Document 7
	What to Do if the PDF is Not a Scanned Document 8

	Step 3: Add Interactive Features: Form Fields and Buttons 8
	PDF Form Fields 9
	Use Acrobat to Detect and Create Interactive Form Fields 9
	Acrobat Form Wizard 9
	Enter Forms Editing Mode Directly 10

	Create Form Fields Manually 10
	Forms Editing Mode 11
	Creating a New Form Field 11
	Form Field Properties 12
	Tooltips for Form Fields 12
	Tooltips for Radio Buttons 13
	Editing or Modifying an Existing Form Field 14
	Deleting a Form Field 14

	Buttons 15
	Set the Tab Order 15

	Step 4: Add Other Accessibility Features 16
	Document Language 16
	Set Security That Permits Accessibility 17
	Create Accessible Links 19
	Add Bookmarks 19

	Step 5: Determine if the PDF File is a Tagged PDF File 20
	How to Tell if a PDF File is Tagged 20
	What to do if the PDF File is Not Tagged 22
	About the Add Tags Report 22

	What to do if the PDF File is Tagged 23

	Step 6: Determine if the PDF File is Properly Tagged 23
	TouchUp Reading Order Tool (TURO) 23
	Selecting the TouchUp Reading Order Tool 24
	TouchUp Reading Order Tool Options 25
	Tips for using the TouchUp Reading Order tool 26

	Checking Read Order with the Touch Up Read Order Tool 26
	Check reading order with the TouchUp Reading Order tool 27
	Change the reading order by dragging on the page 27
	Change the reading order using the Order panel 27

	Editing Tags with the TouchUp Reading Order Tool 28
	Tag a region 28
	Change the tag for a region 28
	Add or remove content from a tagged region 28
	Split a region into two regions 28
	Apply a heading tag 29
	Remove page elements from the tag structure 29
	Apply a figure tag 29

	Using TouchUp Reading Order to Check and Correct Figure Tags 29
	Adding Alternate Text with the TouchUp Reading Order Tool 30

	Using the TouchUp Reading Order Tool Table Editor 31
	Add a Table Summary 31
	Place the Table in Editing Mode 31

	Remove or replace document structure tags 35
	Replace the existing tag structure 35
	Remove all tags from a PDF 35
	Complex Structures 35
	Content Panel 35
	Content Tab Options 37

	Order Panel 37
	Tags Panel 38
	Edit tags with the Tags Panel 39
	Edit a tag title 40
	Move a tag 40
	Change the element type 40
	Tags tab options 40
	Add alternate text and supplementary information to tags 41
	Add alternate text to links 42
	Add alternate text for a figure 42
	Add alternate text for an abbreviated term 42
	Create a new child tag 43
	Add tags to comments 43

	Correct table tags with the Tags tab 43
	Check table elements 43
	Set ColSpan and RowSpan attributes 44


	Step 7: Use the Accessibility Checker to Evaluate the PDF File 44
	Quick Check 44
	Quick Check Results 44

	Full Check 45
	Accessibility Full Check Options 46
	Continue Checking Until All Issues are Addressed 47

	Additional Validation Techniques 47

	Creating Accessible PDF Files Using Authoring Applications 49
	Introduction 49
	Create an Accessible Microsoft Word Document 49
	Use Styles 49
	Text 49
	Headings 50
	Word 2003 Headings 50
	Word 2007 Headings 50

	Add Alternative Text to Word Graphics and Images 51
	Word 2003 51
	Word 2007 51


	Configure the PDFMaker 52
	Show or activate PDFMaker in Microsoft Word 53
	For Office 2003 or earlier, 53
	For Office 2007 53

	View PDFMaker conversion settings 53
	Settings Tab 54
	Security Tab 56
	Word Tab 57
	Bookmarks Tab (Microsoft Word) 58
	Video Tab (Microsoft Word and PowerPoint) 59

	Settings for Other Microsoft Office Applications 60
	Excel-specific options on the Settings tab 60
	PowerPoint-specific options on the Settings tab 60


	Convert the Word Document to Accessible PDF 61
	Microsoft Office 2003 61
	Microsoft Office 2007 61

	If the Word Document is a Form 62
	Check the PDF Version of the Document Using Acrobat 62
	Changes to the Conversion Settings 63
	Repairs You Should Make in the Source File 63
	Repairs You Should Make in the PDF File 63
	Document Language 63
	Tab Order is Consistent with Structure Order 63
	Establish Table Headings for Tables 63


	Introduction
	PDF Accessibility
	Each PDF File is Different
	Two Workflows for Creating Accessible PDF Files
	Making an Existing PDF File Accessible
	Generating Accessible PDF Files from Authoring Applications

	Characteristics of Accessible PDF files
	Searchable text
	Fonts that allow characters to be extracted to text
	Interactive form fields
	Other Features: Buttons, hyperlinks, and navigational aids
	Document language
	Security that will not interfere with assistive technology
	Document structure tags and proper read order
	Alternative text descriptions

	Adobe Acrobat and Adobe Reader Accessibility Features
	Features for Accessible Reading of PDFs
	Features for Creating Accessible PDFs

	Acrobat 9 Pro PDF Accessibility Repair Workflow
	PDF Accessibility Workflow Summary
	Step 1: Analyze the PDF File
	Step 2: Determine if the PDF is a Scanned Document
	How to Tell if a PDF File is a Scanned Document
	What to Do if the PDF is a Scanned Document
	What to Do if the PDF is Not a Scanned Document

	Step 3: Add Interactive Features: Form Fields and Buttons
	PDF Form Fields
	Use Acrobat to Detect and Create Interactive Form Fields
	Acrobat Form Wizard
	Enter Forms Editing Mode Directly

	Create Form Fields Manually
	Forms Editing Mode
	Creating a New Form Field
	Form Field Properties
	Tooltips for Form Fields
	Tooltips for Radio Buttons
	Editing or Modifying an Existing Form Field
	Deleting a Form Field

	Buttons
	Set the Tab Order

	Step 4: Add Other Accessibility Features
	Document Language
	Set Security That Permits Accessibility
	Create Accessible Links
	Add Bookmarks

	Step 5: Determine if the PDF File is a Tagged PDF File
	How to Tell if a PDF File is Tagged
	What to do if the PDF File is Not Tagged
	About the Add Tags Report

	What to do if the PDF File is Tagged

	Step 6: Determine if the PDF File is Properly Tagged
	TouchUp Reading Order Tool (TURO)
	Selecting the TouchUp Reading Order Tool
	TouchUp Reading Order Tool Options
	Tips for using the TouchUp Reading Order tool

	Checking Read Order with the Touch Up Read Order Tool
	Check reading order with the TouchUp Reading Order tool
	Change the reading order by dragging on the page
	Change the reading order using the Order panel

	Editing Tags with the TouchUp Reading Order Tool
	Tag a region
	Change the tag for a region
	Add or remove content from a tagged region
	Split a region into two regions
	Apply a heading tag
	Remove page elements from the tag structure
	Apply a figure tag

	Using TouchUp Reading Order to Check and Correct Figure Tags
	Adding Alternate Text with the TouchUp Reading Order Tool

	Using the TouchUp Reading Order Tool Table Editor
	Add a Table Summary
	Place the Table in Editing Mode

	Remove or replace document structure tags
	Replace the existing tag structure
	Remove all tags from a PDF
	Complex Structures
	Content Panel
	Content Tab Options

	Order Panel
	Tags Panel
	Edit tags with the Tags Panel
	Edit a tag title
	Move a tag
	Change the element type
	Tags tab options
	Add alternate text and supplementary information to tags
	Add alternate text to links
	Add alternate text for a figure
	Add alternate text for an abbreviated term
	Create a new child tag
	Add tags to comments

	Correct table tags with the Tags tab
	Check table elements
	Set ColSpan and RowSpan attributes


	Step 7: Use the Accessibility Checker to Evaluate the PDF File
	Quick Check
	Quick Check Results

	Full Check
	Accessibility Full Check Options
	Continue Checking Until All Issues are Addressed

	Additional Validation Techniques

	Creating Accessible PDF Files Using Authoring Applications
	Introduction
	Create an Accessible Microsoft Word Document
	Use Styles
	Text
	Headings
	Word 2003 Headings
	Word 2007 Headings

	Add Alternative Text to Word Graphics and Images
	Word 2003
	Word 2007


	Configure the PDFMaker
	Show or activate PDFMaker in Microsoft Word
	For Office 2003 or earlier,
	For Office 2007

	View PDFMaker conversion settings
	Settings Tab
	Security Tab
	Word Tab
	Bookmarks Tab (Microsoft Word)
	Video Tab (Microsoft Word and PowerPoint)

	Settings for Other Microsoft Office Applications
	Excel-specific options on the Settings tab
	PowerPoint-specific options on the Settings tab


	Convert the Word Document to Accessible PDF
	Microsoft Office 2003
	Microsoft Office 2007

	If the Word Document is a Form
	Check the PDF Version of the Document Using Acrobat
	Changes to the Conversion Settings
	Repairs You Should Make in the Source File
	Repairs You Should Make in the PDF File
	Document Language
	Tab Order is Consistent with Structure Order
	Establish Table Headings for Tables



