root/gs2-extensions/gnome-lib

Revision Log Mode:


Legend:

Added
Modified
Copied or renamed
Rev Chgset Date Author Log Message
(edit) @30804 [30804] 3 years ak19 Correcting spelling error. Need to adjust the reference in Dr Bainbridge's …
(edit) @30756 [30756] 3 years davidb Moving to a newer version to get beyond a compilation error message on El …
(edit) @30746 [30746] 3 years davidb Version compiled up on El Capitain laptop
(edit) @30467 [30467] 4 years ak19 Dr Bainbridge fixed gnome-lib compilation on Yosemite by updating …
(edit) @29344 [29344] 5 years ak19 Dr Bainbridge got gnome-lib compiling again on the Ubuntu that runs …
(edit) @28828 [28828] 6 years ak19 CUPS.sh needs disable-gssapi in order to compile CUPS on Mac Maverick …
(edit) @28573 [28573] 6 years ak19 Removed the *.la files (in the OS/lib folder) since this causes …
(edit) @28569 [28569] 6 years ak19 Dr Bainbridge fixed the bug that was preventing compilation of wvware and …
(edit) @28326 [28326] 6 years ak19 Mac 11/12 (Lion/Mountain Lion) need CUPS. Mac 9/10 (Leopard, Snow Leopard) …
(edit) @28322 [28322] 6 years ak19 Dr Bainbridge had earlier added in sourcing of imagemagick's devel.bash in …
(edit) @28313 [28313] 6 years ak19 Fixed two more instances of misplaced dot-slash in the recent commits to …
(edit) @28306 [28306] 6 years ak19 Fixing typing errors in previous commit
(edit) @28305 [28305] 6 years ak19 More cases of needing to source a script using source dot-slash-script
(edit) @28304 [28304] 6 years ak19 More cases of needing to source a script using source dot-slash-script
(edit) @28303 [28303] 6 years ak19 Dr Bainbridge fixed a crucial problem in the gnomelib devel.bash file, …
(edit) @28300 [28300] 6 years ak19 Rename/move operation.
(edit) @28298 [28298] 6 years ak19 Adding a README for compiling and using the gnome-lib package, and …
(edit) @28294 [28294] 6 years ak19 Used the new makeminimal CASCADE-MAKE command to regenerate the …
(edit) @28293 [28293] 6 years ak19 Adding in the makeminimal command for gnomelib, to produce the minimal …
(edit) @28291 [28291] 6 years ak19 Adding in the gnome-lib-minimal archive for Lion/Mountain lions.
(edit) @28286 [28286] 6 years ak19 On the latest Mac we found that gnome-lib failed to compile properly and …
(edit) @27633 [27633] 6 years sjm84 Under linux, test for linux/magic.h causes a compilation error on older …
(edit) @27225 [27225] 7 years ak19 Adding a README file tracking the changes made to various packages to get …
(edit) @27224 [27224] 7 years ak19 Replaced by gs-libxml2-2.9.0.tar.gz
(edit) @27223 [27223] 7 years ak19 Replaced by gs-glib-2.28.1.tar.gz
(edit) @27219 [27219] 7 years ak19 gs-glib package needs to extract as gs-glib not as glib, same as the …
(edit) @27217 [27217] 7 years ak19 The unpacked glib and libxml packages are expected to have the gs- prefix …
(edit) @27198 [27198] 7 years ak19 If a source code version of imagemagick exists in the gs2build ext folder, …
(edit) @27197 [27197] 7 years ak19 Needed to make changes to 2 packages to get gnome-lib src code to compile …
(edit) @26823 [26823] 7 years davidb Further patch needed for dbus
(edit) @26814 [26814] 7 years davidb More careful selection of packages, as needed by various cross-compilers
(edit) @26813 [26813] 7 years davidb Adjustments to help compilation with Android NDK
(edit) @26812 [26812] 7 years davidb Tweaks needed for compiling with Android NDK
(edit) @26811 [26811] 7 years davidb dbus used/needed by Android compile of glib
(edit) @26810 [26810] 7 years davidb dbus used/needed by Android compile of glib
(edit) @26807 [26807] 7 years davidb Helpful script to reset cross-compilation
(edit) @26790 [26790] 7 years davidb Config update needed by Android NDK now in a separate file
(edit) @26788 [26788] 7 years davidb Cascade make can now patch files if needed
(edit) @26787 [26787] 7 years davidb Files that patch code fro Android NDK
(edit) @26786 [26786] 7 years davidb Changes for Android NDK
(edit) @26785 [26785] 7 years davidb Newer version to help with compilation with Android NDK
(edit) @26784 [26784] 7 years davidb Commented out line added for future proofing of using a newer glib tar …
(edit) @26783 [26783] 7 years davidb Changes that resulted from testing under Android NDK
(edit) @26782 [26782] 7 years davidb Change to newer version resulting from Android NDK testing
(edit) @26781 [26781] 7 years davidb New package that newer versions of glib depends on
(edit) @26764 [26764] 7 years davidb Cross compile script initial developed for mingw on Linux. In the process …
(edit) @26763 [26763] 7 years davidb Needed for packages using autoconfigure that predate Android coming on to …
(edit) @26762 [26762] 7 years davidb More careful control of ./configure to avoid unneeded …
(edit) @26761 [26761] 7 years davidb Typo fix in if-statement, and more carely setting of variables fro …
(edit) @26740 [26740] 7 years davidb More careful setting of crtdll for cross-compiling for Windows only
(edit) @26628 [26628] 7 years davidb Upgrade to 2.2.9 triggered by adding support for cross-compiling (using …
(edit) @26626 [26626] 7 years davidb Minor tweak to the code made (the 'build-aux/moopp' file needed some …
(edit) @26625 [26625] 7 years davidb Cross-compilation support added (mingw under Linux)
(edit) @26624 [26624] 7 years davidb Needed when cross-compiling (using mingw under Linux) but not (as the …
(edit) @26623 [26623] 7 years davidb Minor tweaks to help with compilation with mingw under Linux …
(edit) @26622 [26622] 7 years davidb Minor tweak added to help with compilation with mingw under Linux …
(edit) @26621 [26621] 7 years davidb Cross-compilation support added (mingw under Linux)
(edit) @26620 [26620] 7 years davidb Cross-compilation support added (mingw under Linux)
(edit) @26619 [26619] 7 years davidb Cross-compilation support added (mingw under Linux) which in turn needed …
(edit) @26618 [26618] 7 years davidb Newline added to end of file
(edit) @24814 [24814] 8 years ak19 devel.bash has to source setup.bash_old not setup.bash
(edit) @24378 [24378] 8 years ak19 For ticket 779: wvware's environment, including necessary gnome-lib …
(edit) @24377 [24377] 8 years ak19 For ticket 779: wvware's env including lib is set in wvware.pl, no longer …
(edit) @24376 [24376] 8 years ak19 For ticket 779: wvware's env including lib is set in wvware.pl, no longer …
(edit) @23719 [23719] 9 years sjm84 Again reverting back to an earlier version of the intel darwin gnome-lib …
(edit) @23718 [23718] 9 years sjm84 Removed iconv again, as another way to solve the problem was discovered
(edit) @23716 [23716] 9 years sjm84 Added iconv for mac only
(edit) @23715 [23715] 9 years sjm84 These intel darwin tarballs have a daarwin version of iconv added in an …
(edit) @23713 [23713] 9 years sjm84 Recommiting the previous versions of the darwin intel gnome-lib tarballs …
(edit) @23702 [23702] 9 years sjm84 Added iconv to the gnome-lib for darwin to try and help fix the strange …
(edit) @23640 [23640] 9 years sjm84 Created power pc versions of the gnome-lib tarballs for Darwin. Added …
(edit) @23631 [23631] 9 years sjm84 libpng isn't necessary on Mac
(edit) @23630 [23630] 9 years sjm84 Added libpng to the gnome-lib and updated the gnome-lib tarballs
(edit) @23629 [23629] 9 years sjm84 Added libpng to the gnome-lib and updated the gnome-lib tarballs
(edit) @23626 [23626] 9 years sjm84 Fixing the minimal 64-bit linux gnome-lib tarball
(edit) @23625 [23625] 9 years sjm84 Updating the two 64-bit linux gnome lib tarballs
(edit) @23624 [23624] 9 years sjm84 Updated the two darwin gnome-lib tarballs
(edit) @23623 [23623] 9 years sjm84 Updated the two 32-bit Linux gnome-lib tarballs
(edit) @23622 [23622] 9 years sjm84 Adding readline to the gnome-lib extension as it is needed by several …
(edit) @23616 [23616] 9 years sjm84 Must have made a mistake when committing the minimal Darwin version of the …
(edit) @23605 [23605] 9 years sjm84 Correcting the setup.bash for the full and minimal versions of the darwin …
(edit) @23604 [23604] 9 years sjm84 Correcting the setup.bash for the full and minimal versions of the 64-bit …
(edit) @23602 [23602] 9 years sjm84 Correcting the setup.bash for the full and minimal versions of the linux …
(edit) @23601 [23601] 9 years sjm84 Fixed a mistake in previous commit -> Updated gnome-lib's setup.bash to …
(edit) @23600 [23600] 9 years sjm84 Updated gnome-lib's setup.bash to work with Greenstone 3
(edit) @23579 [23579] 9 years sjm84 Added a minimal version of the gnome-lib tarball for x64 Linux
(edit) @23576 [23576] 9 years sjm84 Adding a minimal version of the gnome-lib tarball for darwin
(edit) @23573 [23573] 9 years sjm84 Adding back the non-minimal gnome-lib linux tarball
(edit) @23563 [23563] 9 years sjm84 Added the include folder back into the minimal linux gnome-lib tarball
(edit) @23560 [23560] 9 years sjm84 Renaming the recently created linux gnome-lib tarball to …
(edit) @23559 [23559] 9 years sjm84 Creating a new gnome-lib tarball with the fixed devel.bash and with the …
(edit) @23558 [23558] 9 years sjm84 Added PKG_CONFIG_PATH to the list of environment variables set by …
(edit) @23524 [23524] 9 years sjm84 Created an updated version of the pre-compiled gnome-lib extension for …
(edit) @23375 [23375] 9 years sjm84 Adding XML-Parser and expat to the packages needed for gnome-lib
(edit) @23339 [23339] 9 years sjm84 The pre-built linux gnome-lib is now lsb 3.1 compatible
(edit) @23275 [23275] 9 years sjm84 Adding a 64-bit gnome-lib that has been compiled on Ubuntu x64
(edit) @23274 [23274] 9 years sjm84 LIBBZ2 needs -fPIC when compiling for 64-bit
(edit) @23260 [23260] 9 years sjm84 Added the -fPIC argument to the CFLAGS of the bz2 library in the gnome-lib …
(edit) @23152 [23152] 9 years sjm84 Renamed the directory within this tar.gz
(edit) @23151 [23151] 9 years sjm84 Changed the linux gnome-lib tar.gz file to be compiled on Hinau instead of …
Note: See TracRevisionLog for help on using the revision log.