Ticket #263 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

John Rose's problems with GLI client on XP Home

Reported by: kjdon Owned by: oranfry
Priority: moderate Milestone:
Component: GLI Severity: blocker
Keywords: Cc:

Description

Intermittent problem.

greenstone 2.80, XP Home edition.

Run GLI client, it would start up ok, but then when opening an existing collection or creating a new collection, sometimes it would hang. We had periods of time where it almost always failed, periods where it almost always worked, and some where it randomly did or didn't work.

The client is sending requests to the server, and waiting for the response. It appears that the request is completed but the client doesn't realise so its still waiting for completion, and the program hangs cos it can't do anything else while its waiting.

It hangs at different places - I have had some stop at get-script-options for buildcol.pl, get-script-options for pluginfo.pl on HTMLPlug and WordPlug?.

We had the same thing happen connecting to server on localhost, and connecting through a proxy to kanuka.

I have had a couple of times where you get a collection open then try to create a new one and it hangs, so its not just the first time you run it.

Is this just a problem with John's computer? We need to try on another XP Home machine and see if we can reproduce the problem.

Change History

Changed 11 years ago by oranfry

  • owner changed from nobody to oranfry
  • status changed from new to assigned
  • severity set to blocker

I installed Greenstone 2.80 and Apache 2.2.8 on David Bainbridge's laptop running XP Home, and was unable to reproduce the problem. Because the problem was classed as intermittent, I started and stopped the gli client five times to be thorough, but it worked each time. I was able to rebuild collections, too.

We can only hope that the problems John encountered were a result of the conditions on his machine. Is it time to close this ticket?

Changed 11 years ago by oranfry

  • status changed from assigned to closed
  • resolution set to worksforme
Note: See TracTickets for help on using tickets.