Ticket #264 (closed task: wontfix)

Opened 13 years ago

Last modified 12 years ago

GS3 Java 1.4 minimum requirement should be 1.5

Reported by: dmn Owned by: kjdon
Priority: moderate Milestone: 3.05 Release
Component: Greenstone3 Runtime Severity: minor
Keywords: Cc:


In build.xml we have

<fail if="java.too.old" message="You need Java 1.4 or greater to run Greenstone 3"/>


however, in the Tomcat release notes it says:

"Tomcat 5.5 is designed to run on J2SE 5.0 and later and requires configuration to run on J2SE 1.4."


Surely we should enforce this guidance?

Change History

Changed 13 years ago by dmn

  • owner changed from nobody to kjdon

Changed 13 years ago by dmn

  • severity set to blocker
  • milestone changed from Release 3.04 to Release 3.05

this is related to JavaScript? processing of metadata:


is Rhino in Java written using 1.5 constructs?


Changed 13 years ago by dmn

  • type changed from defect to task

Changed 13 years ago by dmn

for reference, the version release dates are:

J2SE 1.4 (February 6, 2002) J2SE 5.0 (September 30, 2004) Java SE 6 (December 11, 2006)


Changed 13 years ago by dmn

  • severity changed from blocker to minor

Changed 12 years ago by dmn

Also, if we want to do Greenstone + Fedora then Fedora's min. requirement is 1.5:


"Whether installing a binary or source distribution, JDK 5.0 is required. The JDK should be installed on the machine you intend to use as the Fedora server." Fedora 2.2.1

Changed 12 years ago by dmn

  • status changed from new to closed
  • resolution set to wontfix
Note: See TracTickets for help on using tickets.