Ticket #395 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Download panel problems

Reported by: ak19 Owned by: ak19
Priority: moderate Milestone: Release 2.81
Component: GLI Severity: major
Keywords: Download Cc:

Description

Prof Witten identified several problems to do with the Download panel.


Subject: Problems with Download panel Date: Wed, 27 Aug 2008 05:02:36 +1200 From: Ian Witten <ian.witten@…> To: Kathy Don <kjdon@…>, David Bainbridge <davidb@…>

I've been playing with the Greenstone Download panel and encountered a few problems. Maybe it's just my setup here and things have been fixed since I downloaded Greenstone just before I left. But if not, it would be great if these were fixed before the upcoming release, though maybe they're not top priority -- I'll leave the decision up to you. The *'d ones are probably enhancements that you shouldn't consider for the next release, the ?? one is probably not our problem at all.

1. I just rebuilt the OAI demo collection (oai-e), and the extracted metadata in the Enrich panel looked like ex..Title, etc (with two dots). Although the collection built, the classifiers etc were wrong of course.

2. When using the Download panel to download websites, the Get Information button produces a popup panel that is completely blank.

3. When downloading from  http://englishhistory.net/tudor/citizens with both the "below this URL" and "within the same site" options switched on and a download depth of 2, it downloads about 450 files including ones like  http://englishhistory.net/tudor/*. But the "below this URL" option should have prevented this, no?

4. *? When you download from the same place with a download depth of 1, you get about 35 files including a few (4, I think) with names like  http://englishhistory.net/tudor/citizens/?N=D. Can this be prevented?

5. ?? If you then download a second time, it re-downloads some of the files even though they haven't changed. (some message about the timestamp not being set, maybe it should be set by the webserver and there's nothing we can do about this).

6. * The log file accumulates, whereas in the interface it seems clear that the log file pertains only to the download operation that you have just done. It's really confusing.

7. I couldn't get the Z39.50 or SRW/SRU parts of the Download panel to work at all. E.g. I tried with

  • Host: z3950.loc.gov
  • Port: 7090
  • Database: Voyager

(see www.loc.gov/z3950/lcserver.html#addr).

Change History

Changed 11 years ago by ak19

I think Katherine fixed 1 just recently.

2, 3 and 7 have been fixed. In fixing 7, a problem not identified in the above--improper termination of Z3950 and SRW--has also been fixed. They are now terminated by sending the "quit" command.

Task 6 is listed in a separate ticket.

Timestamping is turned on when the GS perl scripts issue their wget commands, so 5 seems to be out of our hands.

Regarding 4, these 4 extra pages are located at the static links like N=D. Unless exclusion filters are used, these will be downloaded.

Changed 11 years ago by kjdon

  • status changed from new to closed
  • resolution set to fixed

It looks like these are all either fixed or not our problem, or moved to another ticket, so I am closing this.

Note: See TracTickets for help on using tickets.