Ticket #415 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

GS3: ant.jar not in WEB-INF/lib folder and not mentioned in manifest file

Reported by: ak19 Owned by: oranfry
Priority: very high Milestone: 3.04 Release
Component: Greenstone3 Runtime Severity: blocker
Keywords: Cc:

Description

There's an ant.jar file in GS3's WEB-INF/lib that looks like it should be included in the directory and mentioned in the manifest file in cp.jar. But it's not. Does it need to go into the release kit somewhere.

Need to be able to call org.apache.tools.ant.* methods, classes.

How do you call the ant tasks from java without ant.jar being included in the classpath or in the distribution?

Change History

Changed 11 years ago by dmn

Clarifying: the ant.jar isn't in the /lib folder (or the cp.jar manifest) but looks like it should be.

When Eric downloads the ant/jar file from the Apache website it works, but when using the ant.jar from Trac it fails:

http://trac.greenstone.org/browser/release-kits/shared/ant/lib/ant.jar

with a componentdef failure

This is to support the calling of Ant targets from Java in the Admin client - so needs to be in binary distribution as well.

Changed 11 years ago by dmn

update: GAI.jar is now in WEB-INF/lib and Anu wrote a gs3-admin.bat script. /lib/cp.jar is in the classpath but GAI.jar is not in the cp.jar manifest.

C:\Documents and Settings\daven\My Documents\Greenstone3>gs3-admin.bat

gsdl3srchome: C:\Documents and Settings\daven\My Documents\Greenstone3 gsdl3srchome: C:\Documents and Settings\daven\My Documents\Greenstone3\web javahome: classpath: .;C:\Program Files\Java\jre1.6.0_05\lib\ext\QTJava.zip;.;C:\Documents

and Settings\daven\My Documents\Greenstone3\web\WEB-INF\classes;C:\Documents an

d Settings\daven\My Documents\Greenstone3\resources\java;C:\Documents and Settin gs\daven\My Documents\Greenstone3\server.jar;C:\Documents and Settings\daven\My Documents\Greenstone3\web\WEB-INF\lib\cp.jar;C:\Documents and Settings\daven\My Documents\Greenstone3\lib\jni\cp.jar;C:\Documents and Settings\daven\My Document s\Greenstone3\build\cp.jar;C:\Documents and Settings\daven\My Documents\Greensto ne3\packages\tomcat\common\endorsed\xercesImpl.jar;C:\Documents and Settings\dav en\My Documents\Greenstone3\packages\tomcat\common\endorsed\xml-apis.jar

Exception in thread "main" java.lang.NoClassDefFoundError?: org/greenstone/admin/ GAI Caused by: java.lang.ClassNotFoundException?: org.greenstone.admin.GAI

at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController?.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader?.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader?.loadClass(Unknown Source) at java.lang.ClassLoader?.loadClass(Unknown Source) at java.lang.ClassLoader?.loadClassInternal(Unknown Source)

Changed 11 years ago by dmn

clariying: we need a cp.jar in the packages dir for the ant and svn tasks to be available in Java

Changed 11 years ago by dmn

  • status changed from new to closed
  • resolution set to fixed

closing this as Eric's admin client work has addressed it

Note: See TracTickets for help on using tickets.