Ticket #657 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Classifiers depend on GLI language??

Reported by: kjdon Owned by: kjdon
Priority: moderate Milestone: 2.84 Release
Component: GLI Severity: minor
Keywords: Cc:

Description

John Rose reported (3/5/09)

I just took a collection that I had built under a previous version (probably 2.72) and rebuilt under 2.81 with English as the set language. All of my classifiers showed as blank screens whether I used English or French as the preference (whereas the search indexes showed in either language). Then I changed GLI to French (the language of the collection) and rebuilt, everything seems to be fine. Is this normal? I seem to remember that it was not so in the past (that a French collection could be built with GLI in English and then viewed in Greenstone with any language interface?

* Check whether this is still true or not * What does command line building give? * Is GLI setting language for classifiers? * Is gli setting lang attribute for metadata or something?

Change History

Changed 10 years ago by kjdon

  • milestone changed from Collection building wishlist to 2.84 Release

Changed 10 years ago by kjdon

Check the latest version to see if it behaves the same way that John describes.

Changed 10 years ago by kjdon

  • owner changed from nobody to kjdon
  • status changed from new to assigned

Changed 10 years ago by kjdon

  • status changed from assigned to closed
  • resolution set to fixed

I think this was probably due to GLI writing the wrong metadata names to the config file, eg the French version.

There had been problems in the past with this, but I think they are fixed now. There is no language thing with classifiers.

Note: See TracTickets for help on using tickets.