source: gs2-extensions/gnome-lib/trunk/src/packages/CASCADE-MAKE.sh@ 30862

Last change on this file since 30862 was 30862, checked in by ak19, 5 years ago

Changes to get libiconv issues on MacOS El Capitan straightened out, since DYLD_LIBRARY_PATH gets wiped out on these newer Mac OS versions. The current solution is to use the system libiconv on MacOS machines that are already specific to Macs (and therefore compatible with Macs).

  • Property svn:executable set to *
File size: 2.5 KB
Line 
1#!/bin/bash
2
3source ../cascade-make/lib/cascade-lib.bash GEXTGNOME .. $*
4
5# The standard list of packages
6# For Mac Yosemite we found that PKG-CONFIG is dependent on GLIB, so we've moved GLIB ahead of PKG-CONFIG in the list
7pkglist="LIBZ LIBBZ2 EXPAT LIBPNG READLINE XMLPARSER INTLTOOL GETTEXT GLIB PKG-CONFIG LIBXML LIBFFI LIBGSF"
8
9# libiconv was found to be necessary on the latest DL mac (2013)
10# This triggered the need for 'cups' as well, not because libiconv needed it, but due to
11# glib getting a conflict during its configure stage over the version of iconv
12
13# Mac 11/12 (Lion/Mountain Lion and possibly later versions) need CUPS. Mac 9/10 (Leopard, Snow Leopard) don't need it and gnome-lib fails to compile with it.
14# 14 Oct 2016: Mac 15 (El Capitan and possibly later versions) changed matters again: DYLD_LIBRARY_PATH gets wiped out, leading to libiconv problems
15# The solution was that, since MacOS come with their own special compatible libconv (see https://discussions.apple.com/thread/1931034?start=0&tstart=0),
16# to let MacOS machines use the system libiconv rather than compiling up the one in gnome-lib or the other one used by indexers' jni and mgpp/text, etc.
17# Since CUPS was only included to get libiconv to work, neither are now compiled up with gnome-lib:
18osversion=`uname -r | sed 's/\..*$//'`;
19if [ "x$GSDLOS" = "xdarwin" -a $osversion -ge 11 ] ; then
20# pkglist="LIBZ LIBBZ2 EXPAT LIBPNG READLINE XMLPARSER INTLTOOL CUPS LIBICONV GETTEXT GLIB PKG-CONFIG LIBXML LIBFFI LIBGSF"
21 pkglist="LIBZ LIBBZ2 EXPAT LIBPNG READLINE XMLPARSER INTLTOOL GETTEXT GLIB PKG-CONFIG LIBXML LIBFFI LIBGSF"
22fi
23
24if [ "x$crossOS" != "x" ] ; then
25 # cross compiling
26 windows_pkglist="LIBZ LIBBZ2 EXPAT LIBPNG READLINE INTLTOOL LIBICONV GETTEXT GLIB LIBXML LIBGSF"
27
28 android_pkglist="LIBZ LIBBZ2 EXPAT LIBPNG READLINE INTLTOOL LIBICONV GETTEXT GLIB LIBXML DBUS LIBFFI LIBGSF"
29
30
31 if [ $crossOS = "android" ] ; then
32 pkglist=$android_pkglist
33 elif [ $crossOS = "windows" ] ; then
34 pkglist=$windows_pkglist
35 fi
36
37fi
38
39for d in $pkglist; do
40
41 echo " Running CASCADE-MAKE/$d.sh"
42
43 ./CASCADE-MAKE/$d.sh $*
44
45 if [ $? != 0 ] ; then
46 echo "Error encountered running CASCADE-MAKE/$d.sh"
47 exit 1
48 fi
49done
50
51if [ $install = "1" ] ; then
52 touch "$GEXTGNOME_INSTALLED/lib/pkgconfig/.fixed-prefix.awk"
53fi
54
55if [ $makedist = "1" ] ; then
56 rm -f "$GEXTGNOME_INSTALLED/lib/pkgconfig/.fixed-prefix.awk"
57 lalist=`find $GEXTGNOME_INSTALLED/lib -name "*.la"`
58 if [ -n "$lalist" ] ; then
59 rm -f $lalist
60 fi
61fi
Note: See TracBrowser for help on using the repository browser.