source: local/greenstone2/windows-64bit/setup.bat@ 31424

Last change on this file since 31424 was 31424, checked in by ak19, 4 years ago

Committing helpful comments of older local\setup.bat file for Win64 machines which still need to compile GS2 in 32 bit mode to get apache-httpd to compile. This file has been superseded by devel64-in32mode.bat which will be renamed to setup.bat hereafter.

File size: 2.4 KB
Line 
1@echo off
2echo.
3echo ******************************
4
5:: For notes on compiling GS2 on 64 bit Win 7 see
6:: http://wiki.greenstone.org/doku.php?id=en:developer:compiling_apache&#compiling_the_apache-httpd_included_with_gs2_on_64_bit_windows_7
7
8set JAVA_HOME=C:\Program Files\Java\jdk1.7.0_55
9if not exist "%JAVA_HOME%" echo %JAVA_HOME% does not exist& goto done
10set PATH=%JAVA_HOME%\bin;%PATH%
11
12echo + Set JAVA_HOME=%JAVA_HOME% and updated PATH
13
14set PERL_HOME=C:\Perl64
15if not exist "%PERL_HOME%" echo %PERL_HOME% does not exist& goto done
16set PATH=%PERL_HOME%\bin;%PATH%
17
18echo + Set PERL_PATH=%PERL_HOME% and updated PATH
19
20:: Setup Visual Studio env
21
22:: Running VS in 64 bit mode doesn't work, need to run in 32 bit mode.
23:: For now only VS9.0 (VS2008) works
24:: call "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\Tools\vsvars32.bat"
25set vslocation=C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\Tools
26if not exist "%vslocation%" echo %vslocation% does not exist& goto done
27pushd "%vslocation%"
28call vsvars32.bat
29popd
30
31:: VS10 fails: Common Tools folder not found for VS10
32rem call "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\vcvars32.bat"
33
34:: VS12 fails: Calling "vsvars32.bat" above produces the same error as calling
35:: C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\amd64_x86\vcvarsamd64_x86.bat
36:: (and possibly the same error as calling
37:: C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\vcvarsall.bat without passing "amd64" param)
38rem call "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools\vsvars32.bat"
39
40:: Error: https://groups.google.com/forum/#!topic/UniMRCP/Iybpn51UYnI
41:: http://msdn.microsoft.com/en-us/library/ff770576.aspx
42:: http://stackoverflow.com/questions/11544563/can-i-set-the-platform-toolset-from-the-command-line-when-building-with-vs2010s
43:: /p:PlatformToolset=v100
44
45
46:: If using SetEnv.cmd to set up MS SDK env (no longer needed even for compiling GS2 with debug):
47
48::call "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd"
49:: Run with /? to see what options it takes (/x86, /x64, /ia64, /vista, /xp, /win7 and more)
50
51::set sdklocation=C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin
52::if not exist "%sdklocation%" echo %sdklocation% does not exist& goto done
53::pushd "%sdklocation%"
54::call SetEnv.cmd /x64
55::popd
56
57
58
59:done
60echo Leaving local/setup.bat
61echo ******************************
62echo.
63
Note: See TracBrowser for help on using the repository browser.