source: main/trunk/greenstone2/perllib/XMLParser.pm@ 24706

Last change on this file since 24706 was 24706, checked in by davidb, 11 years ago

'use Config' needs to appear earlier on in the file for the BEGIN block to make use of it. Moved 'use strict' to there as well

  • Property svn:keywords set to Author Date Id Revision
File size: 2.2 KB
Line 
1###########################################################################
2#
3# XMLParser.pm -- Wrapper that ensures the right version of XML::Parser
4# is loaded given the version of Perl being used. Need
5# to distinguish between Perl 5.6 and Perl 5.8
6#
7# A component of the Greenstone digital library software
8# from the New Zealand Digital Library Project at the
9# University of Waikato, New Zealand.
10#
11# Copyright (C) 2005-2010 New Zealand Digital Library Project
12#
13# This program is free software; you can redistribute it and/or modify
14# it under the terms of the GNU General Public License as published by
15# the Free Software Foundation; either version 2 of the License, or
16# (at your option) any later version.
17#
18# This program is distributed in the hope that it will be useful,
19# but WITHOUT ANY WARRANTY; without even the implied warranty of
20# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21# GNU General Public License for more details.
22#
23# You should have received a copy of the GNU General Public License
24# along with this program; if not, write to the Free Software
25# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
26#
27###########################################################################
28
29use strict;
30use Config;
31
32sub BEGIN {
33 my $perl_dir;
34
35 # Note: $] encodes the version number of perl
36 if ($]>=5.010) {
37 $perl_dir = "perl-5.10";
38 }
39 elsif ($]>5.008) {
40 # perl 5.8.1 or above
41 $perl_dir = "perl-5.8";
42 }
43 elsif ($]>=5.008) {
44 # perl 5.8.1 or above
45 $perl_dir = "perl-5.8";
46 }
47 elsif ($]<5.008) {
48 # assume perl 5.6
49 $perl_dir = "perl-5.6";
50 }
51 else {
52 print STDERR "Warning: Perl 5.8.0 is not a maintained release.\n";
53 print STDERR " Please upgrade to a newer version of Perl.\n";
54 $perl_dir = "perl-5.8";
55 }
56
57 if ($ENV{'GSDLOS'} !~ /^windows$/i) {
58 # Use push to put this on the end, so an existing XML::Parser will be used by default
59 if (-d "$ENV{'GSDLHOME'}/perllib/cpan/$perl_dir-mt" && $Config{usethreads}){
60 push (@INC, "$ENV{'GSDLHOME'}/perllib/cpan/$perl_dir-mt");
61 }
62 else{
63 push (@INC, "$ENV{'GSDLHOME'}/perllib/cpan/$perl_dir");
64 }
65 }
66}
67
68use XML::Parser;
69
701;
Note: See TracBrowser for help on using the repository browser.