Changeset 21822


Ignore:
Timestamp:
2010-03-25T21:09:50+13:00 (11 years ago)
Author:
ak19
Message:

Dr Bainbridge has fixed several perl files that depended on perl 5.8 to work and used to fail with Perl 5.10.

Location:
main/trunk/greenstone2
Files:
5 edited

Legend:

Unmodified
Added
Removed
  • main/trunk/greenstone2/bin/script/buildcol.pl

    r21786 r21822  
    3131    unshift (@INC, "$ENV{'GSDLHOME'}/perllib");
    3232    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/cpan");
    33     unshift (@INC, "$ENV{'GSDLHOME'}/perllib/cpan/perl-5.8");
    3433    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/cpan/XML/XPath");
    3534    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/plugins");
  • main/trunk/greenstone2/bin/script/import.pl

    r21664 r21822  
    3636    unshift (@INC, "$ENV{'GSDLHOME'}/perllib");
    3737    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/cpan");
    38     unshift (@INC, "$ENV{'GSDLHOME'}/perllib/cpan/perl-5.8");
    3938    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/plugins");
    4039    unshift (@INC, "$ENV{'GSDLHOME'}/perllib/plugouts");
  • main/trunk/greenstone2/perllib/XMLParser.pm

    r15894 r21822  
    88
    99    # Note: $] encodes the version number of perl
    10     if ($]>5.008) {
     10    if ($]>=5.010) {
     11    $perl_dir = "perl-5.10";
     12    }
     13    elsif ($]>5.008) {
     14    # perl 5.8.1 or above
     15    $perl_dir = "perl-5.8";
     16    }
     17    elsif ($]>=5.008) {
    1118    # perl 5.8.1 or above
    1219    $perl_dir = "perl-5.8";
  • main/trunk/greenstone2/perllib/buildConfigxml.pm

    r21785 r21822  
    4242
    4343    # Note: $] encodes the version number of perl
    44     if ($]>5.008) {
     44    if ($]>=5.010) {
     45    $perl_dir = "perl-5.10";
     46    }
     47    elsif ($]>5.008) {
    4548    # perl 5.8.1 or above
    4649    $perl_dir = "perl-5.8";
  • main/trunk/greenstone2/perllib/collConfigxml.pm

    r20104 r21822  
    3838
    3939    # Note: $] encodes the version number of perl
    40     if ($]>5.008) {
     40    if ($]>=5.010) {
     41    $perl_dir = "perl-5.10";
     42    }
     43    elsif ($]>5.008) {
    4144    # perl 5.8.1 or above
    4245    $perl_dir = "perl-5.8";
Note: See TracChangeset for help on using the changeset viewer.