Changeset 28194


Ignore:
Timestamp:
08/30/13 17:25:47 (7 years ago)
Author:
davidb
Message:

Changes necessary to move version of subversion used to 1.8.1

Location:
gs2-extensions/subversion/trunk/src/packages
Files:
6 added
4 deleted
4 edited

Legend:

Unmodified
Added
Removed
  • gs2-extensions/subversion/trunk/src/packages/CASCADE-MAKE.sh

    r23376 r28194  
    22
    33
    4 for d in APR SQLITE APRUTIL OPENSSL SERF NEON ZLIB SUBVERSION ; do
     4for d in LIBXML APR SQLITE APRUTIL OPENSSL SERF ZLIB SUBVERSION ; do
    55  echo "    Running CASCADE-MAKE/$d.sh $*"
    66
  • gs2-extensions/subversion/trunk/src/packages/CASCADE-MAKE/SERF.sh

    r23376 r28194  
    22
    33package=serf
    4 version=-0.3.0
     4version=-1.3.1
    55
    66progname=$0
     
    1010prefix=$GEXTSVN_INSTALLED
    1111
    12 export CFLAGS="-fPIC -I$prefix/include $CFLAGS"
    13 export CXXFLAGS="-fPIC -I$prefix/include $CXXFLAGS"
    14 export CPPFLAGS="-fPIC -I$prefix/include $CPPFLAGS"
    15 export LDFLAGS="-L$prefix/lib $LDFLAGS"
     12#export CFLAGS="-fPIC -I$prefix/include $CFLAGS"
     13#export CXXFLAGS="-fPIC -I$prefix/include $CXXFLAGS"
     14#export CPPFLAGS="-fPIC -I$prefix/include $CPPFLAGS"
     15#export LDFLAGS="-L$prefix/lib $LDFLAGS"
    1616
    17 opt_run_untar $force_untar $auto_untar $package $version
    18 opt_run_configure $force_config $auto_config $package $version $prefix
     17opt_run_untar $force_untar $auto_untar $package $version .tar.bz2
     18if [ ! -f $package$version/scons.py ] ; then
     19  /bin/cp scons-local-2.3.0.tar.gz $package$version/. \
     20  && (cd $package$version ; tar xvzf scons-local-2.3.0.tar.gz )
     21fi
    1922
    20 opt_run_make $compile   $package $version
    21 opt_run_make $install   $package $version "install"
    22 opt_run_make $clean     $package $version "clean"
     23#opt_run_configure $force_config $auto_config $package $version $prefix
     24
     25#opt_run_make $compile   $package $version
     26if [ $compile = 1 ] ; then
     27  (cd $package$version ; ./scons.py APR=$prefix APU=$prefix OPENSSL=$prefix PREFIX=$prefix)
     28fi
     29
     30#opt_run_make $install   $package $version "install"
     31if [ $compile = 1 ] ; then
     32  (cd $package$version ; ./scons.py install)
     33fi
     34
     35#opt_run_make $clean     $package $version "clean"
     36if [ $compile = 1 ] ; then
     37  (cd $package$version ; ./scons.py -c)
     38fi
     39
     40
    2341opt_run_make $distclean $package $version "distclean"
    2442
  • gs2-extensions/subversion/trunk/src/packages/CASCADE-MAKE/SQLITE.sh

    r23094 r28194  
    22
    33package=sqlite
    4 version=-3.7.2
     4version=-3.7.17
    55
    66progname=$0
     
    1111
    1212opt_run_untar $force_untar $auto_untar $package $version
    13 opt_run_configure $force_config $auto_config $package $version $prefix
     13opt_run_configure $force_config $auto_config $package $version $prefix --disable-tcl
    1414
    1515opt_run_make $compile   $package $version
  • gs2-extensions/subversion/trunk/src/packages/CASCADE-MAKE/SUBVERSION.sh

    r23376 r28194  
    22
    33package=subversion
    4 version=-1.6.13
     4version=-1.8.1
    55
    66progname=$0
     
    1616
    1717opt_run_untar $force_untar $auto_untar $package $version
    18 opt_run_configure $force_config $auto_config $package $version $prefix --with-sqlite=$prefix
     18opt_run_configure $force_config $auto_config $package $version $prefix \
     19  --with-sqlite=$prefix \
     20  --with-serf=$prefix
    1921
    2022opt_run_make $compile   $package $version
Note: See TracChangeset for help on using the changeset viewer.