Changeset 30197 for gs2-extensions


Ignore:
Timestamp:
09/04/15 17:18:38 (5 years ago)
Author:
davidb
Message:

Added support for Python and CMake

File:
1 edited

Legend:

Unmodified
Added
Removed
  • gs2-extensions/ocr/trunk/lib/cascade-lib.bash

    r16800 r30197  
    114114}
    115115
    116 
    117 opt_run_make()
     116opt_run_setuppy()
    118117{
    119118  local type=$1
     
    128127  if [ $type = "1" ] ; then
    129128    ( cd $package$version ; \
     129      python setup.py $opt_target)
     130
     131    if [ $? != 0 ] ; then
     132        echo "      Error encountered running *setup.py $target* stage of $progname"
     133        exit 1
     134    fi
     135  fi
     136}
     137
     138opt_run_make()
     139{
     140  local type=$1
     141  local package=$2
     142  local version=$3
     143  local opt_target=""
     144
     145  if [ ! -z "$4" ] ; then
     146    opt_target=$4
     147  fi
     148
     149  if [ $type = "1" ] ; then
     150    ( cd $package$version ; \
    130151      make $opt_target)
    131152
     
    137158}
    138159
    139 
     160opt_run_cmake()
     161{
     162  local type=$1
     163  local package=$2
     164  local version=$3
     165  local subdir=$4
     166  local opt_target=""
     167
     168  if [ ! -z "$5" ] ; then
     169    opt_target=$5
     170  fi
     171
     172  if [ $type = "1" ] ; then
     173    ( cd $package$version/$subdir ; \
     174      make $opt_target)
     175
     176    if [ $? != 0 ] ; then
     177        echo "      Error encountered running *make $target* stage of $progname"
     178        exit 1
     179    fi
     180  fi
     181}
    140182
    141183force_untar=0
Note: See TracChangeset for help on using the changeset viewer.