Changeset 34567


Ignore:
Timestamp:
2020-11-25T12:29:32+13:00 (19 months ago)
Author:
anupama
Message:
  1. Trying to produce the static libz.a on Mac Mojave by passing minus-minus-static to the configure command of LIBZ/sh, so that running otool -L on the built and isntalled GS' wvware/wget does not refer to libz*.dylib files that are in the original gnomelib compiled area (which may no longer exist on the machine where it was generated, and which certainly won't exist on machines where GS3 executables like wvware and wget are run). Maybe GS3 Mac binaries worked on previous Mac OS versions with zlib dylibs because those OS came with zlib dylibs in system locations which were found? They're not found in system locations now, so need the static libz.a to be produced. 2. For GS2, compiling up release binary failed on Mojave because zlib 1.2.7 was too old a version. Online discussions about the exact error message recommended zlib v 1.2.11 would get us past the error. This appears to have worked in that compiling a GS2 release binary on Mojave took us past this, but now another error appears to do with new https svn URL: the get ant task bails without a security certificate.
Location:
gs2-extensions/gnome-lib/branches/macos-dev/src/packages
Files:
1 added
1 edited

Legend:

Unmodified
Added
Removed
  • gs2-extensions/gnome-lib/branches/macos-dev/src/packages/CASCADE-MAKE/LIBZ.sh

    r26761 r34567  
    22
    33package=zlib
    4 version=-1.2.7
     4version=-1.2.11
    55
    66progname=$0
     
    3333    echo "[pushd $package$version]"
    3434    ( cd $package$version ; \
    35       echo $CROSSCONFIGURE_VARS ./configure --prefix="$prefix" $CROSSCONFIGURE_ARGS $@ ; \
    36       eval $CROSSCONFIGURE_VARS ./configure --prefix="$prefix" $CROSSCONFIGURE_ARGS $@ )
     35      echo $CROSSCONFIGURE_VARS ./configure --static --prefix="$prefix" $CROSSCONFIGURE_ARGS $@ ; \
     36      eval $CROSSCONFIGURE_VARS ./configure --static --prefix="$prefix" $CROSSCONFIGURE_ARGS $@ )
    3737    if [ $? != 0 ] ; then
    3838        echo "      Error encountered running *configure* stage of $progname"
Note: See TracChangeset for help on using the changeset viewer.