source: gs2-extensions/gnome-lib/trunk

Revision Log Mode:


Legend:

Added
Modified
Copied or renamed
Diff Rev Age Author Log Message
(edit) @35810   5 months kjdon on research-internal gnome-lib didn't compile with a -fPIC error. …
(edit) @35660   7 months davidb svn URLs updated from http to https
(edit) @35074   13 months anupama Re-generated the gnome-lib tarballs for 32bit linux on linux32 LSB …
(edit) @35073   13 months anupama the new gnome-lib build requires -march=i686r added to CFLAGS for …
(edit) @34983   14 months anupama Merging the gnome-lib branch macos-dev at …
(edit) @34982   14 months anupama Re-generated the gnome-lib-minimal and gnome-lib tarballs for x64 on …
(edit) @34981   14 months anupama svn externals to grab cascade-make failed in lsb environment, because …
(edit) @34600   17 months kjdon Anu asked me to remake the 32 bit linux gnomelib minimal. So I did. …
(edit) @34598   17 months anupama Corrected exterm (meant to be x-term) to terminal
(edit) @34597   17 months anupama Correction and additions for clarification for readers other than myself.
(edit) @34566   18 months anupama Redid the gnome-lib-minimal for Mojave from Dr Bainbridge's gnome-lib …
(edit) @34553   18 months ak19 gnome-lib-minimal for Mojave redone after fixes by Dr Bainbridge on …
(edit) @34549   18 months ak19 Correcting instructions for compiling up a single package in gnomelib.
(edit) @34548   18 months ak19 Tried to redo the gnome-lib-minimal for generating GS2 on Mojave Mac, …
(edit) @33819   2 years davidb Moved to newer version of intltool. This still had a problem with …
(edit) @33818   2 years davidb Changed #include statement in gio/gdbusmessage.c to work with Ubuntu 18
(edit) @32974   3 years sjm84 Rebuilt lin64 version of gnome-lib-min tarball after the recent …
(edit) @32972   3 years ak19 Experimental change to see if generating libpng.a without libpng.so …
(edit) @32936   3 years sjm84 Some minor adjustments to the instructions
(edit) @32935   3 years sjm84 Recommitting one more time.
(edit) @32934   3 years sjm84 Recommitting just in case something was wrong with the previous tarball.
(edit) @32933   3 years ak19 Explicitly detailing some further instructions on compiling up gnome-lib.
(edit) @32887   3 years davidb Change to ./configure setting to avoid compliation error in glib
(edit) @31437   5 years sjm84 Recompiled gnome-lib-minimal for 64 bit linux in the LSB environment …
(edit) @31436   5 years ak19 Related to previous commits. Experimenting to get diffcol gs2 checkout …
(edit) @31435   5 years ak19 Redoing previous commit (made changes to wrong file). Related to …
(edit) @31434   5 years ak19 Related to previous commit. Experimenting to get diffcol gs2 checkout …
(edit) @31433   5 years ak19 Experimenting to get diffcol gs2 checkout on 64 bit linux to work …
(edit) @31163   5 years ak19 Experimenting to get GS2-caveat to work on El Capitan laptop. …
(edit) @31160   5 years ak19 Recommitting for previous aim from rev 31154, this time with …
(edit) @31159   5 years ak19 I think LIBXSLT is dependent on LIBXML rather than the other way …
(edit) @31158   5 years ak19 When recommitting the file with the right permissions, had …
(edit) @31157   5 years ak19 Adding in LIBXSLT to compile pipeline for darwin v. 11 (El Cap) too.
(edit) @31156   5 years ak19 Attempting to remove and then include again with exec permissions.
(edit) @31155   5 years ak19 Attempting to remove and then include again with exec permissions.
(edit) @31154   5 years ak19 Experimenting to fix failrue to compile nightly gs2 binary (caveat) …
(edit) @31153   5 years ak19 Experimenting: Adding in new package libxslt, to overcome that GS2 …
(edit) @31087   6 years sjm84 Trying once again. This gnome-lib minimal was compiled within a fresh …
(edit) @31084   6 years sjm84 Some instructions are no longer required, indicating that they're …
(edit) @31083   6 years sjm84 Regenerated gnome-lib-minimal on 64 bit linux lsb, with CFLAGS set to …
(edit) @31037   6 years ak19 Recreating gnome-lib minimal for 32 bit linux in 32 bit lsb environment.
(edit) @31032   6 years sjm84 Recompiled gnome-lib-minimal in lsb 64 bit environment.
(edit) @31031   6 years ak19 Still had to update the linux 32 bit gnome-lib minimal after the …
(edit) @30965   6 years ak19 Further clarification
(edit) @30964   6 years ak19 Clarification in README
(edit) @30963   6 years ak19 Updated gnome-lib-minimal for 64 bit linux after the changes to …
(edit) @30892   6 years ak19 Undoing yesterday's commit. Removing libz's dylib files to leave just …
(edit) @30888   6 years ak19 Committing ElCap version of gnome-lib-minimal without the dylib …
(edit) @30887   6 years ak19 Updating gnome-lib-minimal tar gz for Mountain Lion after recent …
(edit) @30882   6 years ak19 Committing modified gnome-lib-minimal tar gz file for ElCapitan. If …
(edit) @30881   6 years ak19 Adding in disable-shared and enable-static flags to the configure step …
(edit) @30873   6 years ak19 Making some instructions more explicit.
(edit) @30872   6 years ak19 Updated the gnome-lib-minimal.tar.gz for ElCapitan Mac to incorporate …
(edit) @30862   6 years ak19 Changes to get libiconv issues on MacOS El Capitan straightened out, …
(edit) @30804   6 years ak19 Correcting spelling error. Need to adjust the reference in Dr …
(edit) @30756   6 years davidb Moving to a newer version to get beyond a compilation error message on …
(edit) @30746   6 years davidb Version compiled up on El Capitain laptop
(edit) @30467   6 years ak19 Dr Bainbridge fixed gnome-lib compilation on Yosemite by updating …
(edit) @29344   8 years ak19 Dr Bainbridge got gnome-lib compiling again on the Ubuntu that runs …
(edit) @28828   8 years ak19 CUPS.sh needs disable-gssapi in order to compile CUPS on Mac Maverick …
(edit) @28573   9 years ak19 Removed the *.la files (in the OS/lib folder) since this causes …
(edit) @28569   9 years ak19 Dr Bainbridge fixed the bug that was preventing compilation of wvware …
(edit) @28326   9 years ak19 Mac 11/12 (Lion/Mountain Lion) need CUPS. Mac 9/10 (Leopard, Snow …
(edit) @28322   9 years ak19 Dr Bainbridge had earlier added in sourcing of imagemagick's …
(edit) @28313   9 years ak19 Fixed two more instances of misplaced dot-slash in the recent commits …
(edit) @28306   9 years ak19 Fixing typing errors in previous commit
(edit) @28305   9 years ak19 More cases of needing to source a script using source dot-slash-script
(edit) @28304   9 years ak19 More cases of needing to source a script using source dot-slash-script
(edit) @28303   9 years ak19 Dr Bainbridge fixed a crucial problem in the gnomelib devel.bash file, …
(edit) @28300   9 years ak19 Rename/move operation.
(edit) @28298   9 years ak19 Adding a README for compiling and using the gnome-lib package, and …
(edit) @28294   9 years ak19 Used the new makeminimal CASCADE-MAKE command to regenerate the …
(edit) @28293   9 years ak19 Adding in the makeminimal command for gnomelib, to produce the minimal …
(edit) @28291   9 years ak19 Adding in the gnome-lib-minimal archive for Lion/Mountain lions.
(edit) @28286   9 years ak19 On the latest Mac we found that gnome-lib failed to compile properly …
(edit) @27633   9 years sjm84 Under linux, test for linux/magic.h causes a compilation error on …
(edit) @27225   9 years ak19 Adding a README file tracking the changes made to various packages to …
(edit) @27224   9 years ak19 Replaced by gs-libxml2-2.9.0.tar.gz
(edit) @27223   9 years ak19 Replaced by gs-glib-2.28.1.tar.gz
(edit) @27219   9 years ak19 gs-glib package needs to extract as gs-glib not as glib, same as the …
(edit) @27217   9 years ak19 The unpacked glib and libxml packages are expected to have the gs- …
(edit) @27198   9 years ak19 If a source code version of imagemagick exists in the gs2build ext …
(edit) @27197   9 years ak19 Needed to make changes to 2 packages to get gnome-lib src code to …
(edit) @26823   9 years davidb Further patch needed for dbus
(edit) @26814   9 years davidb More careful selection of packages, as needed by various cross-compilers
(edit) @26813   9 years davidb Adjustments to help compilation with Android NDK
(edit) @26812   9 years davidb Tweaks needed for compiling with Android NDK
(edit) @26811   9 years davidb dbus used/needed by Android compile of glib
(edit) @26810   9 years davidb dbus used/needed by Android compile of glib
(edit) @26807   9 years davidb Helpful script to reset cross-compilation
(edit) @26790   9 years davidb Config update needed by Android NDK now in a separate file
(edit) @26788   9 years davidb Cascade make can now patch files if needed
(edit) @26787   9 years davidb Files that patch code fro Android NDK
(edit) @26786   9 years davidb Changes for Android NDK
(edit) @26785   9 years davidb Newer version to help with compilation with Android NDK
(edit) @26784   9 years davidb Commented out line added for future proofing of using a newer glib tar file
(edit) @26783   9 years davidb Changes that resulted from testing under Android NDK
(edit) @26782   9 years davidb Change to newer version resulting from Android NDK testing
(edit) @26781   9 years davidb New package that newer versions of glib depends on
(edit) @26764   9 years davidb Cross compile script initial developed for mingw on Linux. In the …
Note: See TracRevisionLog for help on using the revision log.