Opened 14 years ago

Closed 13 years ago

#264 closed task (wontfix)

GS3 Java 1.4 minimum requirement should be 1.5

Reported by: dmn Owned by: kjdon
Priority: moderate Milestone: 3.05 Release
Component: Greenstone3 Runtime Severity: minor
Keywords: Cc:

Description

In build.xml we have

<fail if="java.too.old" message="You need Java 1.4 or greater to run Greenstone 3"/>

http://trac.greenstone.org/browser/greenstone3/trunk/build.xml#L381

however, in the Tomcat release notes it says:

"Tomcat 5.5 is designed to run on J2SE 5.0 and later and requires configuration to run on J2SE 1.4."

http://mirror.fslutd.org/apache/tomcat/tomcat-5/v5.5.26/RELEASE-NOTES

Surely we should enforce this guidance?

Change History (7)

comment:1 by dmn, 14 years ago

Owner: changed from nobody to kjdon

comment:2 by dmn, 13 years ago

Milestone: Release 3.04Release 3.05
Severity: blocker

this is related to JavaScript processing of metadata:

http://trac.greenstone.org/ticket/290

is Rhino in Java written using 1.5 constructs?

http://www.mozilla.org/rhino/

comment:3 by dmn, 13 years ago

Type: defecttask

comment:4 by dmn, 13 years ago

for reference, the version release dates are:

J2SE 1.4 (February 6, 2002) J2SE 5.0 (September 30, 2004) Java SE 6 (December 11, 2006)

http://en.wikipedia.org/wiki/Java_version_history

comment:5 by dmn, 13 years ago

Severity: blockerminor

comment:6 by dmn, 13 years ago

Also, if we want to do Greenstone + Fedora then Fedora's min. requirement is 1.5:

http://www.fedora.info/download/2.2.1/userdocs/distribution/installation.html

"Whether installing a binary or source distribution, JDK 5.0 is required. The JDK should be installed on the machine you intend to use as the Fedora server." Fedora 2.2.1

comment:7 by dmn, 13 years ago

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.