Opened 16 years ago

Closed 16 years ago

#264 closed task (wontfix)

GS3 Java 1.4 minimum requirement should be 1.5

Reported by: dmn Owned by: kjdon
Priority: moderate Milestone: 3.05 Release
Component: Greenstone3 Runtime Severity: minor
Keywords: Cc:


In build.xml we have

<fail if="java.too.old" message="You need Java 1.4 or greater to run Greenstone 3"/>

however, in the Tomcat release notes it says:

"Tomcat 5.5 is designed to run on J2SE 5.0 and later and requires configuration to run on J2SE 1.4."

Surely we should enforce this guidance?

Change History (7)

comment:1 by dmn, 16 years ago

Owner: changed from nobody to kjdon

comment:2 by dmn, 16 years ago

Milestone: Release 3.04Release 3.05
Severity: blocker

this is related to JavaScript processing of metadata:

is Rhino in Java written using 1.5 constructs?

comment:3 by dmn, 16 years ago

Type: defecttask

comment:4 by dmn, 16 years ago

for reference, the version release dates are:

J2SE 1.4 (February 6, 2002) J2SE 5.0 (September 30, 2004) Java SE 6 (December 11, 2006)

comment:5 by dmn, 16 years ago

Severity: blockerminor

comment:6 by dmn, 16 years ago

Also, if we want to do Greenstone + Fedora then Fedora's min. requirement is 1.5:

"Whether installing a binary or source distribution, JDK 5.0 is required. The JDK should be installed on the machine you intend to use as the Fedora server." Fedora 2.2.1

comment:7 by dmn, 16 years ago

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.