Opened 13 years ago

Closed 11 years ago

#377 closed defect (fixed)

mgpp incremental build

Reported by: kjdon Owned by: kjdon
Priority: low Milestone: 2.84 Release
Component: Collection Building Severity: minor
Keywords: Cc:

Description

Just tried incremental build with mgpp.

Did buildcol.pl, then buildcol.pl -incremental.

Nothing new added, so should get the same result.

The text and indexes get overwritten, so they are ok.

But, all docs are reconstructed from the database, then all the docs in the archives are added. AZList copes cos it complains that each doc is being reclassified, and doesn't add it again. but the oai list has each doc twice, and generic list ends up with each doc in 4 times under the same metadata instead of just once.

numbytes, numsections, numdocs are all double in build.cfg

Not so important, but should be fixed at some stage.

Change History (3)

comment:1 by kjdon, 11 years ago

Milestone: 2.84 Release
Owner: changed from nobody to kjdon
Status: newassigned

Have I fixed this? test.

comment:2 by kjdon, 11 years ago

see also #631.

I think we changed it so that if you are using mg/mgpp you can't do incremental build.

comment:3 by kjdon, 11 years ago

Resolution: fixed
Status: assignedclosed

Yes, now if you try to do incremental build with mgpp collection, it says you can't do it and reverts to -removeold.

Note: See TracTickets for help on using tickets.