Opened 12 years ago

Closed 12 years ago

#472 closed defect (worksforme)

problem on shearching with UTF-8 code

Reported by: aminhjz Owned by: nobody
Priority: high Milestone: Greenstone 3 wishlist
Component: Greenstone3 Runtime Severity: critical
Keywords: Cc:

Description

while searching any term regardles of the indexer the term searched is not the term typed in the search box this problem ocurred resently while updating greenstone 3 to the new svn trunk version

Change History (3)

comment:1 by aminhjz, 12 years ago

just test by typeing in some of these wordes in the search box تست آزمایش

comment:2 by kjdon, 12 years ago

Have just emailed Amin about this:

"I just tried this by copying and pasting the characters you provided into a search box. Obviously it didn't find anything, but the word count was showing words that to me looked like what I had copied in.

If you are still interested in this, can you please try it again with a fresh checkout of greenstone. Do you still get your problem? When entering characters are they utf-8? Do you get the right result if you copy and paste from a web page?

I would like to try and fix it if it is still a problem."

comment:3 by kjdon, 12 years ago

Resolution: worksforme
Status: newclosed

I have just tried searching for arabic and its working. Didn't hear back from Amin, so will assume that its ok now.

Note: See TracTickets for help on using tickets.