Opened 9 months ago

Last modified 9 months ago

#961 assigned task

Moving to bundling JRE8, compiling releases with JDK8 & ant 1.9.4

Reported by: anupama Owned by: anupama
Priority: moderate Milestone:
Component: Greenstone2&3 Severity: major
Keywords: Cc:

Description (last modified by anupama)

By Sep 29 2021,

  • Previously, we bundled JRE7u72, we've now moved to JRE8u301.
  • Release-kits are now uniformly compiled with JDK 8u301 and ant 1.9.4 across all release machines.
  • We're now turning on the checkout.gnomelib.ext build property by default. In order for the original behaviour to continue on release-kits, which turns on its own use.gnomelib.ext, the release kits' rk3 compile.xml script has now been updated to turn checkout.gnomelib.ext off.

Regular GS3 build.xml now only does checkount.gnomelib.ext related steps (checking out from SVN, compiling and/or setting compile flags) if the OS is not windows.

  • Previously, release-kits compiled on different release machines had different JDKs installed that the releases were compiled with:
  • Windows with JDK 7u55
  • Mojave Mac with JDK 7u80
  • Linux 32 and 64 bit machines with JDK 6u22 (7u80 present but was not used by envi)
  • All release machines now set up to use ant 1.9.4

Dr Bainbridge needed release kits to be updated to 1.8.2

Previously:

  • Linux 32 and 64 bit release machines used ant 1.8.1
  • Mojave Mac release-kits used ant 1.8.3
  • Windows release-kits used ant 1.9.4

The latest version at the time of testing was ant 1.9.13, but when tested on the linux 64 bit release machine, this caused the release-kit to instantly fail with a non-transparent error saying a release-kit xml build file didn't exist that did exist. Since 1.9.4 had been successfully building releases on Windows, this was now used and successfully tested to work on the other release machines.

Change History (1)

comment:1 by anupama, 9 months ago

Description: modified (diff)
Type: defecttask
Note: See TracTickets for help on using tickets.