Changeset 18634 for gli

Show
Ignore:
Timestamp:
06.03.2009 15:25:11 (11 years ago)
Author:
oranfry
Message:

make sure gli.sh is run with bash not sh or other interpretters, and took out erroneous brackets from function definitions

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • gli/trunk/gli.sh

    r17819 r18634  
    1 #!/bin/sh 
     1#!/bin/bash 
    22 
    33# Function that, when given gsdlpath as parameter, will return the 
    44# version of greenstone that is to run (2 or 3). If things are not, 
    55# this program will exit here. 
    6 get_version() { 
     6get_version { 
    77    # first parameter is value of gsdlpath 
    88    if [ -f "${1}/gs3-setup.sh" ]; then 
     
    2222# and checks the installation.  
    2323# If things are not right, this program will exit here. 
    24 check_installation() { 
     24check_installation { 
    2525# Check that the Greenstone installation looks OK 
    2626    if [ "$3" = "es" ]; then