Changeset 22195

Show
Ignore:
Timestamp:
28.05.2010 17:12:18 (9 years ago)
Author:
davidb
Message:

fixing up .la files only needs to be done if crosscompiling

Location:
gs2-extensions/music-stand/trunk/runtime-srcpack/packages/CASCADE-MAKE
Files:
2 modified

Legend:

Unmodified
Added
Removed
  • gs2-extensions/music-stand/trunk/runtime-srcpack/packages/CASCADE-MAKE/EVINCE.sh

    r22150 r22195  
    22 
    33package=evince 
    4 version=-2.24.2 
     4version=-2.24.2-MUSICSTAND 
    55 
    66progname=$0 
     
    3434opt_run_make $install   $package $version "install" 
    3535 
    36 if [ $install = "1" ] ; then 
    37   pushd $prefix/lib ;  
    38   for f in libdocument.la libpdf; do 
    39     sed -i~ -e "s; /usr/lib/; /usr/local/poky/eabi-glibc/arm/arm-poky-linux-gnueabi/usr/lib/;g" $f 
    40   done 
    41   popd; 
     36if [ ! -z $CROSSCOMPILE ] ; then 
     37    if [ $install = "1" ] ; then 
     38      pushd $prefix/lib ;  
     39      for f in libdocument.la libpdf; do 
     40        sed -i~ -e "s; /usr/lib/; /usr/local/poky/eabi-glibc/arm/arm-poky-linux-gnueabi/usr/lib/;g" $f 
     41      done 
     42      popd; 
     43    fi 
    4244fi 
    4345 
  • gs2-extensions/music-stand/trunk/runtime-srcpack/packages/CASCADE-MAKE/LIB-POPPLER.sh

    r22150 r22195  
    2626opt_run_make $install   $package $version "install" 
    2727 
    28 if [ $install = "1" ] ; then 
    29   pushd $prefix/lib ;  
    30   for f in libpoppler-glib.la libpoppler.la ; do 
    31     sed -i~ -e "s; /usr/lib/; /usr/local/poky/eabi-glibc/arm/arm-poky-linux-gnueabi/usr/lib/;g" $f 
    32   done 
    33   popd; 
     28if [ ! -z $CROSSCOMPILE ] ; then 
     29    if [ $install = "1" ] ; then 
     30    pushd $prefix/lib ;  
     31      for f in libpoppler-glib.la libpoppler.la ; do 
     32        sed -i~ -e "s; /usr/lib/; /usr/local/poky/eabi-glibc/arm/arm-poky-linux-gnueabi/usr/lib/;g" $f 
     33      done 
     34      popd; 
     35    fi 
    3436fi 
    3537