Show
Ignore:
Timestamp:
21.07.2010 13:33:08 (9 years ago)
Author:
sjm84
Message:

Modified the script that adds the different versions of XML-Parser so that it only adds the versions that the release-kit system does not already have

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/release-kits/kits/rk2/ant-scripts/compile.xml

    r22447 r22461  
    4747            <delete dir="${basedir}/compiled/gems.app"/> 
    4848            <delete dir="${basedir}/compiled/gs2-server.app"/> 
     49            <delete dir="${basedir}/compiled/gli.app"/> 
    4950        </if> 
    5051         
     
    111112            </if> 
    112113             
     114            <rsr> 
     115                <fileset dir="${basedir}/compiled/runtime-src/packages/apache-httpd/httpd-2.2.11" includes="*.mak,srclib/**/*.mak,support/**/*.mak"/> 
     116                <job pattern="/MD" replacement="/MT"/> 
     117            </rsr> 
     118             
    113119            <!-- compile c code --> 
    114120            <exec dir="${basedir}/compiled" executable="nmake"><arg value="/f"/><arg value="win32.mak"/><arg value="clean"/></exec> 
     
    176182        </if> 
    177183         
    178         <!-- insert an xml parser --> 
     184        <!-- insert the necessary additional xml parser versions--> 
    179185        <if><bool><equals arg1="${rk.os}" arg2="linux"/></bool> 
    180             <copy todir="compiled/perllib/cpan"> 
    181                 <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="**/*"/> 
    182             </copy> 
     186            <!-- Add the 5.6 version if necessary --> 
     187            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.6"/></not></bool> 
     188                <copy todir="${basedir}/compiled/perllib/cpan"> 
     189                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.6,perl-5.6/**/*"/> 
     190                </copy> 
     191            </if> 
     192             
     193            <!-- Add the 5.8 version if necessary --> 
     194            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.8"/></not></bool> 
     195                <copy todir="${basedir}/compiled/perllib/cpan"> 
     196                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.8,perl-5.8/**/*"/> 
     197                </copy> 
     198            </if> 
     199             
     200            <!-- Add the 5.10 version if necessary --> 
     201            <if><bool><not><available file="${basedir}/compiled/perllib/cpan/perl-5.10"/></not></bool> 
     202                <copy todir="${basedir}/compiled/perllib/cpan"> 
     203                    <fileset dir="${rk.home}/shared/linux/XML-Parser" includes="perl-5.10,perl-5.10/**/*"/> 
     204                </copy> 
     205            </if> 
    183206        </if> 
    184207