Changeset 27390

Show
Ignore:
Timestamp:
22.05.2013 17:01:58 (6 years ago)
Author:
ak19
Message:

Authentication hasn't been implemented for GS3 when using metadata-server.pl. Since the authentication_enabled flag is always on now (since authentication has been implemented now for GS2), need to now return immediately from baseaction::authenticate_user() for GS3.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/greenstone2/perllib/cgiactions/baseaction.pm

    r27366 r27390  
    226226{ 
    227227    my $self = shift @_; 
     228 
     229    my $gsdl_cgi = $self->{'gsdl_cgi'}; 
     230 
     231    # For now, we don't authenticate for GS3 as this still needs to be implemented for it. 
     232    if($gsdl_cgi->greenstone_version() == 3) {  
     233    $gsdl_cgi->generate_message("**** To do: still need to authenticate for GS3."); 
     234    return; 
     235    }    
     236 
    228237    my $username = shift(@_); 
    229238    my $collection = shift(@_); 
     
    231240    my $keydecay = 1800; # 30 mins same as in runtime-src/recpt/authentication.cpp 
    232241 
    233     my $gsdl_cgi = $self->{'gsdl_cgi'}; 
    234242 
    235243    # Remove the pw argument (since this can mess up other scripts)