Changeset 27797 for main

Show
Ignore:
Timestamp:
10.07.2013 16:32:48 (6 years ago)
Author:
ak19
Message:

Moving from apache ant 1.8.0 to 1.8.2 since the latter is needed by activate.pl to run an ant command on the GS3 build.xml file to find out the GS3 library url. Using ant version 1.8.0 caused the online GS3 metadata editor to throw errors when trying to buildAndActivate a collection after updating metadata on Windows, where the call to build.xml further opened an extra console.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/release-kits/kits/rk3/ant-scripts/compile.xml

    r27778 r27797  
    111111 
    112112        <!-- insert ant --> 
     113        <property name="insert.ant.version" value="1.8.2"/> 
    113114        <mkdir dir="compiled/packages"/> 
    114         <get src="http://www.greenstone.org/gs3files/apache-ant-1.8.0-bin.tar.gz" dest="compiled/packages/apache-ant-1.8.0-bin.tar.gz"/> 
    115         <untar src="compiled/packages/apache-ant-1.8.0-bin.tar.gz" dest="compiled/packages/" compression="gzip"/> 
    116         <move file="compiled/packages/apache-ant-1.8.0" tofile="compiled/packages/ant"/> 
    117         <delete file="compiled/packages/apache-ant-1.8.0-bin.tar.gz"/> 
     115        <get src="http://www.greenstone.org/gs3files/apache-ant-${insert.ant.version}-bin.tar.gz" dest="compiled/packages/apache-ant-${insert.ant.version}-bin.tar.gz"/> 
     116        <untar src="compiled/packages/apache-ant-${insert.ant.version}-bin.tar.gz" dest="compiled/packages/" compression="gzip"/> 
     117        <move file="compiled/packages/apache-ant-${insert.ant.version}" tofile="compiled/packages/ant"/> 
     118        <delete file="compiled/packages/apache-ant-${insert.ant.version}-bin.tar.gz"/> 
    118119 
    119120        <!-- put the uninstaller in place -->