Changeset 31969

Show
Ignore:
Timestamp:
14.09.2017 20:07:12 (3 months ago)
Author:
ak19
Message:

Found the location where libsqlite3.dylib was included by the release kit in the Mac binary. Modified the code to start making exceptions from Maverick onwards (Yosemite, El Capitan), which is Mac version 10.9 and onwards, so that these versions don't end up with this incompatible dylib that we generate and which prevents gli from launching sucessfully on a Mac where setup.bash is not already sourced. Instead, for these later versions of mac where we don't include our own dylib for sqlite3, we let it find the system version.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • main/trunk/release-kits/kits/rk2/ant-scripts/compile.xml

    r31165 r31969  
    245245            </exec> 
    246246             
    247             <copy todir="${basedir}/compiled/lib/${os.shell}"> 
    248                 <fileset dir="${basedir}/compiled/common-src/packages/sqlite/lib" includes="*.dylib"/> 
    249             </copy>  
     247            <!-- the libsqlite3.dylib is no longer compatible with Macs from Maverick/Yosemite/El Capitan onwards, so 10.9, 10.10, 10.11,  
     248                 but also future versions of darwin, like anything that is version 11+, so major version numbers that are 2 digits or beyond) --> 
     249            <if><bool> 
     250                <and> 
     251                  <contains string="${os.shell}" substring="darwin" casesensitive="false"/> 
     252                  <not><matches pattern="^(10\.9|10\.[1-9][0-9]|1[1-9]|[2-9][0-9])" string="${os.version}"/></not><!--all darwin before Maverick/10.9--> 
     253                </and>               
     254              </bool> 
     255              <copy todir="${basedir}/compiled/lib/${os.shell}"> 
     256                <fileset dir="${basedir}/compiled/common-src/packages/sqlite/lib" includes="*.dylib"/> 
     257              </copy> 
     258            </if> 
     259 
    250260        </if> 
    251261