Ticket #430 (closed defect: fixed)

Opened 11 years ago

Last modified 9 years ago

check wvWare version - can we ship newer version (1.2.4)

Reported by: dmn Owned by: max
Priority: high Milestone: 2.84 Release
Component: Collection Building Severity: critical
Keywords: Cc:

Description (last modified by kjdon) (diff)

in the mailing list:

"An issue that has bugged me for a while is now resolved - simply enough, I must add, but I wonder if people in the GS Team could take a note of this please, if they have not already done so for 2.81. It concerns the version of wvWare that comes with 2.80, and which handles conversion of MS files, particularly Word. It is an older version, and while wvWare has remained somewhat static for a few years, there is a newer version 1.2.4 which works better than the one shipped with GS 2.80. Could this newer version be included, please, in upgrades of GS? I realise that the issue is less important for Windows users, who can overcome problems by using Windows scripting, but in my case, using Ubuntu 8.10 and GS 2.80, MSWord files were simply not being converted to html as they should be, and I was left with hieroglyphics instead of readable text. By replacing the wvWare file in the gsdl/bin/linux folder (that was sufficient, nothing else needed) with the 1.2.4 version I resolved the problem. It also seems to have resolved a similar problem I was having with ppt files. I might add, for anyone using Linux, that I had to download a few lib file dependencies to compile wvWare, and that kept me a bit preoccupied for a while until I succeeded, but that's by the way."

see also #667

Change History

Changed 11 years ago by oranfry

  • owner changed from oranfry to max

Changed 10 years ago by kjdon

  • milestone changed from Next Release (2 or 3) to Release 2.82

Changed 9 years ago by kjdon

  • description modified (diff)
  • milestone changed from Greenstone 2 wishlist to 2.84 Release

Changed 9 years ago by kjdon

Notes from an old ticket:

Upgrade to a newer version of wv -- but very carefully! (Newer versions have been reported to be less portable, so they should be tested on as many platforms as possible). Doug Carter (dcarter@…) has reported that wv 1.0.2 is quite stable, but it is tricky to compile it statically.

Changed 9 years ago by kjdon

  • description modified (diff)

Changed 9 years ago by mdewsnip

  • status changed from new to closed
  • resolution set to fixed

- Added build-src/packages/wv/wv-1.2.4-gs.tar.gz, a slightly modified version of wv-1.2.4.tar.gz (as downloaded from sourceforge) that only installs the stuff Greenstone needs. This is basically a drop-in replacement for wv-0.7.1-gs.tar.gz, although the new version has different library dependencies (now requires libgsf, no longer seems to use iconv).

- Changed build-src/packages/configure to unpack the new version of wv (wv-1.2.4-gs.tar.gz) instead of the old version (wv-0.7.1-gs.tar.gz).

- Updated etc/packages/wv/wvHtml.xml for the new 1.2.4 version of wv.

- The Windows wvWare.exe binary already seems to be version 1.2.4, so this doesn't need changing.

I'm not sure how portable the new version is -- the issue will be the libgsf library (it's not clear how standard this is -- it's part of GNOME). I've left the wv-0.7.1-gs.tar.gz file in SVN, and it is easy to revert back to the old version: just change the wv tar.gz filename in build-src/packages/configure, and revert back to the previous version of etc/packages/wv/wvHtml.xml.

Note: See TracTickets for help on using tickets.