Ticket #858 (new defect)

Opened 5 years ago

Last modified 5 years ago

Many things to do for GS3 and after GS2 release

Reported by: ak19 Owned by: nobody
Priority: moderate Milestone: 3.09 Release
Component: Greenstone2&3 Severity: major
Keywords: Cc:

Description

GS3 windows BINARY: setting metadata fails (not in svn version). Probably because activate.pl doesn't have the necessary supporting perl files in the cut-down version of perl that comes with the windows binary.

GS3 Mac: activate.pl first call to special http/lwp functions fails. Need to investigate what perl files mac needs to get this to work.

GS3 Mac: libjni error prevents using mg/mgpp and gdbm for collections. These may not have been compiled up well because the version of Java it finds is not what it needs to be.

* GS3 user comments feature

* GS3: need to be able to move GS3 installation folder, and everything should still work.

* downloadfrom.pl is printing a fixed list (when called from GLI?) It ought to dynamically work out what it should print, like pluginfo.pl's -listall does. Perhaps GLI isn't calling existing functionality to dynamically download the information for the listing.

* need more harddisk space on 64 bit VM.

Change History

Changed 5 years ago by ak19

The item "GS3: need to be able to move GS3 installation folder, and everything should still work."

It appears to already work. I tested it by copying a gs3-svn into gs3-svn-moved and moving the old one out of the way (as orig-gs3-svn).

Next, I checked that the gs3-server still ran in the gs3-svn-moved installation. Server starting and stopping both worked. Checked that, with the gs3-server window running, the existing demo collection's documents still displayed, and could be searched and browsed.

Then I ran GLI successfully, built a new collection, previewed, searched and browsed it.

Changed 5 years ago by ak19

  • milestone set to 3.06 Release
Note: See TracTickets for help on using tickets.