Ticket #414 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

GS3 Standard Servlet does not show any content for Title Classifier docs

Reported by: ak19 Owned by: nobody
Priority: high Milestone: 3.04 Release
Component: Greenstone3 Runtime Severity: major
Keywords: servlet Cc:

Description

The following is the case when using the STANDARD Library servlet in GS3. Things are fine when using the DEFAULT Library servlet to view collections in the browser.

When viewing a new GS3 collection in the browser (normal database file or txtgz database file), and going straight to the Titles classifier and trying to access an document item in this, nothing displays.

However, if we now went to the Filenames classifier, the document items can be viewed. Going back to the Titles classifier, the docs are viewable too.

If the first classifier we viewed after building the collection had been Filenames, the docs *were* visible.

Following combinations (and order of classifiers when designing in GLI) fail, where T is the Titles classifier, F is the filenames classifier and HT is a hierarchical classifier on Titles (AZCompactList). An X in front means that classifier failed:

1. X T AZList

F AZList

2. F

X T

3. T

X F

HT

4. F

X T

HT

5. F

T

T

6. X T

F

T

Change History

Changed 10 years ago by ak19

  • status changed from new to closed
  • resolution set to fixed

I don't know who fixed it, but I just tested the above combinations (Design of classifiers, order in which they are organised, order in which they are tested/browse buttons are clicked) and it all seems to work fine for the GS3 Standard Servlet, as well as its Default Servlet. The tests use the more recent gdbm database that's been customised for GS rather than the txt.gz variants. Am unable to reproduce any problems. Closing this ticket.

Note: See TracTickets for help on using tickets.